INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
PT100 Messverstärkerschaltung
15.07.2016, 07:58
Beitrag #1
PT100 Messverstärkerschaltung
Hallo ihr Lieben,

ich bin gerade dabei eine Schaltung+Programmierung für eine Temperaturgeregelte Heizplatte zu erstellen.
Als Messfühler habe ich mich für den PT100 entschieden.
Folgende Schaltung habe ich aus dem Internet entnommen:
[Bild: Schaltung.jpg]

Nun habe ich die Schaltung aufgebaut und an den Arduino angeschlossen. Mein Problem ist, dass der ADC immer 1023 anzeigt. Also es verändert sich nichts.
Wisst ihr woran das liegen könnte? Huh

LG
Jessi
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.07.2016, 08:13
Beitrag #2
RE: PT100 Messverstärkerschaltung
(15.07.2016 07:58)Jessi97 schrieb:  ich bin gerade dabei eine Schaltung+Programmierung für eine Temperaturgeregelte Heizplatte zu erstellen.
Als Messfühler habe ich mich für den PT100 entschieden.
Folgende Schaltung habe ich aus dem Internet entnommen:

Nun habe ich die Schaltung aufgebaut und an den Arduino angeschlossen. Mein Problem ist, dass der ADC immer 1023 anzeigt. Also es verändert sich nichts.
Wisst ihr woran das liegen könnte? Huh

Da in der Schaltung nicht alle Werte angegeben sind, kann man nicht wirklich viel dazu sagen.

Warum nimmst du nicht einen fertigen/Bausatz Messverstärker?

Hier findest du einen preiswerten: Messverstärker

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.07.2016, 11:14
Beitrag #3
RE: PT100 Messverstärkerschaltung
(15.07.2016 07:58)Jessi97 schrieb:  ...

Nun habe ich die Schaltung aufgebaut und an den Arduino angeschlossen. Mein Problem ist, dass der ADC immer 1023 anzeigt. Also es verändert sich nichts.
Wisst ihr woran das liegen könnte? Huh

LG
Jessi

Hi,
nun die Schaltung ist im Prinzip in Ordnung, nur einen LM317 sollte man auch da einsetzen wo er hingehört...nämlich zur Spannunsstabilisierung weil in dem Fall fliesen da wohl mindestens 10mA durch den Sensor was da je nach Typ schon zur Eigenerwärmung und somit zu Messfehlern reicht. Also hier wäre als Konstantstromquelle ein LM134 sinnvoller.
Zudem könnte man den Anschluß des PT100 auf einen 3 Leiter Anschluß erweitern ohne die Messschaltung verändern zu müßen.
Die nächste Krux ist der OP....was hast du da verwendet...ist der für Singel 5V Betrieb geeignet und liefert dann auch noch korrekte Werte...
Und wie schon der Kollege sagte...die Werte der Widerstände bräuchte man auch noch...wobei ich anstellen von R1+R2 ein 20K oder 50K Trimmpot setzen würde für den Null Grad Abgleich.
Wobei das Ganze sowieso gagga ist weil die Spannung wo am PT100 abfällt sehr gering ist das der OP in dem Bereich wohl gar nicht sauber arbeiten kann... da nützt auch der Elektrometer Verstärker am Eingang nichts.
Also eine Messschaltung mit nur 5V zu versorgen ist immer ein haariger Kompromiss wo es heißt alle Komponenten auf Herz und Nieren zu überprüfen ob sie dazu tauglich sind.
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.07.2016, 12:27
Beitrag #4
RE: PT100 Messverstärkerschaltung
Hi,
danke schonmal für die schnellen Antworten!

der erste R1 hat 1,25kOhm, der zweite R1 49kOhm.
R2 = 1kOhm
R3 = 51kOhm
R4 = 1kOhm

Danke schonmal!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.07.2016, 12:38
Beitrag #5
RE: PT100 Messverstärkerschaltung
(15.07.2016 12:27)Jessi97 schrieb:  Hi,
danke schonmal für die schnellen Antworten!

der erste R1 hat 1,25kOhm, der zweite R1 49kOhm.
R2 = 1kOhm
R3 = 51kOhm
R4 = 1kOhm

Danke schonmal!

Wo hast du die Widerstandswerte her?

R2 und R4 erscheinen mit recht klein mit 1 kOhm.
Und betreibst du den Verstärker auch wie gefordert mit +-12 Volt (also symetrisch)?

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.07.2016, 13:12
Beitrag #6
RE: PT100 Messverstärkerschaltung
Ja klar könnte ich einfach einen Bausatz übernehmenSmile.
Aber es soll einen Lerneffekt haben und ich möchte dahinter steigen, wie es tatsächlich funktioniert.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.07.2016, 13:15 (Dieser Beitrag wurde zuletzt bearbeitet: 15.07.2016 13:16 von hotsystems.)
Beitrag #7
RE: PT100 Messverstärkerschaltung
(15.07.2016 13:12)Jessi97 schrieb:  Aber es soll einen Lerneffekt haben und ich möchte dahinter steigen, wie es tatsächlich funktioniert.
Dann sag uns mit welcher Spannung du den Verstärker betreibst und wie du auf die Werte der Widerstände kommst.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.07.2016, 13:18
Beitrag #8
RE: PT100 Messverstärkerschaltung
Der OP wird mit +12V / -12V betrieben.
Die Werte der Widerstände stehen oben Smile. Habe ich schonmal kommentiert.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  PT100 Temperaturmessung Hilfe Black2009fox 12 2.883 15.05.2015 04:31
Letzter Beitrag: Scherheinz
  pt100: r25 und b-Werte ? Bill 3 1.473 20.05.2014 11:06
Letzter Beitrag: Thorsten Pferdekämper

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste