INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
PIR will nicht
14.02.2015, 11:24
Beitrag #1
PIR will nicht
Guten Tag - alle,
steh ich aufn Schlauch oder spielt mir der Sketch einen Streich Huh.
PIR angeschlossen Versorgung 5 Volt Trig. an 7, 2, 8, 10, egal wo Pro Mini (Led) reagiert nicht. - Und jetzt kommt der Hammer Big Grin
Led von 9 weg nach 13 - PIR funktioniert. - Geht nur auf Pin 13
4 versch. PIR genommen - alles gleich.
Findet wer einen Fehler oder weshalb geht der Sch Angry nicht. (Hier fehlt ein ICON).
Ich sage frustriert danke
Gerd
Ach so ..... piezo habe ich für den Versuch deaktiviert also nicht angeschlossen?
-------
int piezo=5;
int bewegung=7;
int bewegungsstatus=0;
int led = 9;
int pinled = 6;

void setup()
{
pinMode(piezo, OUTPUT);
pinMode(bewegung, INPUT);
pinMode(led, OUTPUT);
pinMode (pinled, OUTPUT);
}
void loop()
{
digitalWrite (pinled, HIGH);
bewegungsstatus=digitalRead(bewegung);
if (bewegungsstatus == HIGH)
{
digitalWrite(piezo, HIGH);
digitalWrite (led, HIGH);
delay(500);
digitalWrite(piezo, LOW);

delay(1000);
digitalWrite(piezo, HIGH);
delay(500);
digitalWrite(piezo, LOW);
delay(1000);
digitalWrite(piezo, HIGH);
delay(500);
digitalWrite(piezo, LOW);
delay(1000);
digitalWrite(piezo, HIGH);
delay(500);
digitalWrite(piezo, LOW);
delay(1000);
digitalWrite(piezo, HIGH);
delay(500);
digitalWrite(piezo, LOW);
delay(1000);
digitalWrite (led, LOW);
digitalWrite (pinled,LOW);

}

else

{

digitalWrite(piezo, LOW);
}}

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.02.2015, 12:58
Beitrag #2
RE: PIR will nicht
Hallo,
mit den gemachten Angaben kann man leider nur im Trüben fischen.Sad
Was für einen Ausgang hat dein PIR-Sensor? Aktiv VCC schaltend oder OpenKollektor?

Versuche mal ob es mit:
Code:
pinMode(bewegung, INPUT_PULLUP);
besser geht.

Gruß
Arne

Gruß Arne
ExclamationMit zunehmender Anzahl qualifizierter Informationen bei einer Problemstellung, erhöht sich zwangsläufig die Gefahr auf eine zielführende Antwort.Exclamation
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.02.2015, 13:11
Beitrag #3
RE: PIR will nicht
Danke dir !
Schaltung als offener Kollektor ! - witzig nur, dass es bislang ging.
OK ich probiere "Pallup".
Gruß
Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  BME280 wird nicht erkannt sowerum 14 175 Gestern 22:14
Letzter Beitrag: Tommy56
  Echtzeituhrmodul läuft nicht scritch 21 523 30.11.2017 10:44
Letzter Beitrag: Tommy56
  Bootloader lässt sich nicht brennen?? dobermann145 10 489 21.11.2017 22:58
Letzter Beitrag: hotsystems
Sad Nano - nicht genug Speicher torsten_156 10 616 30.10.2017 21:40
Letzter Beitrag: MicroBahner
  NeoPixels: Sketch will nicht - Problem mit delay? Zabsi 5 479 22.08.2017 15:17
Letzter Beitrag: Tommy56
  BME280 - Luftdruckoffset nicht einstellbar ? Stargazer 17 1.267 13.08.2017 15:38
Letzter Beitrag: hotsystems
  Ich komme mit millis nicht weiter !!! Gonmaus 8 930 09.07.2017 21:24
Letzter Beitrag: Tommy56
  WEMOS Motorshield funzt nicht Rumpl-X 8 774 07.06.2017 21:10
Letzter Beitrag: Tommy56
  LCD geht nicht - keine Ahnung warum?? DL1AKP 12 1.052 15.05.2017 13:17
Letzter Beitrag: DL1AKP
  433mHz Funkmodule senden/empfangen nicht metzgefa 2 891 06.05.2017 13:30
Letzter Beitrag: metzgefa

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste