INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Outputs vom Nano
18.07.2020, 15:53
Beitrag #1
Outputs vom Nano
Hallo,

ich da mal eine Frage?

Ich habe ein kleines Programm für den Nano geschrieben und benutze nur die I/O
als Digitale in- oder out-puts.
Bei den Pins D10, D11, D12 kommt nichts weil ich diese als Ausgang genommen habe
Hat das was mit dem MISO MOSI SS zutun muss da was beachten?

Gruß Reinhard
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.07.2020, 15:59 (Dieser Beitrag wurde zuletzt bearbeitet: 18.07.2020 16:00 von Tommy56.)
Beitrag #2
RE: Outputs vom Nano
Benutzt Du SPI?

Ohne Deinen Sketch (bitte in Codetags) kann man da nur raten und das bringt nichts.

Was verstehst Du unter "kommt nichts"?

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.07.2020, 16:00
Beitrag #3
RE: Outputs vom Nano
Es sollten eigentlich alle Pins problemlos funktionieren.
Ausser A6 und A7, da dies nur Analog-Pins sind.
Auch D13 könnte als Input Schwierigkeiten machen, da dieser mir der LED verbunden ist.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.07.2020, 16:34
Beitrag #4
RE: Outputs vom Nano
Tommy hat es ja schon gefragt.
Was genau heißt "kommt nichts" ?
Wenn du die als Ausgang haben willst, müssen die auch so definiert werden.
Und du musst die im Sketch auch richtig ansprechen.
Allerdings können wir deinen geheimen Sketch nicht sehen.
Auch ei Schaltbild deines Aufbaus kann sehr nützlich sein, wenn du es zeigst.

Aber ohne diese Infos, ist es fischen im Trüben.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.07.2020, 17:00 (Dieser Beitrag wurde zuletzt bearbeitet: 18.07.2020 17:02 von Reinhard112.)
Beitrag #5
RE: Outputs vom Nano
Sorry,

Hier ist mein Programm

es geht um den Pin 11

Code:
int E1 = 2; //Eingang M1 Impuls
int E2 = 4; //Eingang M1 Richtung
int E3 = 7; //Eingang M2 Impuls
int E4 = 8; //Eingang M2 Richtung
int Aus1 = 5; // Ausgang M1 Imp
int Aus2 = 6; // Ausgang M1 Richt
int Aus3 = 10; // Ausgang M2 Imp
int Aus4 = 11; // Ausgang M2 Richt

void setup() {
pinMode(E1,INPUT);
pinMode(E2,INPUT);
pinMode(E3,INPUT);
pinMode(E4,INPUT);

pinMode(Aus1,OUTPUT);
pinMode(Aus2,OUTPUT);
pinMode(Aus3,OUTPUT);
pinMode(Aus4,OUTPUT);
}

void loop() {
if ((digitalRead(E2) == LOW)) //Richtung M1
{
  digitalWrite(Aus2,LOW);
}
else
{
  digitalWrite(Aus2,HIGH);
}


if ((digitalRead(E4) == LOW))  //Richtung M2
{
  digitalWrite(Aus4,LOW);
}
else
{
  digitalWrite(Aus4,HIGH);
}


delay(1);
  
if ((digitalRead(E1) == LOW)) //Impupls für Motor 1
{

digitalWrite(Aus1,HIGH);
delayMicroseconds(500);
digitalWrite(Aus1,LOW);
delayMicroseconds(500);
}


if ((digitalRead(E3) == LOW)) // Implus für Motor 2
{

digitalWrite(Aus3,HIGH);
delayMicroseconds(500);
digitalWrite(Aus3,LOW);
delayMicroseconds(500);
}
}
Es geht um den Pin 11 also Aus4 der müsste von HIGH auf LOW Schalten macht er aber nicht.

Wenn ich Aus4 auf Pin 3 lege macht er das. Ich habe schon 2 Nanos ausbrobiert mit dem Gleichen Ergebnis.
Ich hoffe das reicht. Wenn nicht bitte nochmal melden.
Gruß Reinhard
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.07.2020, 17:11
Beitrag #6
RE: Outputs vom Nano
Hast Du mal mit seriellen Ausgaben geprüft, ob Deine Bedingung erfüllt wird?

Wie hast Du den Taster angeschlossen? Hast Du einen PullDown-Widerstand an Pin 8?

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.07.2020, 17:18 (Dieser Beitrag wurde zuletzt bearbeitet: 18.07.2020 17:26 von hotsystems.)
Beitrag #7
RE: Outputs vom Nano
Nimm doch den einfachen Blinksketch für den Pin D4.
Damit kannst du den Pin doch einfach testen.

Wenn das funktioniert, ist etwas am Aufbau falsch.

Edit:
Auch wenn es nicht das Problem löst, aber eine doppelte Klammer brauchst du bei der if-Abfrage nicht.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.07.2020, 18:40 (Dieser Beitrag wurde zuletzt bearbeitet: 18.07.2020 18:41 von Reinhard112.)
Beitrag #8
RE: Outputs vom Nano
Danke die Tipps haben mir weiter geholfen.

1. Blink geht
2. Widerstand ist vorhanden
3. Serialmonitor anzeige ok mit 0 und 1
4. direkt am pin 11 gemessen OK
5. auf Klemmeiste gemessen nicht OK Gesucht und Leiterbahnunterbrechung gefunden verlötet. Teil war neu !!
6. Probelauf ok Smile

Bis denne.

Gruß Reinhard
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  JES LED mit Ardino Nano Steuern??? Hartcor1 13 220 Gestern 11:11
Letzter Beitrag: SpaghettiCode
  E-ink und Nano Hans Riemers 20 2.919 01.12.2020 17:31
Letzter Beitrag: Bernd666
  Arduino Nano + 2 Elektromotoren + 2 Servos + 2 Ultraschallsensoren + IR Sensor PurpleLightning 22 4.686 13.10.2020 10:24
Letzter Beitrag: hotsystems
  nano atmega168 und Fingerprintsensor DY50 nanofanman 1 778 01.10.2020 14:20
Letzter Beitrag: hotsystems
  RX-LED am Nano abfragen Fiete11 19 3.190 20.08.2020 20:40
Letzter Beitrag: hotsystems
  Motorrad-Tacho (Nano) robust gegen Störungen machen SebastianM 10 2.787 04.08.2020 23:15
Letzter Beitrag: Chopp
  Arduino Nano Funktioniert nicht? acca500 7 2.383 10.05.2020 10:22
Letzter Beitrag: hotsystems
  Nano nur mit CH340 USB ?? Franz54 23 6.067 18.04.2020 21:16
Letzter Beitrag: Franz54
  Nano und 12Volt für Weichensteuerung Jan99 2 1.604 13.04.2020 12:30
Letzter Beitrag: hotsystems
  Stand-alone-Nano an USB leuchtet nicht AnFi 5 1.767 23.03.2020 10:08
Letzter Beitrag: SOFTHARD

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste