INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Original Arduino MEGA 2560 und Original Arduino TFT LCD screen funzt nicht
16.11.2014, 22:59
Beitrag #1
Original Arduino MEGA 2560 und Original Arduino TFT LCD screen funzt nicht
Nach ersten Schritten Arduino wollte ich mich nun am Thema "Display" beschäftigen. Um das Risiko an nicht kompatibler Hard- und Software gering zu halten, habe ich in die Tasche gegriffen und Original Arduino Produkte geordert.
Leider bekomme ich es nicht zum laufen - nur Streifen auf dem Display, obwohl ich nur die Musterprogramme ausprobiert habe.
Hat hier schon jemand das Display am Mega in Betrieb nehmen können?
Kennt jemand eine Alternative zu Arduino, wo die Komponenten besser funzen?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.11.2014, 09:01 (Dieser Beitrag wurde zuletzt bearbeitet: 17.11.2014 09:11 von Odiug.)
Beitrag #2
RE: Original Arduino MEGA 2560 und Original Arduino TFT LCD screen funzt nicht
Hi Zorg,

also auf der Arduino-Homepage wird unter Produkte nur ein Display angezeigt. Dieses hier:

Link: Display auf Arduino Homepage

Es gibt dort sogar einen Verdrahtungsplan:

Link: Verdrahtungsplan

Hier die Ansachlüsse lt. Arduino:

Link: Belegung Display

+5V -> +5V
MISO -> 50
SCK -> 52
MOSI -> 51
LCD CS -> 10
SD CS -> 4
D/C -> 9
Reset -> 8
BL
Ground -> GND

Es gibt wohl noch andere, die ein Problem haben, das Ding ans Laufen zu bekommen. Da habe ich z.B. gelesen, dass PIN 4 auf PIN 53 gelegt werden soll. Funzt aber auch nicht.

Da verkauft Arduino selbst Displays, bekommt es aber nicht hin, einen funktionierenden Beispiel-Sketch dazu zu liefern. Eigentlich ein Trauerspiel.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.11.2014, 11:03
Beitrag #3
RE: Original Arduino MEGA 2560 und Original Arduino TFT LCD screen funzt nicht
(17.11.2014 09:46)Zorg schrieb:  sorry, da kann ich dann leider nicht weiterhelfen - ich verwende kein "Original- Arduino- Material"

(hast Du die alternativen Lib's schon getestet ?)

Ne, habe ich nicht ...
Ich will - ehrlich gesagt - nicht unenedliche Zeit (ich bin Anfänger) damit verbringen, den Fehler für Arduino zu suchen (wenn ich es überhaupt schaffe).
Dann kaufe ich mir lieber ein neues Display auf Empfehlung eines Users hier und versuche meine ersten "Display-Schritte".

Also: Wer hat ein 1.8" Display mit einem Arduino MEGA 2560 laufen und kann mir etwas empfehlen?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.11.2014, 15:27
Beitrag #4
RE: Original Arduino MEGA 2560 und Original Arduino TFT LCD screen funzt nicht
Hallo zusammen,

ich hatte das gleiche Problem in Zusammenhang mit dem Arduino Uno und dem TFT-Display. Ich hatte bloss Streifen, egal was ich gemacht habe.
Hab dann auf der Homepage die Arduino 1.5.8 BETA geladen und installiert, dann ging es.

Versuch doch das auch mal.

Gruss Andreas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.11.2014, 12:42
Beitrag #5
RE: Original Arduino MEGA 2560 und Original Arduino TFT LCD screen funzt nicht
(20.11.2014 15:27)andreashuber schrieb:  Hallo zusammen,

ich hatte das gleiche Problem in Zusammenhang mit dem Arduino Uno und dem TFT-Display. Ich hatte bloss Streifen, egal was ich gemacht habe.
Hab dann auf der Homepage die Arduino 1.5.8 BETA geladen und installiert, dann ging es.

Versuch doch das auch mal.

Gruss Andreas

Hi Andreas,

vielen Dank für die Anregung. Ich habe zwischenzeitlich ein paar Tests gemacht:

UNO und IDE 1.0.6 -> funzt nicht (Streifen)
UNO und IDE 1.5.8 Beta -> funzt
MEGA und IDE 1.0.6 -> funzt nicht (Streifen)
MEGA und IDE 1.5.8 Beta -> funzt nicht (heller Bildschirm)

Ich denke mit der IDE 1.5.8 Beta habe ich die größeren Chancen noch etwas hinzubekommen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.11.2014, 11:40 (Dieser Beitrag wurde zuletzt bearbeitet: 22.11.2014 11:43 von tito-t.)
Beitrag #6
RE: Original Arduino MEGA 2560 und Original Arduino TFT LCD screen funzt nicht
das mit dem Mega deckt sich mit meinen Erfahrungen: habe auch nie eines mit dem Mega zum Laufen gekriegt!
(1.5.6, 1.5.8)

peinliche Sache für die Arduino-Entwickler, wie bereits in mindestens 2 anderen Threads diskutiert....
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.12.2014, 15:28
Beitrag #7
RE: Original Arduino MEGA 2560 und Original Arduino TFT LCD screen funzt nicht
Läuft doch Big Grin
Ich habe ein wirklich originales MEGA-Board (von Arduino geliefert) genommen und nun läuft es.
.... so mal hinterher geschoben Shy
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Display für ATMega 2560 mit Shield lion88 3 135 18.08.2017 13:30
Letzter Beitrag: lion88
  Drehregler (Jog Dial?) für Arduino lion88 17 370 16.08.2017 11:13
Letzter Beitrag: Bitklopfer
  Arduino Resonator Bezugsquelle BennIY 15 325 08.08.2017 07:26
Letzter Beitrag: hotsystems
Question [Anfängerfrage] Arduino zum Schaltsignal filtern terminus 39 780 28.07.2017 19:57
Letzter Beitrag: Tommy56
  Anfänger Frage - Arduino Schalter Fireman88 7 235 16.07.2017 16:27
Letzter Beitrag: hotsystems
  12V Schrittmotor mit Arduino ansteuern niggo 4 425 21.06.2017 11:09
Letzter Beitrag: Binatone
Lightbulb NeoMatrix, Arduino Uno und Java Kenaz 5 299 20.06.2017 21:26
Letzter Beitrag: georg01
  WS2801 - Arduino2560 Mega - Glediator - Ausgabeproblem Royal-mit-Käse 0 233 13.06.2017 14:40
Letzter Beitrag: Royal-mit-Käse
  Watt mit Arduino messen Sandro2504 13 602 09.06.2017 22:41
Letzter Beitrag: ardu_arne
  Arduino schaltet durch?! Sandro2504 14 514 08.06.2017 19:18
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste