INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Nebelmaschine: Programmteile funktionieren nicht
14.11.2019, 13:26 (Dieser Beitrag wurde zuletzt bearbeitet: 14.11.2019 13:32 von ChrisTastic.)
Beitrag #9
RE: Nebelmaschine: Programmteile funktionieren nicht
Eigene Dummheit
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.11.2019, 00:06 (Dieser Beitrag wurde zuletzt bearbeitet: 15.11.2019 00:50 von ChrisTastic.)
Beitrag #10
RE: Nebelmaschine: Programmteile funktionieren nicht
Also iwie löscht es dauernd die häflte meiner Kommentare, daher schreib ichs mal stückelweise:

Was ich jetzt noch für ein Problem habe:

Code:
if ((Fernsteuerung == HIGH) || (Taster == HIGH))
  {
    digitalWrite(LuftPumpeAusgang, HIGH);
    digitalWrite(RauchAusgang, HIGH);

    int potPinValue = map(analogRead(potPin), 0, 1024, 0, 255);
...

In diesem Teil möchte ich sagen, dass entweder die Fernsteuerung ODER der Taster die if Bedingung auslösen. Aber jedes mal wenn ich das einfüge, läuft es ohne Taster betätigung sofort los wenn gebootet ist.
Ohne den Taster funzt es einwandfrei. Ist das einfach falsch was ich mache?
Danke dir/euch
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.11.2019, 08:11
Beitrag #11
RE: Nebelmaschine: Programmteile funktionieren nicht
(15.11.2019 00:06)ChrisTastic schrieb:  In diesem Teil möchte ich sagen, dass entweder die Fernsteuerung ODER der Taster die if Bedingung auslösen. Aber jedes mal wenn ich das einfüge, läuft es ohne Taster betätigung sofort los wenn gebootet ist.
Ohne den Taster funzt es einwandfrei. Ist das einfach falsch was ich mache?
Danke dir/euch

Hast du den Taster zufällig an Pin 13 angeschlossen? Dieser ist nämlich mit der Platineneigenen LED verbunden und die ist bei booten immer kurz an.

bis später
Peter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.11.2019, 09:08
Beitrag #12
RE: Nebelmaschine: Programmteile funktionieren nicht
(15.11.2019 00:06)ChrisTastic schrieb:  In diesem Teil möchte ich sagen, dass entweder die Fernsteuerung ODER der Taster die if Bedingung auslösen. Aber jedes mal wenn ich das einfüge, läuft es ohne Taster betätigung sofort los wenn gebootet ist.
Ohne den Taster funzt es einwandfrei. Ist das einfach falsch was ich mache?
Danke dir/euch

Dann ist deine Variable "Fernsteuerung" immer High.
Diese sehe ich auch nicht in deinem Sketch, also wo füllst du die mit einem Wert ?

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  AT90CAN Interrupt wird nicht ausgelöst slsb02 5 243 19.11.2019 15:04
Letzter Beitrag: slsb02
  Nextion und Arduino kommunizieren nicht alpenpower 7 337 04.11.2019 10:36
Letzter Beitrag: GuaAck
  Button funktioniert nicht trotz korrekter Schaltung Schneggl 3 313 12.10.2019 08:17
Letzter Beitrag: Schneggl
  Empfänger funktioniert nicht mehr jgrothe 5 488 06.09.2019 18:57
Letzter Beitrag: Tommy56
  myport nicht gefunden? - Arduino und Visual Studio Stagneth.Alexander 4 562 04.09.2019 14:16
Letzter Beitrag: Stagneth.Alexander
  UDP send oder print ??? Ich kapiers nicht HarryB 5 512 03.09.2019 13:06
Letzter Beitrag: Tommy56
Wink Solar Roboter- Servo dreht nach Stopp nicht weiter Stagneth.Alexander 37 2.855 20.08.2019 14:15
Letzter Beitrag: geist4711
  Atmega 328 Sketchl läuft auf UNO3, alleine auf Breadboard nicht delay 9 986 02.08.2019 15:03
Letzter Beitrag: hotsystems
  Reaktionsspiel funktioniert nicht, wie es sollte... Stagneth.Alexander 27 1.781 21.07.2019 07:57
Letzter Beitrag: Stagneth.Alexander
Question Programm läuft nicht richtig CMeeep 22 1.976 04.07.2019 21:58
Letzter Beitrag: Franz54

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste