INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Nano spielt verrückt!
14.01.2019, 21:17
Beitrag #1
Nano spielt verrückt!
Liebes Forum
ich hatte Probleme mit dem SerialMonitor. Ich konnte nur Daten ausgeben, wenn zuvor ein Hardware-Reset erfolgte.
So habe ich versucht, den Reset softwaremässig einzurichten:
#include <avr/wdt.h>
und im Setup:
wdt_disable();
wdt_enable(WDTO_2S);
Seither spielt der Nano verrückt. Er blinkt (D13) unablässig und lässt sich mit allen Tricks nicht mehr beruhigen (ausschalten, Hardware-Reset).
Was empfehlt ihr mir, um den Kerl zu bändigen?
Andreas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.01.2019, 21:26 (Dieser Beitrag wurde zuletzt bearbeitet: 14.01.2019 21:31 von Tommy56.)
Beitrag #2
RE: Nano spielt verrückt!
Der wird bevor er ein neues Programm laden kann wieder in den Reset gezwungen.

Evtl. kannst Du mit einem (lange geübten) Reset kurz vorm Hochladen von Blink das Ding wiederbeleben. Sonst HV-Programming (Googeln) oder eimern.
Edit: oder neuen Bootlader brennen

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.01.2019, 21:26
Beitrag #3
RE: Nano spielt verrückt!
Der komplette Sketch wäre sinnvoll. Mit deinen Schnipseln kann man nur eine Glaskugel bemühen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.01.2019, 00:36 (Dieser Beitrag wurde zuletzt bearbeitet: 15.01.2019 01:59 von Chopp.)
Beitrag #4
RE: Nano spielt verrückt!
Hallo,
versuch mal: Reset drücken, und gedrückt halten.
Dann ein leeres Programm laden.
Genau in dem Moment , wo die IDE flaschen will, den Reset loslassen.
Sollte dies funktionieren, mal den Blink Sketch laden.
Wenn nichts geht, neuen Bootloader mittels ISP einspielen.
Solltest du den Bootloader neu brennen wollen... es gibt seit 03/2018 eine neue Version.
Ich weiß nicht ob die mit den Clones so ohne weiteres sofort läuft.
Ich hab nur mitbekommen, das die wesendlich kleiner ist,
und mit doppelter Geschwindigkeit ( 115200 ) läuft.
Könnte sein , das man das in der IDE umstellen muß.
Gruß, Markus

Immer in Stress
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.01.2019, 09:13
Beitrag #5
RE: Nano spielt verrückt!
(15.01.2019 00:36)Chopp schrieb:  Hallo,
versuch mal: Reset drücken, und gedrückt halten.
Dann ein leeres Programm laden.
Genau in dem Moment , wo die IDE flaschen will, den Reset loslassen.
Sollte dies funktionieren, mal den Blink Sketch laden.
Wenn nichts geht, neuen Bootloader mittels ISP einspielen.
Solltest du den Bootloader neu brennen wollen... es gibt seit 03/2018 eine neue Version.
Ich weiß nicht ob die mit den Clones so ohne weiteres sofort läuft.
Ich hab nur mitbekommen, das die wesendlich kleiner ist,
und mit doppelter Geschwindigkeit ( 115200 ) läuft.
Könnte sein , das man das in der IDE umstellen muß.
Gruß, Markus

[b]Problem gelöst, Dank an alle:
Ich habe ein minimales Blink-Sketch nach 15 Umdrehungen im Uploader gestartet.
..und siehe da: alles wieder im Normalbereich. Wenn nur alles so einfach wäre!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.01.2019, 10:50
Beitrag #6
RE: Nano spielt verrückt!
...ich meine wenn man den Wachhund schon ins Boot holt sollte man den in der Loop auch immer füttern weil sonst beißt er in den Sketch...dazu sind WDT's da...
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.01.2019, 02:54
Beitrag #7
RE: Nano spielt verrückt!
(15.01.2019 09:13)AnFi schrieb:  [b]Problem gelöst, Dank an alle:
Ich habe ein minimales Blink-Sketch nach 15 Umdrehungen im Uploader gestartet.
..und siehe da: alles wieder im Normalbereich. Wenn nur alles so einfach wäre!

Hallo,
Schön das es jetzt geht,
und Danke für die Rückmeldung.

Willkommen hier im Forum, und eine schöne Zeit noch hier.
Gruß, Markus

Immer in Stress
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Nano läuft nicht nach Einschalten Gritte 29 3.777 23.07.2019 20:43
Letzter Beitrag: Tommy56
  Absturz Nano / com-port shrimps 5 939 18.05.2019 18:27
Letzter Beitrag: hotsystems
  Arduino nano auf 3,3Volt umbauen Bernd666 10 1.346 08.05.2019 14:52
Letzter Beitrag: Bernd666
  Spannungsversorgung Nano AnFi 1 1.018 24.03.2019 14:02
Letzter Beitrag: hotsystems
  Kann ein Arduino Nano mittels delayMicroseconds(13) ein 38kHz-Signal erzeugen SchwuppSchwupp 6 1.676 21.03.2019 11:06
Letzter Beitrag: biologist
  Nano CH340 - Software Reset Lite 16 2.808 17.03.2019 20:07
Letzter Beitrag: Tommy56
  Nano - gelöste USB-Buchse wieder anlöten? Arduinero 7 1.980 27.01.2019 17:05
Letzter Beitrag: Chopp
  PWM-Signal reduzieren auf 5V und per Nano auswerten (PulseIn) dionys 13 2.792 21.12.2018 21:38
Letzter Beitrag: georg01
  Wemos TTGO XI 8F328P-I Nano V3.0 AnFi 8 3.064 20.12.2018 20:33
Letzter Beitrag: AnFi
  Fehlfunktion bei Nano + Servomotor im Batteriebetrieb Backtobasics 11 2.401 10.12.2018 11:11
Letzter Beitrag: Backtobasics

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste