INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Motor reagiert nur auf 5 Volt
18.10.2016, 21:36
Beitrag #9
RE: Motor reagiert nur auf 5 Volt
(18.10.2016 21:17)Flap schrieb:  Habe ein Problem mit dem Transistor.
Es ist ein 2n3866 NPN Transistor.

Wo ist mein Fehler?

Vermutlich liegt der Fehler beim Transistor.
Das ist ein Hochfrequenz-Sendetransistor, wie kommst du auf diesen Typ ?

Nimm einen BC547 o.ä., dann wird es funktionieren.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.10.2016, 22:39 (Dieser Beitrag wurde zuletzt bearbeitet: 18.10.2016 22:40 von Flap.)
Beitrag #10
RE: Motor reagiert nur auf 5 Volt
Zitat:Vermutlich liegt der Fehler beim Transistor.
Das ist ein Hochfrequenz-Sendetransistor, wie kommst du auf diesen Typ ?
Den Transistor habe ich aus meiner Fachhochschule, da sind viele Kataloge mit vielen Bauteilen, das war der erste der ungefähr meinen Strömen und Spannungen entsprach. (30V ist ein wenig hoch gegriffen, aber das sollte ja keinen Unterschied machen, ist ja bloß die Obergrenze.)

Außerdem war bei vielen keine Taktrate angegeben und ich dachte mir das 500MHz reichen sollten *lach*

Aber mal Spaß bei Seite, ob ich da nun einen MiC oder eine Batterie anschließe, sollte doch keinen Unterschied machen? Wieso messe ich einen negativen Strom aus dem MiC?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
19.10.2016, 08:14
Beitrag #11
RE: Motor reagiert nur auf 5 Volt
Vergiss das mit dem Transistor, der ist nicht dafür geeignet, da die Stromverstärkung zu gering ist.

Nimm einen normalen Transistor und 500 MHz brauchst du def. nicht, selbst wenn du mit 100 kHz schalten würdest.
Wenn du negativen Strom mist, hast du evtl. das Messgerät oder die Spannung verkehrt angeschlossen.
Was ist MiC ?

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
19.10.2016, 09:34
Beitrag #12
RE: Motor reagiert nur auf 5 Volt
(19.10.2016 08:14)hotsystems schrieb:  Wenn du negativen Strom mist, hast du evtl. das Messgerät oder die Spannung verkehrt angeschlossen.
Was ist MiC ?
Mit MiC meinte ich den Microkontroller also Arduino in diesem Fall.
Ich habe schon richtig herum gemessen, sonst hätte der Transistor auch durchgeschaltet.
Ein Kommilitone gab mir den Tipp, dass ich den GND vom Arduino mit dem - der Batterie koppeln müsste, da sonst ein Potentialunterschied nicht ausgeglichen wird. Das erklärt auch die -0,8V.
Werde das Freitag mal näher untersuchen.

Der Transistor ist eigentlich nur Spielerei, möchte das Prinzip aber verstanden haben, bis ich eine H-Brücke o.ä. einbaue.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
19.10.2016, 10:03
Beitrag #13
RE: Motor reagiert nur auf 5 Volt
(19.10.2016 09:34)Flap schrieb:  Mit MiC meinte ich den Microkontroller also Arduino in diesem Fall.
Ich habe schon richtig herum gemessen, sonst hätte der Transistor auch durchgeschaltet.
Ein Kommilitone gab mir den Tipp, dass ich den GND vom Arduino mit dem - der Batterie koppeln müsste, da sonst ein Potentialunterschied nicht ausgeglichen wird. Das erklärt auch die -0,8V.
Werde das Freitag mal näher untersuchen.
Der Transistor ist eigentlich nur Spielerei, möchte das Prinzip aber verstanden haben, bis ich eine H-Brücke o.ä. einbaue.

Wenn du den GND aller Komponenten nicht verbunden hast, kann es nicht funktionieren. Das sind Grundlagen der Elektrotechnik. Damit solltest du dich unbedingt befassen.
Nur wenn du Minus der Batterie nicht am Arduino hast, kann dieser nicht funktionieren. Also mit dieser Beschreibung kommt keiner klar.

Ein Schaltbild wäre hier hilfreich.

Und lass die Spielerei mit dem falschen Transistor.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.10.2016, 20:30
Beitrag #14
RE: Motor reagiert nur auf 5 Volt
Danke für deine Hilfe, schön blöd der Fehler. Nun läuft es wie es soll!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.10.2016, 20:56
Beitrag #15
RE: Motor reagiert nur auf 5 Volt
(20.10.2016 20:30)Flap schrieb:  Danke für deine Hilfe, schön blöd der Fehler. Nun läuft es wie es soll!

Prima, freut mich das es jetzt funktioniert.
Danke für die Rückmeldung.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.10.2016, 23:42
Beitrag #16
RE: Motor reagiert nur auf 5 Volt
Hallo,
sorry - aber möchte gerne auch fragen:

Der Flap schreibt;
Zitat:Nun reagiert der Motor auf 4,5 Volt (in das Batteriefach kommen 3*1,5V Batterien) und auch auf den 5 Volt-Ausgang des Arduinos, aber nicht auf ein Pin der mittels digitalWrite(motor, HIGH); 5V ausspuckt, geschweige denn auf ein PWM das auf 255 geschaltet ist.
Der Motor fiept bei dem PWM.
...
Nun die Frage: Warum funktioniert das nicht mit den Outputpins?
Gibt es da eine Stromgrenze die niedriger als der 5V-Ausgang ist?

Der hat also den Motor (? ca. paar Ohm Wicklungswiderstand) direkt an den / die GPIO angeschlossen. Haben die (GPIO) eine Kurzschluss- Sicherung?

Gruß
Georg

Sorry für mein nicht korrektes Deutsch. Sad
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Schrittmotor ruckelt beim Start und im laufenden Betrieb - Arduino+Motor Shield grt35a 3 276 21.09.2016 06:56
Letzter Beitrag: Bitklopfer
  Arduino hängt bei DC-Motor MeisterQ 4 248 27.08.2016 18:39
Letzter Beitrag: Binatone
  Past der Schritt Motor??? Uwe1475 0 161 11.08.2016 19:56
Letzter Beitrag: Uwe1475
  Arduino / SPS / 24 Volt in-Out Binatone 21 1.081 27.07.2016 13:47
Letzter Beitrag: Binatone
  Step UP von 3,6 V auf mind. 9 Volt toto1975 3 386 06.04.2016 21:03
Letzter Beitrag: hotsystems
  Motor Shield wird Heiß erwin 8 1.137 24.03.2016 11:29
Letzter Beitrag: hotsystems
  Bipolar Motor ansteuern #elextro19 7 749 12.02.2016 02:11
Letzter Beitrag: Wetteronkel
  Motor shield #elextro19 2 668 25.01.2016 09:24
Letzter Beitrag: #elextro19
  FTDI FT232-Seriell-USB-Wandler 3,3 Volt arduinofan 2 508 22.12.2015 22:21
Letzter Beitrag: arduinofan
  Problem mit adafruit motor shield Philthy 13 1.824 22.12.2015 15:27
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste