INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Mega2560 keine USB Funktion
07.01.2016, 12:56
Beitrag #1
Mega2560 keine USB Funktion
Also ich habe das folgende Problem: Ich kann keine Skets mehr über USB auf meinen Mega2560 laden und das von jetzt auf gleich. Angry
Bei meinen anderen Arduino geht es einwandfrei. Über die ISP (mit stk500) kann ich eine Hex-Dat auf den 2560 laden und der läuft dann auch (Blink). Die USB- Schnittstelle ist aber Tot, auch über die ISP für den Mega8u2 (oder Mega16U2? trotz Lupe) ist dieser nicht ansprechbar.
Muss da noch was anderes gemacht werden damit ich ein neues Programm für die USB Schnittstelle laden kann oder muss da ein Bootloader auf den Atmel? ich habe keine Ideen mehr. Huh
Da sind ja noch ein paar nicht bestückte Lötpunkte neben der ISP Schnittstelle, muss da was gemacht werden???. Ich habe einen USB-Adapter und eine STK500 von Atmel als ISP-Programmer und wäre froh wenn hier einer wüste wo das Problem liegt. Immer den Mega mit dem Programmer programmieren ist lästig und "Print" geht ohne USB ja nicht. Wenn der Chip hin ist, hat den schon mal einer getauscht?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.01.2016, 15:56
Beitrag #2
RE: Mega2560 keine USB Funktion
Klar warte ich gerne, ich habe nur erst später eine Mail zur deutschen Seite bekommen und gedacht das es hier wohl besser aufgehoben ist da ich nicht gut in englisch bin



(07.01.2016 13:46)Lötzinnerhitzer schrieb:  Crossposting ! (Kommentar dazu erspare ich mir)

http://forum.arduino.cc/index.php?PHPSES...c=370196.0

magst Du im anderen Forum nicht erst auf Antworten warten ?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.01.2016, 18:29 (Dieser Beitrag wurde zuletzt bearbeitet: 07.01.2016 20:16 von Bobby32.)
Beitrag #3
RE: Mega2560 keine USB Funktion
So zu Deinen Fragen: Win7, Wird als Com7 erkannt.
Diese Meldung kommt:
Binäre Sketchgröße: 4.126 Bytes (von einem Maximum von 258.048 Bytes)
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
Keine der TX oder RX Led leuchtet.
Die USB-Ports habe ich getauscht und ein anderer Laptop geht auch nicht. Arduino IDE 1.0.5 und 1.6.4 probiert, 1.0.5 läuft aber 1.6.4 will nicht laufen und meldet ungültige Bibliotheken gut das ich die alte Version noch drauf habe.
Der andere Mega2560 wird als Com1 erkannt und ein Sketch lässt sich hochladen alle LED blinken beim hochladen, das PRG Blink läuft.
Klar geht es mit einem neuen vom Chinamann, aber ich möchte doch gerne diesen komischen Fehler auf den Grund kommen. Einfach so von jetzt auf gleich keine Reaktion mehr ist schon unheimlich. Wenn das bei meinem 3-D-Drucker auch passiert wäre. dann wäre das Problem größer weil ich dann keinen Mega in Reserve mehr hätte.
Welche Bedeutung hat eigendlich JP5?
Ich habe noch einen Test gemacht, mit Putty geht bei dem guten Mega2560 die RX-Led wenn ich Daten sende bei dem anderen tut sich nichts.



(07.01.2016 16:01)Lötzinnerhitzer schrieb:  - welches PC-Betriebssystem ?
- erkennst Windows den USB-Port ?
- hast Du schon einen anderen Port/anderen PC versucht ?
- Chip tauschen lohnt sich bei den Preisen (Stichwort: freundlicher Chinese) wohl kaum
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.01.2016, 13:54
Beitrag #4
RE: Mega2560 keine USB Funktion
So da bin ich noch mal. Ich bin noch nicht weiter gekommen und wenn einer noch was weis bitte hier:http://forum.arduino.cc/index.php?topic=370196.30 um doppelposting zu vermeiden. Danke für die Tips hier.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino MEGA2560 Lernkit HDT 10 662 27.05.2016 15:34
Letzter Beitrag: hotsystems
  display ili9325, r61505, hx8347 an mega2560 Pit 0 673 15.02.2016 10:36
Letzter Beitrag: Pit
  Komische Funktion durch Kurzschluss eines N-Kanal MOSFET BennIY 6 836 08.10.2015 22:25
Letzter Beitrag: BennIY
  Mega2560 bei -20 C im Frost ?? Pit 14 1.625 26.09.2015 09:41
Letzter Beitrag: Pit
  Mega2560 + Netzwerk/SD Shield hängt sich weg Gandalf 1 688 12.09.2015 13:05
Letzter Beitrag: Bitklopfer
Question ESP8266: "Hochladen abgeschlossen" aber keine Resultate marcus 1 1.290 19.06.2015 20:37
Letzter Beitrag: marcus
  LCD Anzeige für Arduino Mega2560 an Arduino Due? DaniDD 1 808 03.06.2015 12:16
Letzter Beitrag: DaniDD
  WIN7 erkennt keinen Mega2560+Leonardo... alpenpower 4 1.033 30.05.2015 12:22
Letzter Beitrag: alpenpower
  Spannung wo keine sein soll ! bergfrei 30 4.169 28.05.2015 09:25
Letzter Beitrag: Scherheinz
  Uni Projekt und keine Ahnung von E-Technik !!HILFE!!! Bennes91 1 1.082 29.04.2015 16:37
Letzter Beitrag: Bennes91

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste