INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Mega hat Ladehämmung
03.07.2013, 09:30
Beitrag #1
Mega hat Ladehämmung
Hallo Forum

Ich habe ein Problem mit meinem Mega. Ich habe mir ein Programm zur steuerung meines Aquariums geschrieben, was bis Gestern Abend auch noch einmalig lief. Jetzt versuche ich seit Stunden das Programm neu zu laden und habe das Problem das ersten jedesmal die Com Schnittstelle verschwindet und ich das Programm nicht geladen bekomme. Compilieren kein Problem aber beim Upload bleibt die Schaltfläche für den Upload Gelb und das Programm bleibt irgendwo hängen, wenn ich dann nach einiger zeit die Schaltfläche noch einmal anklicke dann kommt folgende Fehlermeldung:

Could not delete C:\DOKUME~1\JRGEN~1.MAL\LOKALE~1\Temp\build2351470189406910101.tmp\Aquarium_Bele​uchtung_Dimmen_Nachtbeleuchtung_Zeitgesteuert1.cpp.hex
Could not delete C:\DOKUME~1\JRGEN~1.MAL\LOKALE~1\Temp\build2351470189406910101.tmp
Binary sketch size: 12236 bytes (of a 258048 byte maximum)
processing.app.SerialException: Serial port 'COM1' already in use. Try quiting any programs that may be using it.
at processing.app.Serial.<init>(Serial.java:144)
at processing.app.Serial.<init>(Serial.java:76)
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:75)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:93​)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java​:56)
at processing.app.Sketch.upload(Sketch.java:1603)
at processing.app.Sketch.exportApplet(Sketch.java:1568)
at processing.app.Sketch.exportApplet(Sketch.java:1524)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2293)
at java.lang.Thread.run(Thread.java:619)
processing.app.debug.RunnerException: Serial port 'COM1' already in use. Try quiting any programs that may be using it.
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:99)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:93​)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java​:56)
at processing.app.Sketch.upload(Sketch.java:1603)
at processing.app.Sketch.exportApplet(Sketch.java:1568)
at processing.app.Sketch.exportApplet(Sketch.java:1524)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2293)
at java.lang.Thread.run(Thread.java:619)


Ich weis nicht mehr was ich noch versuchen kann, den wenn ich ein anderes Programm teste Faden oder Blinken dann habe ich kein Problem es Hoch zu laden und es läuft auch einwandfrei. Das Programm für das Aquarium ist 12236 bytes lang und ich denke einmal das dürfte ja nichts ausmachen. Wäre schön wenn mir einer helfen könnte.

l.G. Jürgen

Verzeihe Deinen Feinden, aber vergesse nie Ihren Namen.....
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.07.2013, 17:51 (Dieser Beitrag wurde zuletzt bearbeitet: 03.07.2013 17:59 von malerlein.)
Beitrag #2
RE: Mega hat Ladehämmung
Also die IDE vollzieht alle Uploads von den mitgelieferten Beispiel Programmen, nur wenn ich mein Aqua Programm uploade, dann hängt es sich auf. das Programm hat 12236 bytes und an dem Arduino Mega leuchtet immer ganz kurt die RX und dann etwas länger die TX LED auf aber es tut sich nichts die IDE läuft durch bis kurz vor Schluss dann hängt sie. Das Compilieren schlisst die IDE vollständig ab.

l.G.Jürgen

(03.07.2013 17:51)malerlein schrieb:  Also die IDE vollzieht alle Uploads von den mitgelieferten Beispiel Programmen, nur wenn ich mein Aqua Programm uploade, dann hängt es sich auf. das Programm hat 12236 bytes und an dem Arduino Mega leuchtet immer ganz kurt die RX und dann etwas länger die TX LED auf aber es tut sich nichts die IDE läuft durch bis kurz vor Schluss dann hängt sie. Das Compilieren schlisst die IDE vollständig ab.
Und ich bekomme immer die Meldung z.B. Port Com8 wird von einem anderen Programm verwendet obwohl ich nichts anderes angeschlossen habe als den Arduino und auch kein Programm was einen Com Port verwendet.

l.G.Jürgen

l.G. Jürgen

Verzeihe Deinen Feinden, aber vergesse nie Ihren Namen.....
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Datenübertragung vom Arduino Mega 2560 zu Hterm Datatom 1 97 13.11.2016 23:08
Letzter Beitrag: hotsystems
  Arduino Mega 2560 läuft nicht Wolfgang50 6 180 13.11.2016 10:50
Letzter Beitrag: Wolfgang50
  Arduino Mega 2560 Manfred1981 4 188 11.11.2016 18:07
Letzter Beitrag: hotsystems
  Attiny45 Bootloader brennen mit Funduino Mega toto1975 63 2.189 23.10.2016 17:08
Letzter Beitrag: hotsystems
Question Mega 2560 defekt? triode 11 359 29.09.2016 07:21
Letzter Beitrag: hotsystems
  nrf24 an Mega 2560 jgrothe 2 162 10.09.2016 13:39
Letzter Beitrag: jgrothe
  Arduino mega 2560 mit TFT LCD Touch Shield V1 Clemens55555 17 935 02.08.2016 20:51
Letzter Beitrag: Clemens55555
  Mega: Hardware i2c bus speed (Wire.) verändern? HaWe 10 2.922 14.07.2016 20:09
Letzter Beitrag: Mathias
  (Mega) Timer 3 A, B & C Scheams 0 229 04.06.2016 17:09
Letzter Beitrag: Scheams
  DUE-MEGA über I2C Verbinden HTO 0 222 22.05.2016 10:16
Letzter Beitrag: HTO

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste