INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Mega 2560 geht in Verbindung mit China Ethernet-Shield und SD Karte defekt
22.01.2015, 11:55
Beitrag #1
Mega 2560 geht in Verbindung mit China Ethernet-Shield und SD Karte defekt
Hallo zusammen,
heute habe ich folgende Kombination zusammengebaut Sainsmart Mega2560 und „China W5100 Ethernet Board Schild Ethernet-Shield für Arduino IDE TF Mega 2560, ebay
381068456992“ Ein Webserver ließ sich problemlos installieren und betreiben. Anschließend habe ich auf dem W5100 Ethernet Board eine micro SD Karte eingesteckt um diese zu testen. Hierbei wurde das Mega 2560 Board zerschossen, habe anschließend das Ethernet Board auf einen neuen Sainsmart Mega2560 gesetzt und dieses lief zunächst einwandfrei, bis ich auch hier die SD eingesteckt habe. Danach lies sich das Ethernet-Shield nicht mehr ansprechen. Der defekt liegt aber bei den Mega 2560. Warum gehen die Sainsmart Mega2560 defekt wenn ich auf dem Ethernet Board die SD Karte betreibe. Beim Mega sind anscheinend nur Datenleitungen durch, die 5V, 3,3V sind vorhanden und auch die Einspielung neuer Sketche funktioniert, nur die Ethernet Board funktionieren nicht mehr. Das letzte Ethernet Board habe ich ohne SD Karte jetzt am 3. Sainsmart Mega2560 problemlos laufen, natürlich ohne SD Karte. Kann mir jemand das Verhalten erklären.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.01.2015, 13:14
Beitrag #2
RE: Mega 2560 geht in Verbindung mit China Ethernet-Shield und SD Karte defekt
Hallo!
Pin 53 hast am Mega auf Output gesetzt?

mfg Martin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.01.2015, 15:16
Beitrag #3
RE: Mega 2560 geht in Verbindung mit China Ethernet-Shield und SD Karte defekt
Hallo Martin,

nein den Pin 53 habe ich nicht geändert. Ist hierdurch der Schaden am Mega entstanden?

Gruß

Tom
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.01.2015, 18:02
Beitrag #4
RE: Mega 2560 geht in Verbindung mit China Ethernet-Shield und SD Karte defekt
Hallo!
Nein, Schaden kannst dadurch keinen anstellen.
Der SPI Bus funktioniert halt nicht richtig.
Warum glaubst du, das die Boards defekt sind ?
Hast schon ein Beispiel aus der SD Lib probiert ?

mfg Martin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.01.2015, 18:44
Beitrag #5
RE: Mega 2560 geht in Verbindung mit China Ethernet-Shield und SD Karte defekt
Hallo,
ja die Mega 2560 sind mit Sicherheit defekt, ich habe das Ethernet-Shield jetzt auf einem dritten Board gesteckt und ohne SD mit dem gleichen Sketch am laufen. So lief es auch auf den Mega 1+2, bis die SD Karte dazu kam. Danach waren beide Boards nicht mehr funktionsfähig. Auf den Board 3 möchte ich die SD jetzt nicht einstecken, um dieses auch noch zu zerschießen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.01.2015, 20:41
Beitrag #6
RE: Mega 2560 geht in Verbindung mit China Ethernet-Shield und SD Karte defekt
Hallo!
..hattest bei den letzen Tests die Pins 4 und 53 auf OUTPUT ?

mfg Martin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  SunFounder 16 Channel 12 Bit PCA9685 PWM Servo I2C Driver Shield Bikandajyo 31 1.820 15.01.2018 15:11
Letzter Beitrag: Bikandajyo
  RS232 Verbindung und Serial Monitor rev.antun 15 495 28.12.2017 11:21
Letzter Beitrag: Chopp
  Probleme mit dem Arduino Ethernet-Shild jalu4601 46 4.135 26.12.2017 00:26
Letzter Beitrag: ArduTux
  2.8" TFT Touchscreen ST7783 mit Arduino Mega arduinoma 7 347 22.12.2017 09:11
Letzter Beitrag: Chopp
  Welches GSM Shield Kaufen ?? huber5093 7 320 19.12.2017 07:53
Letzter Beitrag: Chopp
  Arduino Mega mit TFT Shield Diskusguppy 4 315 15.12.2017 02:04
Letzter Beitrag: Diskusguppy
  Box cases für arduino nano UNO etc mit ethernet buchse sepp01 8 703 22.11.2017 14:55
Letzter Beitrag: sepp01
  nano, micro oder? für LAN Shield sepp01 10 906 12.11.2017 11:30
Letzter Beitrag: sepp01
  Steckertyp von SD Card Shield V4.0? alpenpower 7 801 10.11.2017 10:04
Letzter Beitrag: SkobyMobil
  Display für ATMega 2560 mit Shield lion88 8 1.202 08.10.2017 18:27
Letzter Beitrag: SkobyMobil

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste