INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Mal geht das kompilieren mal nicht ????
05.01.2020, 14:15
Beitrag #9
RE: Mal geht das kompilieren mal nicht ????
Weil Du auf den ersten Blick mehrere } falsch gesetzt hast.
Das drösel ich jetzt aber nicht auf, das kannst Du durch sauberes Einrücken und ordentliches Sortieren z.B innerhalb von Setup selbst herausbekommen.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.01.2020, 16:41
Beitrag #10
RE: Mal geht das kompilieren mal nicht ????
Servus Tommy,

ich kireg die Krise ich probier setze zeichen neu andere weg formatier,
dann komm ich zwar wieder ein paar zeilen, dann geht auf einmal etwas wieder nicht was vorher ging, das mach mich wahnsinnig.

Kannst mur bitte zeigen wo und warum ich den Fehler mache ?
ich kapiers nicht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.01.2020, 17:03
Beitrag #11
RE: Mal geht das kompilieren mal nicht ????
Du sollst nicht rumstochern, sondern die Funktionen der IDE nutzen.

Wenn Du auf eine { mit der Maus gehst, zeigt er Dir die dazugehörende } an.

Wenn Du außerdem Deinen Mamutcode in sinnvolle Funktionen aufteilst, wird das Ganze übersichtlicher. z.B. die ganzen Serial2.xxx im Setup in eine eigene Funktion nextionInit auslagern.
Warum definierst Du nextion und schreibst dann doch Serial2?

Unnötige auskommentierte Konfigurationszeilen löschen.

z.B. sind die { Klammern in den Zeilen 72 und 137 falsch und nach 185 fehlt eine.

Keine Garantie für Vollzähligkeit, da ich Deinen Code mangels einiger Libs nicht kompilieren kann.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.01.2020, 07:47
Beitrag #12
RE: Mal geht das kompilieren mal nicht ????
Servus Tommy,

Danke für Deine Hilfe.

ich bin froh das ich den ursprung Sketch so hinbekommen habe, lief alles, konnt ich auch aufs board laden. mein Problem ist nur, es wird ein Text ausgabe geändert und dann geht nix mehr.
ich habe deine Tips befolgt, aber ich komm nicht weiter.

ich weiß dank Google was eine IDE ist (Arduino wird verwendet)
und wie funktionen auslagern ?
keine Ahnung
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.01.2020, 10:34
Beitrag #13
RE: Mal geht das kompilieren mal nicht ????
Dann schau mal in die hier im Forum verlinkte Referenz, da werden auch Funktionen erklärt.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Library Ethernet: Nicht zu compilieren GuaAck 5 232 22.02.2021 17:31
Letzter Beitrag: Tommy56
  von delay auf millis umgestellt, klappt nur nicht. Servo Geschwindigkeit einstellen. gutschy 8 410 21.02.2021 15:22
Letzter Beitrag: gutschy
  MMega2560-Clone läßt sich nicht programmieren kpc 8 415 08.02.2021 09:50
Letzter Beitrag: hotsystems
  If-Schleife wird nicht mehr durchlaufen LK2567 2 263 05.02.2021 21:20
Letzter Beitrag: LK2567
  Tasterabfrage funktioniert nicht Moehn 4 383 05.02.2021 15:23
Letzter Beitrag: Moehn
  Kompiler beschwert sich nicht, LC-Display macht aber nicht, was es soll. generic_user492 3 303 26.01.2021 14:11
Letzter Beitrag: MicroBahner
  Arduino Uno+ Ethernetshield W5100 wird in Fritz Box nicht erkannt Justus S. 14 620 23.01.2021 13:39
Letzter Beitrag: Justus S.
  Die && Verknuepfung von zwei Schaltern auf ESP8266 will nicht. gutschy 6 398 22.01.2021 22:25
Letzter Beitrag: hotsystems
  Zähler zählt nicht wonk 14 674 21.01.2021 20:26
Letzter Beitrag: wonk
  Methode wird nicht aufgerufen rrobbyy 7 430 19.01.2021 15:59
Letzter Beitrag: katsumi_s

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste