INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
MAX7219 8x8 Matrix Problem
12.03.2014, 23:15
Beitrag #9
RE: MAX7219 8x8 Matrix Problem
Nein
Das glaube ich nicht
selbst bei eimen Modul läuft es falsch rum
und falsch anschliessen kann man da nicht viel

Anschlossen ist das bei mir jetzt so
Pin 5V auf VCC dann oben pin VCC
PIN GND auf GND dann oben pin GND
Pin 9 = Data auf DIN dann oben pin DOUT
pIN 10 = CS AUF CS dann oben pin CS
Pin 11 = CLK auf CLK dann oben pin CLK

USW



Gruß Andy
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.03.2014, 18:11
Beitrag #10
RE: MAX7219 8x8 Matrix Problem
Hallo;
das steht mit in deinem 1. Post drinne.
Zitat:\ def USE_FONT_ADJUST
1, um die Schriftanpassungsmethodezu ermöglichen - in der Regel deaktiviert .
Nützlich, wenn Schriftarten (z. B. Kopf -Hardware) gedreht werden müssen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.03.2014, 15:41
Beitrag #11
RE: MAX7219 8x8 Matrix Problem
(12.03.2014 23:15)Andrzejjj schrieb:  Nein
Das glaube ich nicht
selbst bei eimen Modul läuft es falsch rum
und falsch anschliessen kann man da nicht viel

Anschlossen ist das bei mir jetzt so
Pin 5V auf VCC dann oben pin VCC
PIN GND auf GND dann oben pin GND
Pin 9 = Data auf DIN dann oben pin DOUT
pIN 10 = CS AUF CS dann oben pin CS
Pin 11 = CLK auf CLK dann oben pin CLK

USW



Gruß Andy

Hallo Andy,
also ich habe auch diese 8x8 Module hier und beschäftige mich damit. Also wenn deine Zeichen um 90 Grad verdreht sind dann liegt das an dem verwendeten Zeichengenerator deiner Library. Da ich den ganzen Sermon zu Fuss programmiere (nur die SPI Lib verwendet) weiß ich wovon ich rede weil ich meine Zeichen auch erst kippen mußte. Zum erstellen der Zeichen habe ich mir ein Tabellenkalkulationsblatt angelegt wo ich komfortabel die Zeichen definieren kann und dann nur noch die Hex-Werte ins Programm kopieren muß.
Allerdings stehe ich noch am Anfang und habe erst mal ne Handvoll Zeichen definiert....auch kann ich sie noch nicht über den Zeichencode abrufen....kommt noch...
Aber nun will ich erst mal den Lauftext programmieren.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.03.2014, 21:23
Beitrag #12
RE: MAX7219 8x8 Matrix Problem
Hallo


So ich hab geschaft alles läuft so wie es laufen soll
musste nur die library als Text dokoment öffen da umstellen
und Speichern. Siehe da es läuft


Hab ab und zu mal Pixel feher oder das ein komplettes modul aus fehlt bzw schwach leuchtet.



mfg Andi[/php]
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  matrix display elegoo uno R3 starter set lecker16 7 153 23.11.2016 21:14
Letzter Beitrag: Bitklopfer
  Problem mit SD Card Library BennIY 4 193 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 212 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 852 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 459 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 604 13.06.2016 21:14
Letzter Beitrag: torsten_156
  ESP8266_01 flashen - Problem torsten_156 12 1.056 30.05.2016 20:12
Letzter Beitrag: torsten_156
  Hardwareserial/Softserial: Problem mit Superklasse tuxedo0801 10 483 19.05.2016 12:25
Letzter Beitrag: amithlon
  ESP8266 HTML Problem arduino_weatherstation 1 497 25.04.2016 21:52
Letzter Beitrag: rkuehle
  Problem mit OLED 0.96" Display torsten_156 3 545 03.04.2016 15:10
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste