INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Led will nicht
17.02.2015, 16:19
Beitrag #1
Led will nicht
Hallo Gemeinde,
habe einen Sketch ( funktioniert einwandfrei)Wink
nur die Led will nicht leuchten. Big Grin
Die Wav Datei dreht munter die Kreise (Loop) solange soll auch die Led leuchten.
Ist wer bereit und schaut sich mal den Sketch an ? - Ähhhh und mir sagen warum?
Danke und liebe Grüße
Gerd

#include <SD.h> // need to include the SD library
#define SD_ChipSelectPin 10 //example uses hardware SS pin 53 on Mega2560
#include <TMRpcm.h> // also need to include this library...
int led = 6;
TMRpcm tmrpcm; // create an object for use in this sketch


void setup(){
pinMode (led, OUTPUT);
tmrpcm.speakerPin = 9;
//tmrpcm.soundBuff = 500;

pinMode(11,OUTPUT); //set this to the speaker pin : 10 for Mega, 11 for Uno,Duemilinove etc.

Serial.begin(115200);
if (!SD.begin(SD_ChipSelectPin)) { // see if the card is present and can be initialized:
Serial.println("SD fail"); return; // don't do anything more if not

}else{ Serial.println("SD_ok"); }
// tmrpcm.play("5.wav"); //spielt beim Einschalten und zurück setzen
}

void loop(){

if (Serial.available() ){
if (Serial.read() == 'SD_ok'){
tmrpcm.play("05.wav"); // sending a C through the serial port starts the conversion
delay(200);
digitalWrite (led, HIGH);
}
}
}

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 16 292 Heute 14:15
Letzter Beitrag: oOSpikeOo
  Mein Skript macht nicht das was es soll ;( DerMatze79 4 129 16.03.2017 22:19
Letzter Beitrag: MicroBahner
  Programmablauf macht nicht das was ich möchte !! ESP + Blynk b3ta 3 159 01.03.2017 14:29
Letzter Beitrag: Tommy56
Rainbow File geht nicht zum compilieren!!!! Jocky 7 259 19.02.2017 20:01
Letzter Beitrag: Binatone
  IRremote bringe ich nicht zum laufen Franz54 5 183 19.02.2017 11:56
Letzter Beitrag: Tommy56
  Code aus 1.6.9 geht mit 1.8.1 nicht mehr zu kompilieren DL1AKP 7 367 02.02.2017 12:16
Letzter Beitrag: Tommy56
  Arduino Läst sich nicht Programmieren Micha06 4 259 29.01.2017 17:27
Letzter Beitrag: Micha06
  Nicht verzagen Forum fragen bergfrei 13 492 28.01.2017 06:09
Letzter Beitrag: dqb312
  Sloeber findet meinen Com Port nicht :-( Pfeilebastler 2 150 27.01.2017 11:11
Letzter Beitrag: hotsystems
  nRF24l01 empfängt Daten nicht techniclover 1 220 09.01.2017 19:20
Letzter Beitrag: celle

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste