INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Led will nicht
17.02.2015, 16:19
Beitrag #1
Led will nicht
Hallo Gemeinde,
habe einen Sketch ( funktioniert einwandfrei)Wink
nur die Led will nicht leuchten. Big Grin
Die Wav Datei dreht munter die Kreise (Loop) solange soll auch die Led leuchten.
Ist wer bereit und schaut sich mal den Sketch an ? - Ähhhh und mir sagen warum?
Danke und liebe Grüße
Gerd

#include <SD.h> // need to include the SD library
#define SD_ChipSelectPin 10 //example uses hardware SS pin 53 on Mega2560
#include <TMRpcm.h> // also need to include this library...
int led = 6;
TMRpcm tmrpcm; // create an object for use in this sketch


void setup(){
pinMode (led, OUTPUT);
tmrpcm.speakerPin = 9;
//tmrpcm.soundBuff = 500;

pinMode(11,OUTPUT); //set this to the speaker pin : 10 for Mega, 11 for Uno,Duemilinove etc.

Serial.begin(115200);
if (!SD.begin(SD_ChipSelectPin)) { // see if the card is present and can be initialized:
Serial.println("SD fail"); return; // don't do anything more if not

}else{ Serial.println("SD_ok"); }
// tmrpcm.play("5.wav"); //spielt beim Einschalten und zurück setzen
}

void loop(){

if (Serial.available() ){
if (Serial.read() == 'SD_ok'){
tmrpcm.play("05.wav"); // sending a C through the serial port starts the conversion
delay(200);
digitalWrite (led, HIGH);
}
}
}

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  BME280 wird nicht erkannt sowerum 14 255 10.12.2017 22:14
Letzter Beitrag: Tommy56
  Echtzeituhrmodul läuft nicht scritch 21 610 30.11.2017 10:44
Letzter Beitrag: Tommy56
  Bootloader lässt sich nicht brennen?? dobermann145 10 549 21.11.2017 22:58
Letzter Beitrag: hotsystems
Sad Nano - nicht genug Speicher torsten_156 10 628 30.10.2017 21:40
Letzter Beitrag: MicroBahner
  NeoPixels: Sketch will nicht - Problem mit delay? Zabsi 5 489 22.08.2017 15:17
Letzter Beitrag: Tommy56
  BME280 - Luftdruckoffset nicht einstellbar ? Stargazer 17 1.286 13.08.2017 15:38
Letzter Beitrag: hotsystems
  Ich komme mit millis nicht weiter !!! Gonmaus 8 945 09.07.2017 21:24
Letzter Beitrag: Tommy56
  WEMOS Motorshield funzt nicht Rumpl-X 8 792 07.06.2017 21:10
Letzter Beitrag: Tommy56
  LCD geht nicht - keine Ahnung warum?? DL1AKP 12 1.063 15.05.2017 13:17
Letzter Beitrag: DL1AKP
  433mHz Funkmodule senden/empfangen nicht metzgefa 2 909 06.05.2017 13:30
Letzter Beitrag: metzgefa

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste