INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
LED leuchtet nur schwach
07.02.2016, 10:45 (Dieser Beitrag wurde zuletzt bearbeitet: 07.02.2016 10:54 von Much.)
Beitrag #1
LED leuchtet nur schwach
Hallo,

Ich habe folgenden Code auf meinem Arduino laufen, eigentlich funktioniert auch alles, aber wenn ich eine LED einschalten lasse, leuchtet diese nur ganz schwach.
Wenn ich sie statt an Pin 6 an den 5V Pin hänge leuchtet sie normal.

Danke im Voraus!

#include "RCSwitch.h"
#include <stdlib.h>
#include <stdio.h>
RCSwitch mySwitch = RCSwitch();

void setup()
{
Serial.begin(9600);
mySwitch.enableReceive(0);
}

void loop()
{
if (mySwitch.available())
{
int value = mySwitch.getReceivedValue();
Serial.println( mySwitch.getReceivedValue() );

if(mySwitch.getReceivedValue()==1)
{
digitalWrite(6,1);
}
if(mySwitch.getReceivedValue()==2)
{
digitalWrite(6,0);
}

mySwitch.resetAvailable();
}
}
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.02.2016, 10:51
Beitrag #2
RE: LED leuchtet nur schwach
VCC ist Deine Versorgungsspannung.
Netzteil, 9V Block irgendwas in der Richtung.

Am Pin liegen 5V an.

Auf dem Arduino wird Vcc zu 5,0 Volt für den Controller geregelt.
Und mehr gibt der auch nicht raus, selbst wenn 12V an vcc liegen

Binatone
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.02.2016, 10:53 (Dieser Beitrag wurde zuletzt bearbeitet: 07.02.2016 10:54 von Much.)
Beitrag #3
RE: LED leuchtet nur schwach
Sorry!
Ich meinte nicht VCC sondern den 5V Pin.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.02.2016, 12:01 (Dieser Beitrag wurde zuletzt bearbeitet: 07.02.2016 12:04 von hotsystems.)
Beitrag #4
RE: LED leuchtet nur schwach
(07.02.2016 10:53)Much schrieb:  Sorry!
Ich meinte nicht VCC sondern den 5V Pin.
Ein Schaltbild würde uns hier weiter helfen.

Und womit programmierst du?
In der Arduino-IDE ist das hier:
Code:
#include <stdlib.h>
#include <stdio.h>
überflüssig.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.02.2016, 12:49
Beitrag #5
RE: LED leuchtet nur schwach
Danke!

Ich habe das "pinMode(6, OUTPUT);" vergessen!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste