INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
LCD Display plötzlich komische Zeichen
27.07.2016, 12:58
Beitrag #1
LCD Display plötzlich komische Zeichen
Hallo Ihr Lieben,

ich habe ein Projekt. Die Temperatur einer Heizung wird gemessen und als Istwert auf einem LCD mit I²C ausgegeben. Ein Sollwert ist über zwei Taster einstellbar und wird ebenfalls auf dem Display ausgegeben.
Je nach dem, wie das Temperaturverhältnis ist, wird die Heizung ein- oder ausgeschalten.
Soweit so gut läuft alles.

Nun zu meinem Problem:

Während der Programmierung, als ich hin und wieder mal etwas in der Software verändert habe und es frisch auf den Arduino hochgeladen habe, kamen immer mal wieder plötzlich nur noch irgendwelche komischen Zeichen auf dem LCD.
Wenn ich dann das Kabel vom Arduino einmal ab- und wieder drangesteckt habe, war alles wieder normal.

Woran kann das liegen, dass da immer mal wieder so komische Zeichen kommen?
Kann es sein, weil der Aufbau auf einem Steckbrett ist und die Datenübertragung vielleicht gestört ist?


Liebe Grüße
Jessi
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
27.07.2016, 13:22
Beitrag #2
RE: LCD Display plötzlich komische Zeichen
(27.07.2016 12:58)Jessi97 schrieb:  Nun zu meinem Problem:
Während der Programmierung, als ich hin und wieder mal etwas in der Software verändert habe und es frisch auf den Arduino hochgeladen habe, kamen immer mal wieder plötzlich nur noch irgendwelche komischen Zeichen auf dem LCD.
Wenn ich dann das Kabel vom Arduino einmal ab- und wieder drangesteckt habe, war alles wieder normal.

Woran kann das liegen, dass da immer mal wieder so komische Zeichen kommen?
Kann es sein, weil der Aufbau auf einem Steckbrett ist und die Datenübertragung vielleicht gestört ist?

Wie lang sind die Kabel zu deinem Display/I2C-Adapter?

Hast du am I2C-Bus Pullup-Widerstände, je Leitung 4,7 k gegen + 5 Volt?

Es kann auch an den Steckkontakten liegen, diese bitte prüfen.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.07.2016, 11:34
Beitrag #3
RE: LCD Display plötzlich komische Zeichen
(27.07.2016 12:58)Jessi97 schrieb:  Hallo Ihr Lieben,

ich habe ein Projekt. Die Temperatur einer Heizung wird gemessen und als Istwert auf einem LCD mit I²C ausgegeben. Ein Sollwert ist über zwei Taster einstellbar und wird ebenfalls auf dem Display ausgegeben.
Je nach dem, wie das Temperaturverhältnis ist, wird die Heizung ein- oder ausgeschalten.
Soweit so gut läuft alles.

Nun zu meinem Problem:

Während der Programmierung, als ich hin und wieder mal etwas in der Software verändert habe und es frisch auf den Arduino hochgeladen habe, kamen immer mal wieder plötzlich nur noch irgendwelche komischen Zeichen auf dem LCD.
Wenn ich dann das Kabel vom Arduino einmal ab- und wieder drangesteckt habe, war alles wieder normal.

Woran kann das liegen, dass da immer mal wieder so komische Zeichen kommen?
Kann es sein, weil der Aufbau auf einem Steckbrett ist und die Datenübertragung vielleicht gestört ist?


Liebe Grüße
Jessi

Hi,
das dürfte daran liegen das vom Arduini her beim Start des Displays die Initialisierung nicht vollständig gemacht wird wie es der Displayhersteller vorsieht.
Das ist mir so auch schon einmal untergekommen. Dann habe ich direkt aus dem Datenblatt des Displaytreibers die Startsequenz mir angeeignet und die dann ausgegeben....dann hat es immer geklappt.
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Waveform auf Nextion Display GuaAck 6 289 12.04.2017 19:08
Letzter Beitrag: SkobyMobil
  neues OLED Display nötig an vorhandenem uC Systemswerlich Ersatz hd311 7 233 26.03.2017 11:16
Letzter Beitrag: hd311
  Pinbelegung TFT-Display ILI9341 mingo 19 682 23.03.2017 17:49
Letzter Beitrag: oOSpikeOo
  Servo macht komische Sachen Jochenv 7 322 08.03.2017 00:23
Letzter Beitrag: Jochenv
  Display über I2-Bus betreiben mfri 22 951 23.01.2017 11:06
Letzter Beitrag: renid55
  matrix display elegoo uno R3 starter set lecker16 7 762 23.11.2016 21:14
Letzter Beitrag: Bitklopfer
  Empfange nur "Geister"zeichen vom BT-Modul dabbamonkeyyy 2 237 23.10.2016 11:34
Letzter Beitrag: Harry Hirsch
  Altes Digitales Display mit Text/Bits durch Genuino Micro versorgen - SPI-Bibliothek? RollingStone 0 301 25.06.2016 17:46
Letzter Beitrag: RollingStone
  Problem mit OLED 0.96" Display torsten_156 3 879 03.04.2016 15:10
Letzter Beitrag: hotsystems
  Display Blinkt immer arduino_weatherstation 29 2.177 12.03.2016 13:10
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste