INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
LCD 16x2 zeigt plötzlich nichts mehr!??
23.10.2013, 20:51
Beitrag #1
LCD 16x2 zeigt plötzlich nichts mehr!??
Hallo Zusammen!

Folgendes Problem:

Mein Uno läuft mit schon seit Wochen einwandfrei. PID-Regelung und Analogauswertung funktioniert auch immer noch, nur das Dispaly zeigt in der ersten Zeile 2 oder 6 und in der zweiten Zeile immer 0.

Programm neu hochladen nützt nichts, Display abstecken wärend dem hochladen oder neustarten danach nützt ebenso nichts!

Serial Monitor in Verbindung mit dem USB Kabel zeigt aber genau den Text denn das Dispaly zeigen soll.

Woran kann das plötzlich kommen/liegen?
Kann mann das Dispaly reseten?


Vielen Dank im Voraus!

Mit freundlichen Grüßen
Wolfgang
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.10.2013, 20:24
Beitrag #2
RE: LCD 16x2 zeigt plötzlich nichts mehr!??
Hallo Wolfgang,

ich würde die Schaltung mal so lassen, aber ein Example-Sketch der Display-Library auf den Arduino schieben und gucken was kommt. Wenn der Output auf dem Display io ist dürfte es ein Problem im eigentlichen Projektsketch sein.
Wenn nicht wird es wohl ein HW-Problem (Verkabelung des Displays!).

Grüße Ricardo
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Question PIN 13 auf HIGH Mulitmeter zeigt 7,2V an Claus_M 8 538 24.01.2017 18:57
Letzter Beitrag: Claus_M
  LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr emduino 2 377 26.07.2016 20:42
Letzter Beitrag: hotsystems
  mehr PWM Pins WIMunios 8 1.612 20.03.2016 00:19
Letzter Beitrag: hotsystems
  Welchen Wert zeigt ein DS18B20 über 125 Grad? Jetiman 3 1.147 02.08.2015 11:29
Letzter Beitrag: Jetiman
  Mehr als einmal I2C? gregors 10 1.460 01.08.2015 10:52
Letzter Beitrag: Bitklopfer
  LCD zeigt nach einiger Zeit unlesbaren Code an kaplopez 19 4.166 03.07.2015 09:41
Letzter Beitrag: fraju
  Probleme mit Sainsmart 16x2 Display spoernc 24 8.410 07.12.2014 11:41
Letzter Beitrag: Bitklopfer
  Arduino und mehr Neuling71 19 4.243 05.11.2014 21:23
Letzter Beitrag: Bitklopfer
Bug plötzlich Fehler beim Hochladen HaWe 0 1.431 26.09.2014 21:45
Letzter Beitrag: HaWe
  Arduino Uno nimmt keine Daten mehr an uwe918 7 4.779 21.08.2014 18:11
Letzter Beitrag: Alexus

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste