INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr
21.07.2016, 14:16
Beitrag #1
LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr
Hallo,

für mein Projekt verwende ich eine Arduino NANO mit einem LCD 1602/HD44780 und den LiquidCrystal Bibliotheken. Betrieben habe ich den Monitor über den 5v Port des Arduino. [/align]Bei meinem Abschlusstest fing der Bildschirm plötzlich an, wirre Zeichenkombination anzuzeigen bzw. eine Art Cursorblinken. Selbst nachdem wiedereinschalten tritt das Problem wieder auf.

Ich habe das Teil an meinem zweiten Arduino Nano angeschlossen und über die LiquidCrystal Scratches getestet. Selbst da wird nicht mehr alles angezeigt.

Habt Ihr eine Idee wie ich herausbekommen kann, ob der LCD-Monitor oder der HD44780 converter einen weg hat?
Einen weiteren Display zum Testen habe ich leider nicht :-(

Danke im Voraus.

Gruß Matze
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.07.2016, 15:10 (Dieser Beitrag wurde zuletzt bearbeitet: 21.07.2016 15:11 von hotsystems.)
Beitrag #2
RE: LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr
(21.07.2016 14:16)emduino schrieb:  Habt Ihr eine Idee wie ich herausbekommen kann, ob der LCD-Monitor oder der HD44780 converter einen weg hat?
Das wird dir nicht viel nützen, da der Controller auf dem Display verbaut ist. den kannst du sicher nicht wechseln. Das sind meist fest verbaute Controller.

Oder meinst du evtl. den I2C-Adapter für TWI?
Wenn ja, dann:

Den musst du ablöten (16 Lötstellen) danach kannst du das Display direkt mit dem Arduino und einer passenden Library (ohne I2C) testen.

Aber prüfe vorher mal alle Verbindungen, ob die noch richtig Kontakt geben.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.07.2016, 20:42
Beitrag #3
RE: LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr
Hallo,

wie sieht es aus, läuft dein Display wieder?
Könnte auch andere interessieren.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Hardware die mehr als 1A benötigen testen georg01 18 274 21.05.2018 18:23
Letzter Beitrag: hotsystems
  [Arduino Mega 2560]Will als ISP nicht arbeiten; IDE macht Fehler? ManniP 24 1.653 20.04.2018 09:35
Letzter Beitrag: ManniP
  [Arduino Mega2560 as ISP]AT90USB162 will sich nicht programmieren lassen ManniP 4 476 31.03.2018 14:11
Letzter Beitrag: ManniP
  CD74HCT4094 - bekomme es nicht zum laufen RayGenWurm 16 899 31.03.2018 09:12
Letzter Beitrag: amithlon
  Arduino Uno wird nicht erkannt McGyver 7 610 11.03.2018 17:43
Letzter Beitrag: hotsystems
Lightbulb LCD 2004 HD44780 see 5 447 09.03.2018 13:33
Letzter Beitrag: hotsystems
  Alternative zu TRCT 5000 mit mehr Reichweite UNO_Beginner 3 352 06.03.2018 19:42
Letzter Beitrag: UNO_Beginner
  Sim800L - wählt nicht ein Dachs 26 1.940 15.01.2018 15:03
Letzter Beitrag: hotsystems
  IR Fernbedienungs Abfrage funktioniert nicht Bully 28 1.545 14.01.2018 09:03
Letzter Beitrag: Bully
  Arduino Uno R3, servos reagieren nicht auf die Befehle Crossedsticks 5 1.006 22.02.2017 22:42
Letzter Beitrag: Binatone

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste