INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr
21.07.2016, 14:16
Beitrag #1
LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr
Hallo,

für mein Projekt verwende ich eine Arduino NANO mit einem LCD 1602/HD44780 und den LiquidCrystal Bibliotheken. Betrieben habe ich den Monitor über den 5v Port des Arduino. [/align]Bei meinem Abschlusstest fing der Bildschirm plötzlich an, wirre Zeichenkombination anzuzeigen bzw. eine Art Cursorblinken. Selbst nachdem wiedereinschalten tritt das Problem wieder auf.

Ich habe das Teil an meinem zweiten Arduino Nano angeschlossen und über die LiquidCrystal Scratches getestet. Selbst da wird nicht mehr alles angezeigt.

Habt Ihr eine Idee wie ich herausbekommen kann, ob der LCD-Monitor oder der HD44780 converter einen weg hat?
Einen weiteren Display zum Testen habe ich leider nicht :-(

Danke im Voraus.

Gruß Matze
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.07.2016, 15:10 (Dieser Beitrag wurde zuletzt bearbeitet: 21.07.2016 15:11 von hotsystems.)
Beitrag #2
RE: LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr
(21.07.2016 14:16)emduino schrieb:  Habt Ihr eine Idee wie ich herausbekommen kann, ob der LCD-Monitor oder der HD44780 converter einen weg hat?
Das wird dir nicht viel nützen, da der Controller auf dem Display verbaut ist. den kannst du sicher nicht wechseln. Das sind meist fest verbaute Controller.

Oder meinst du evtl. den I2C-Adapter für TWI?
Wenn ja, dann:

Den musst du ablöten (16 Lötstellen) danach kannst du das Display direkt mit dem Arduino und einer passenden Library (ohne I2C) testen.

Aber prüfe vorher mal alle Verbindungen, ob die noch richtig Kontakt geben.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.07.2016, 20:42
Beitrag #3
RE: LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr
Hallo,

wie sieht es aus, läuft dein Display wieder?
Könnte auch andere interessieren.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Uno R3, servos reagieren nicht auf die Befehle Crossedsticks 5 326 22.02.2017 22:42
Letzter Beitrag: Binatone
  4-fach Relaiskarte HL-54 zieht nicht richtig an. Kriskind 13 547 12.02.2017 23:51
Letzter Beitrag: Tommy56
  ws2812b + nodemcu Ich finde den Fehler nicht. Tha_Coralis 16 1.033 15.12.2016 18:37
Letzter Beitrag: Harry Hirsch
  USB-Gerät wird nicht erkannt kpc 4 559 13.12.2016 15:48
Letzter Beitrag: René Hitz
  Bluetooth-Steuerung mit elegoo uno funktioniert nicht Matthias_Arduino 0 460 01.11.2016 19:47
Letzter Beitrag: Matthias_Arduino
  Pin 5 an Pro Micro funktioniert nicht scritch 1 251 07.09.2016 13:54
Letzter Beitrag: ardu_arne
  Nema 17 Schrittmotor läuft an a4988 nicht fagus 9 967 04.08.2016 20:12
Letzter Beitrag: fagus
  Uno gehen zwei digital Pins nicht edlosijagen 15 822 07.07.2016 19:22
Letzter Beitrag: Bitklopfer
  Arduino Nano - RGB LED Controller MasT3r-A 13 1.194 29.04.2016 11:43
Letzter Beitrag: hotsystems
  IFLZ44N schaltet nicht korrekt? torsten_156 22 1.298 25.04.2016 13:53
Letzter Beitrag: Bitklopfer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste