INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
If, Else if, else Problem (Anfängerfrage)
02.11.2014, 22:20 (Dieser Beitrag wurde zuletzt bearbeitet: 02.11.2014 22:30 von afk009.)
Beitrag #1
If, Else if, else Problem (Anfängerfrage)
Hallo zusammen,
bitte Nagelt micht nicht fest wenn jemand Bereits hier schon mal so etwas gefragt habe und ich das in der Suche nicht finden konnte.

Ich versuche hier mit einem UNO einen mini Motor mit 2 Tasten (Vorwärts/Rückwerts) zu steuern, aber mein Code scheint nicht dafür asugelegt zu sein und ich finde den Fehler nicht.

PHP-Code:
int motorPin1=3;
int motorPin2=4;
int motorPin3=11;
int motorPin4=12;// PWM
 
void setup() {
  
pinMode(motorPin3,INPUT);
  
pinMode(motorPin4,INPUT);
  
pinMode(motorPin1,OUTPUT);
  
pinMode(motorPin2,OUTPUT);
}
 
void motorStop(){
  
digitalWrite(motorPin1,LOW);
  
digitalWrite(motorPin2,LOW);
}
void loop(){
  if(
digitalRead(motorPin3)==HIGH)
  {
  
digitalWrite(motorPin1,HIGH);
  
digitalWrite(motorPin2,LOW);
  
  }
  else if(
digitalRead(motorPin4)==HIGH)
  {
  
digitalWrite(motorPin1,LOW);
  
digitalWrite(motorPin2,HIGH);
    }
   else  
motorStop();


komischerweise funktioniert das in eine Richtung mit If, Else schon.

Wenn ich den Code übertrage beginnt der Motor sich gleich zu drehen obwohl weder die 11 noch 12 mit Spannung versorgt werden.
Wenn ich 5V in die 11 oder 12 einstecke, dann dreht er sich schon richtig, nur wenn ich keine Spannung mehr drauf gebe dreht er sich weiter, also wird aus Pin 3+4 nicht LOW-LOW wie ich das gerne hätte.

kann mich bitte hier jemand aufklären was ich falsch mache?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.11.2014, 22:53
Beitrag #2
RE: If, Else if, else Problem (Anfängerfrage)
heißer Tipp,
Die Eingänge mit aktiviertem PullUp Widerstand gegen GND per Taste schalten.

digitalWrite(motorPin3, HIGH); // so wird bei einem Eingang der Pull Up aktiviert
dann hast mal an der Ecke definierte Zustände.

is ne alte Leier....Tongue

lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.11.2014, 23:23
Beitrag #3
RE: If, Else if, else Problem (Anfängerfrage)
Huh
hab mir jetzt die Antwort ein paar mal durch gelesen... werde irgendwie nicht schlauer drauß
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.11.2014, 12:50
Beitrag #4
RE: If, Else if, else Problem (Anfängerfrage)
(02.11.2014 23:23)afk009 schrieb:  ... werde irgendwie nicht schlauer drauß

Bitklopfer meint das deine IOs keine klar definierten Zustände haben.

Schaue dir DAS mal an.

VG, Ralf
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 5 117 24.03.2017 22:58
Letzter Beitrag: Tommy56
  ESP8622 - 01 sendet UDP - Problem WLan Kriskind 37 2.612 14.03.2017 19:49
Letzter Beitrag: Tommy56
  Smart Home Webserver Basic Authentication Problem Osotastic 21 559 20.02.2017 18:00
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 456 31.01.2017 20:41
Letzter Beitrag: Tommy56
  Beim Hochladen USB Problem Nils 10 659 29.12.2016 21:05
Letzter Beitrag: renid55
  Problem mit SD Card Library BennIY 4 402 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 325 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 1.149 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 673 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 967 13.06.2016 21:14
Letzter Beitrag: torsten_156

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste