INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
I2C-Problem - DS1307, BMP180, BH1750
04.04.2015, 09:58 (Dieser Beitrag wurde zuletzt bearbeitet: 04.04.2015 10:00 von drFlexus.)
Beitrag #1
I2C-Problem - DS1307, BMP180, BH1750
Hey Leute,

für ein kleines Projekt habe ich mir jetzt eine
- RTC RTC-Ebay
- Lichtsensor Lichtsensor-Ebay
- Luftdrucksensor Luftdrucksensor-Ebay
bestellt und die sind inzwischen auch da.

Gestern wollte ich alles einfach mal mit den entsprechenden libs testen. Leider habe ich den Lichtsensor gar nicht über I2C zum laufen gebracht, der Rest hat soweit funktioniert.
Als ich mit einem I2C-Scanner (weis jetzt nicht genau welcher es war) die Adressen herausfinden wollte ist der Bus scheinbar komplett zusammengebrochen als ich den Lichtsensor eingefügt habe und einzeln hat es auch nicht funktioniert.

Angeschlossen waren alle Teilnehmer richtig, getestet habe ich mit einem UNO- und einem MEGA-Board, IDE 1.6.3.

Hat zufällig jemand ne Idee?

Danke im Voraus und schöne Ostern Wink


EDIT: Ich habe den I2C mit und ohne Pull-Up Widerstände getestet.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.04.2015, 10:25
Beitrag #2
RE: I2C-Problem - DS1307, BMP180, BH1750
Das mit den libs dachte ich mir auch am Anfang. Deshalb wollte ich dann mit dem I2C Scanner testen ob ich überhaupt Teilnehmer finde. Danach hatte ich dann IDE 1.0.6 ausgegraben, hat aber auch nicht funktioniert.
Die Module sind alle 5V (Spannungswandler onboard). BH1750 und BMP180 sollen wohl auch mit 3V3 funktionieren, deshalb hatte ich das auch mal versucht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.04.2015, 17:22
Beitrag #3
RE: I2C-Problem - DS1307, BMP180, BH1750
Hallo,
Die Lib vergibt 2 Adressen.
Mit int BH1750address = 0x23; //setting i2c address
im Setup sollte er dann erreichbar sein.

mfg Martin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Bug Hardware Problem (!) Gandalf 34 827 06.11.2016 07:29
Letzter Beitrag: Pardini
  Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle MSchroeder 2 118 15.10.2016 22:18
Letzter Beitrag: MSchroeder
  ESP8266-01 Problem mit UDP loglo 5 378 03.08.2016 07:49
Letzter Beitrag: loglo
  Problem mit adafruit motor shield Philthy 13 1.813 22.12.2015 15:27
Letzter Beitrag: hotsystems
  Bootloader/Port/Programmer Problem mit altem Diecimila HaWe 7 1.217 29.07.2015 13:10
Letzter Beitrag: HaWe
  DS1307 Uhrzeit nach Start TheGent86 16 2.413 21.07.2015 07:57
Letzter Beitrag: HaWe
  FTDI FT232R Problem BennIY 5 1.427 07.07.2015 22:38
Letzter Beitrag: BennIY
  Problem mit tone() bei Frequenz >11kHz torsten_156 9 2.044 04.07.2015 18:29
Letzter Beitrag: torsten_156
Question Zwei RC522 RFID Reader -> Problem durch Kabel? vtx 2 814 24.06.2015 11:13
Letzter Beitrag: vtx
  LCD 1602 (ohne SPI) - Problem mit Sonderfunktionen ?!? zauche 4 947 19.06.2015 14:04
Letzter Beitrag: zauche

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste