INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
I2C Display geht nicht
15.01.2014, 14:59
Beitrag #1
I2C Display geht nicht
Hallo,

Will mit Arduino ein LCD Display betreiben http://www.conrad.de/ce/de/product/19833...rchDetail. Um Pins zu sparen, schließe ich den über die I2C Buchse: an 5V,GRD, SCL und SDA. Habe die Library LiqiudCrystal_I2C runtergeladen. Die 3 Adressjumper A0-A2 sind gesteckt, laut dem Datenblatt hat das Display deswegen die Adresse 0x40. Lade dieses Programm auf Arduino
[#include <Wire.h>
#include <LiquidCrystal_I2C.h>

LiquidCrystal_I2C lcd(0x40,16,2); //

void setup()
{
lcd.init(); // initialize the lcd

// Print a message to the LCD.
lcd.backlight();
lcd.print("Hello, world!");
}

void loop()
{
}]

SCL und SDA Jumper sind auch gesetzt, ich sehe aber nur Artefakte(Segmente) auf dem Display.
Was kann man noch machen?[/code]
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.01.2014, 07:44 (Dieser Beitrag wurde zuletzt bearbeitet: 16.01.2014 07:47 von rkuehle.)
Beitrag #2
RE: I2C Display geht nicht
Moin Coleby,
Zitat:laut dem Datenblatt hat das Display deswegen die Adresse 0x40.
Prüfe die Adresse mal mit dem I2C-Scanner hier: http://playground.arduino.cc/Main/I2cScanner
Wieviele Zeilen/Spalten hat das Display? Welcher Controller ist drauf?
Versuche mal lcd.begin(Zeilen,Spalten) anstatt lcd.init()
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.01.2014, 12:11
Beitrag #3
RE: I2C Display geht nicht
(16.01.2014 07:44)rkuehle schrieb:  Moin Coleby,
Zitat:laut dem Datenblatt hat das Display deswegen die Adresse 0x40.
Prüfe die Adresse mal mit dem I2C-Scanner hier: http://playground.arduino.cc/Main/I2cScanner
Wieviele Zeilen/Spalten hat das Display? Welcher Controller ist drauf?
Versuche mal lcd.begin(Zeilen,Spalten) anstatt lcd.init()
Grüße Ricardo

Ok, der Scanner sagt, dass die Adresse 0x20 ist. Habe es geändert und auch lcd.begin(16,2) probiert. Beleuchten tut er, "Hello, World" kommt nach wie vor nicht. Habe den ATmega328 drauf. Ich hoffe es liegt nicht daran
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.04.2015, 16:38
Beitrag #4
RE: I2C Display geht nicht
Falls sich für den Tread noch jemand interessiert:
Liquid_Crystal.h
Folgende Sache löschen:


#define En B00010000 // Enable bit
#define Rw B00100000 // Read/Write bit
#define Rs B01000000 //Register select bit

Dann das hier einfügen und speichern:


#define Rw B00010000 // Enable bit
#define Rs B00100000 // Read/Write bit
#define En B01000000 //Register select bit

Die Jumper auf 0011010 (0=offen 1=Zu)
Dann diesen Code benutzen:

#include <Wire.h>
#include <LiquidCrystal_I2C.h>

LiquidCrystal_I2C lcd(0x23,16,2); // set the LCD address to 0x20 for a 16 chars and 2 line display

void setup()
{
lcd.init(); // initialize the lcd

// Print a message to the LCD.
lcd.backlight();
lcd.print("Hello, world!");
}

void loop()
{
}

Fertig!
Eine kleine Problem Lösung:
1. Wenn Gar nichts funktioniert, den I2C-Scanner Benutzen und Folgende Zeile abändern:
LiquidCrystal_I2C lcd(0x23,16,2);
zu:
LiquidCrystal_I2C lcd("Dein Code",16,2);

2.IMMER alle kabel überprüfen!!!

3. Die Steker Reihe andersrum einstecken von:

0011010 (0=offen 1=Zu)
auf
0101100 (0=offen 1=Zu)

Ich hoffe, dir damit Weitergeholfen zu haben Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  matrix display elegoo uno R3 starter set lecker16 7 157 23.11.2016 21:14
Letzter Beitrag: Bitklopfer
  Arduino lässt sich nicht installieren bergfrei 4 148 20.11.2016 18:34
Letzter Beitrag: bergfrei
  Arduino Mega 2560 läuft nicht Wolfgang50 6 185 13.11.2016 10:50
Letzter Beitrag: Wolfgang50
  Ardublock übertragt nicht an IDE oder UNO R3 tobi83 5 357 16.10.2016 14:07
Letzter Beitrag: Pit
  Upload funktioniert nicht Levi 5 248 22.09.2016 20:19
Letzter Beitrag: hotsystems
  ESP8266 tuts nicht sowerum 7 396 19.09.2016 21:01
Letzter Beitrag: sowerum
  If-Bedingung funktioniert nicht bei Serial1.write Datatom 6 226 16.09.2016 20:36
Letzter Beitrag: Datatom
  SD Karte wird nicht erkannt... Maxi290997 2 208 16.08.2016 14:36
Letzter Beitrag: Maxi290997
  Arduino lässt sich nicht mehr beschreiben Maxi290997 15 985 07.08.2016 11:40
Letzter Beitrag: Maxi290997
  LCD Display plötzlich komische Zeichen Jessi97 2 244 28.07.2016 11:34
Letzter Beitrag: Bitklopfer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste