INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
I²C vom NANO zum PI Probleme mit High/Low Bit
28.02.2016, 19:38
Beitrag #1
I²C vom NANO zum PI Probleme mit High/Low Bit
Hi zusammen eventuell hat einer von euch nen guten Gedanken...

Situation:

Ich Lese mit dem Nano eine Wägezelle über einen Messverstärker als Analogwert ein. Das klappt auch wunderbar. Auf Anfrage des Raspberry PI wird dieser Wert an ihn über I²C gesendet...
Alle Werte zwischen 0 und 255 gibt der Pi auch richtig aus. Aber ab 256 fängt er wieder bei 0 an.

Denke mal das sind Probleme mit der Auswertung des High bzw Low Bit?

Nur wie lose ich das?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.02.2016, 19:54
Beitrag #2
RE: I²C vom NANO zum PI Probleme mit High/Low Bit
Was erwartet der Pi, was sendet der Arduino?

Wenn Du den Wert eines analogen Eingangs (0 bis 1023) übertragen willst, dann sind das 2 Byte.
Du scheinst nur ein Byte zu übertragen und da ist bei 255 Ende der Fahnenstange.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.02.2016, 19:57
Beitrag #3
RE: I²C vom NANO zum PI Probleme mit High/Low Bit
(28.02.2016 19:54)Tommy56 schrieb:  Was erwartet der Pi, was sendet der Arduino?

Wenn Du den Wert eines analogen Eingangs (0 bis 1023) übertragen willst, dann sind das 2 Byte.
Du scheinst nur ein Byte zu übertragen und da ist bei 255 Ende der Fahnenstange.

Gruß Tommy

Ja Richtig aber da es ein integer ist bin ich davon ausgegangen das zumindest der Nano es auch so sendet wie er es auch im Serial Monitor zeigt...
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.02.2016, 20:14
Beitrag #4
RE: I²C vom NANO zum PI Probleme mit High/Low Bit
Ohne Sketch auf dem NANO und die Leseroutine auf dem PI kann man da wenig dazu sagen. Grundsätzlich arbeiten die aber erstmal mit einzelnen Bytes, zumindest auf der Empängerseite, wenn Du ihm nix anderes beibringst.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.02.2016, 00:00 (Dieser Beitrag wurde zuletzt bearbeitet: 29.02.2016 00:07 von hotsystems.)
Beitrag #5
RE: I²C vom NANO zum PI Probleme mit High/Low Bit
Zitat:Ja Richtig aber da es ein integer ist bin ich davon ausgegangen das zumindest der Nano es auch so sendet wie er es auch im Serial Monitor zeigt...
Das heißt ja nicht, dass es auch per I2C in einem Stück gesendet werden kann.

Lies die mal den Beitrag durch:

http://hlembke.de/arduinoablage/crate.php?20150411i2c

Da wirst du lesen, das pro "einfacher" Übertragung nur ein Byte gesendet wird. Du musst deine Daten also aufteilen, damit du alles übertragen kannst.

Dazu findest du dann Antworten hier:
http://www.arduinoforum.de/arduino-Threa...ave-Sender

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Gruß Dieter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduin Radio Head Library driver Probleme gandalf7588 3 384 08.04.2018 13:05
Letzter Beitrag: gandalf7588
  Probleme mit multiplexing Thor Wallhall 55 3.419 18.03.2018 18:06
Letzter Beitrag: Tommy56
  Treppenbeleuchtung Probleme mit LED Anzahl Cellman 1 220 18.03.2018 10:13
Letzter Beitrag: hotsystems
  Probleme mit Scheduler Arduino DUE juergen001 5 389 15.03.2018 11:44
Letzter Beitrag: juergen001
  Probleme mit DS3231 Geeros#18 6 385 26.02.2018 14:09
Letzter Beitrag: Tommy56
Sad zu wenig Speicher im Nano (Schulprojekt) Dock.Blanko 5 336 10.02.2018 12:00
Letzter Beitrag: rkuehle
  Mehrere Ausgänge mit einem Befehl auf High oder Low setzen dahans 1 501 10.01.2018 12:48
Letzter Beitrag: Tommy56
  Probleme mit der Software Thor Wallhall 8 703 31.12.2017 11:34
Letzter Beitrag: Tommy56
  Makeblock mit Scratch programmieren- Probleme Keinen Schimmer 17 4.381 30.12.2017 00:40
Letzter Beitrag: koma1965
  Probleme Serieller Kommunikation Arduino Nextero 13 787 12.12.2017 16:47
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste