INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
I²C vom NANO zum PI Probleme mit High/Low Bit
28.02.2016, 19:38
Beitrag #1
I²C vom NANO zum PI Probleme mit High/Low Bit
Hi zusammen eventuell hat einer von euch nen guten Gedanken...

Situation:

Ich Lese mit dem Nano eine Wägezelle über einen Messverstärker als Analogwert ein. Das klappt auch wunderbar. Auf Anfrage des Raspberry PI wird dieser Wert an ihn über I²C gesendet...
Alle Werte zwischen 0 und 255 gibt der Pi auch richtig aus. Aber ab 256 fängt er wieder bei 0 an.

Denke mal das sind Probleme mit der Auswertung des High bzw Low Bit?

Nur wie lose ich das?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.02.2016, 19:54
Beitrag #2
RE: I²C vom NANO zum PI Probleme mit High/Low Bit
Was erwartet der Pi, was sendet der Arduino?

Wenn Du den Wert eines analogen Eingangs (0 bis 1023) übertragen willst, dann sind das 2 Byte.
Du scheinst nur ein Byte zu übertragen und da ist bei 255 Ende der Fahnenstange.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.02.2016, 19:57
Beitrag #3
RE: I²C vom NANO zum PI Probleme mit High/Low Bit
(28.02.2016 19:54)Tommy56 schrieb:  Was erwartet der Pi, was sendet der Arduino?

Wenn Du den Wert eines analogen Eingangs (0 bis 1023) übertragen willst, dann sind das 2 Byte.
Du scheinst nur ein Byte zu übertragen und da ist bei 255 Ende der Fahnenstange.

Gruß Tommy

Ja Richtig aber da es ein integer ist bin ich davon ausgegangen das zumindest der Nano es auch so sendet wie er es auch im Serial Monitor zeigt...
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.02.2016, 20:14
Beitrag #4
RE: I²C vom NANO zum PI Probleme mit High/Low Bit
Ohne Sketch auf dem NANO und die Leseroutine auf dem PI kann man da wenig dazu sagen. Grundsätzlich arbeiten die aber erstmal mit einzelnen Bytes, zumindest auf der Empängerseite, wenn Du ihm nix anderes beibringst.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.02.2016, 00:00 (Dieser Beitrag wurde zuletzt bearbeitet: 29.02.2016 00:07 von hotsystems.)
Beitrag #5
RE: I²C vom NANO zum PI Probleme mit High/Low Bit
Zitat:Ja Richtig aber da es ein integer ist bin ich davon ausgegangen das zumindest der Nano es auch so sendet wie er es auch im Serial Monitor zeigt...
Das heißt ja nicht, dass es auch per I2C in einem Stück gesendet werden kann.

Lies die mal den Beitrag durch:

http://hlembke.de/arduinoablage/crate.php?20150411i2c

Da wirst du lesen, das pro "einfacher" Übertragung nur ein Byte gesendet wird. Du musst deine Daten also aufteilen, damit du alles übertragen kannst.

Dazu findest du dann Antworten hier:
http://www.arduinoforum.de/arduino-Threa...ave-Sender

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Gruß Dieter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Mehrere Ausgänge mit einem Befehl auf High oder Low setzen dahans 1 207 10.01.2018 12:48
Letzter Beitrag: Tommy56
  Probleme mit der Software Thor Wallhall 8 357 31.12.2017 11:34
Letzter Beitrag: Tommy56
  Makeblock mit Scratch programmieren- Probleme Keinen Schimmer 17 3.688 30.12.2017 00:40
Letzter Beitrag: koma1965
  Probleme Serieller Kommunikation Arduino Nextero 13 561 12.12.2017 16:47
Letzter Beitrag: hotsystems
  Arduino Nano mit LCD1602A Gerri3d 20 623 09.11.2017 21:19
Letzter Beitrag: Tommy56
  Probleme mit multiplexing Thor Wallhall 50 2.261 01.11.2017 21:15
Letzter Beitrag: Thor Wallhall
Sad Nano - nicht genug Speicher torsten_156 10 894 30.10.2017 21:40
Letzter Beitrag: MicroBahner
Question Mehrere HX711 an einem Arduino Nano Lambacher 59 3.012 17.10.2017 09:34
Letzter Beitrag: Tommy56
  Interrupt und I2C gibt das Probleme? Badger1875 5 478 03.10.2017 23:26
Letzter Beitrag: GuaAck
  Attiny2313 Pin auf High setzen. georg01 9 865 20.08.2017 09:20
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste