INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Hilfe - Problem beim erstellen einer Eigenen Funktion
24.05.2015, 10:31 (Dieser Beitrag wurde zuletzt bearbeitet: 24.05.2015 10:36 von raspido.)
Beitrag #1
Hilfe - Problem beim erstellen einer Eigenen Funktion
Erledigt, Fehler Gefunden. Trotzdem Danke.

Hey Leute,

ich versuche nun schon eine ganze Weile eine Funktion in Arduino zu bauen, nur er schmeißt mir nur Fehlermeldungen aus. Die Funktion selbst hat bislang noch kein wirklichen Inhalt, Es geht erstmal um das "Gerüst". Auf Dauer soll die Funktion einfach ein Parameter übergeben bekommen und dadrauf reagieren. Also sprich DigitalAusgänge setzen.

Hier mal meine Funktion:

Code:
byte melder = 1;

[...]

void setMelde(byte melder) {
  digitalWrite(melde[0], HIGH);
}

Und folgende Fehlermeldung Spuckt er aus:


Code:
Bewaesserungsstem_Version_0.1.ino:13:21: error: variable or field 'setMelde' declared void
Bewaesserungsstem_Version_0.1.ino:13:15: error: 'melder' was not declared in this scope
Bewaesserungsstem_Version_0.1.ino:119:21: error: variable or field 'setMelde' declared void
Fehler beim Kompilieren.


Kann mir jemand helfen?


Danke schon mal im voraus.

Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Zeitschaltuhr Hilfe für RTC Anfänger 4Jordy 4 46 Heute 15:23
Letzter Beitrag: MicroBahner
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 3 82 18.03.2017 13:23
Letzter Beitrag: Tommy56
  ESP8622 - 01 sendet UDP - Problem WLan Kriskind 37 2.470 14.03.2017 19:49
Letzter Beitrag: Tommy56
  Interrupt beim ESP8266 dost0011 9 302 08.03.2017 14:32
Letzter Beitrag: Tommy56
  Smart Home Webserver Basic Authentication Problem Osotastic 21 555 20.02.2017 18:00
Letzter Beitrag: Tommy56
  Hilfe bei Taster huber5093 11 302 14.02.2017 19:26
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 444 31.01.2017 20:41
Letzter Beitrag: Tommy56
  Arduino hängt beim Upload deranda 14 894 20.01.2017 16:14
Letzter Beitrag: renid55
  Led Impuls beim Taster betätigen clemens5555 11 448 17.01.2017 20:00
Letzter Beitrag: renid55
  Beim Hochladen USB Problem Nils 10 642 29.12.2016 21:05
Letzter Beitrag: renid55

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste