INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Hilfe - Problem beim erstellen einer Eigenen Funktion
24.05.2015, 10:31 (Dieser Beitrag wurde zuletzt bearbeitet: 24.05.2015 10:36 von raspido.)
Beitrag #1
Hilfe - Problem beim erstellen einer Eigenen Funktion
Erledigt, Fehler Gefunden. Trotzdem Danke.

Hey Leute,

ich versuche nun schon eine ganze Weile eine Funktion in Arduino zu bauen, nur er schmeißt mir nur Fehlermeldungen aus. Die Funktion selbst hat bislang noch kein wirklichen Inhalt, Es geht erstmal um das "Gerüst". Auf Dauer soll die Funktion einfach ein Parameter übergeben bekommen und dadrauf reagieren. Also sprich DigitalAusgänge setzen.

Hier mal meine Funktion:

Code:
byte melder = 1;

[...]

void setMelde(byte melder) {
  digitalWrite(melde[0], HIGH);
}

Und folgende Fehlermeldung Spuckt er aus:


Code:
Bewaesserungsstem_Version_0.1.ino:13:21: error: variable or field 'setMelde' declared void
Bewaesserungsstem_Version_0.1.ino:13:15: error: 'melder' was not declared in this scope
Bewaesserungsstem_Version_0.1.ino:119:21: error: variable or field 'setMelde' declared void
Fehler beim Kompilieren.


Kann mir jemand helfen?


Danke schon mal im voraus.

Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Fehlermedungen beim Kompilieren Franz54 7 126 07.12.2016 14:29
Letzter Beitrag: Pit
  Ausschaltverzögerung bei einer PV Heizung Hans_Maulwurf 27 749 29.11.2016 23:38
Letzter Beitrag: georg01
  Hilfe: IR Remote Steuerung, MSGEQ7 + RGB-LED Streifen dastob 1 125 14.10.2016 21:40
Letzter Beitrag: hotsystems
Sad Ich brauche Hilfe Prosac 4 238 09.10.2016 18:39
Letzter Beitrag: Prosac
  Problem mit SD Card Library BennIY 4 197 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Fehler beim Kompilieren binderj1 5 297 03.10.2016 21:27
Letzter Beitrag: hotsystems
  at24c256 Hilfe Gandalf 6 249 29.08.2016 18:59
Letzter Beitrag: MKc
Smile Progammier Neuling Codeschloss bittet um Hilfe Donalonso 2 288 27.08.2016 18:23
Letzter Beitrag: Binatone
  Fehler beim Speichern von Projekten Manni66 16 696 23.08.2016 10:05
Letzter Beitrag: hotsystems
  Problem mit SD.remove Eichner 6 212 22.08.2016 19:42
Letzter Beitrag: Eichner

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste