INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
HIGH statt LOW
25.05.2015, 12:56
Beitrag #17
RE: HIGH statt LOW
(25.05.2015 12:36)bergfrei schrieb:  Lieber Bk.
dein Wunsch war mir schon vorher Befehl.
Also hier 2 Bilder. Du siehst nix als Arduino und Relais
und den Sketch.
5 Sekunden an (obwohl LOW)
1 Sekunde aus (obwohl HIGH)

Danke (du haust dich wirklich ins Zeugs Smile ) und Grüßle
Gerd

-----

// give it a name:
int versorg = 8;

void setup() {
// initialize the digital pin as an output.
pinMode(versorg, OUTPUT);


}

// the loop routine runs over and over again forever:
void loop() {
digitalWrite(versorg, LOW); // turn the LED on (HIGH is the voltage level)

delay(5000);


// wait for a second
digitalWrite(versorg, HIGH); // turn the LED off by making the voltage LOW
delay(1000);

}

...nette Bilder...NUR das was wichtig ist ist im Schatten...wie ein UNO aussieht weis ich...
ABER man sieht das da Widerstände auf dem Board sind...ergo dürften da auch Transistoren drauf sein. Miss doch mal die Spannung an einem IN Pin von der Relaisplatine gegen GND wenn außer den 5V und GND nichts angeschlossen ist....also die Eingänge offen sind.

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.05.2015, 13:26
Beitrag #18
RE: HIGH statt LOW
Sorry ... ich kann nirgendwo einen Widerstand sehen...
Also, wenn Relay schaltet habe ich Pin 8 - 4,4 Volt in delay Zeit 0,5 Volt
wenn Relay nicht schaltet, also delay Zeit, PIN 4,4 Volt - 0,5 Volt
Also HIGH = - 4,4 Volt
oder LOW = 4,4 Volt

Das kann nur am Relay liegen.
Gruß Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.05.2015, 13:34
Beitrag #19
RE: HIGH statt LOW
(25.05.2015 13:26)bergfrei schrieb:  Sorry ... ich kann nirgendwo einen Widerstand sehen...
Also, wenn Relay schaltet habe ich Pin 8 - 4,4 Volt in delay Zeit 0,5 Volt
wenn Relay nicht schaltet, also delay Zeit, PIN 4,4 Volt - 0,5 Volt
Also HIGH = - 4,4 Volt
oder LOW = 4,4 Volt

Das kann nur am Relay liegen.
Gruß Gerd

gut ich wollte es zwar ohne Port wissen...aber 4,4V deuten darauf hin das auf dem Relaisboard ein PNP Transistor das Relais schaltet...im übrigen linst so ein SMD Transi auf deinem Bildchen ein bischen raus...Big Grin
Und dann ist das ganz normal das dein Relais eingeschaltet wird wenn du den Ausgang auf LOW setzt. Kannst du auf dem einen Link von mir nachsehen...

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.05.2015, 15:59 (Dieser Beitrag wurde zuletzt bearbeitet: 25.05.2015 16:08 von fraju.)
Beitrag #20
RE: HIGH statt LOW
http://www.microsofttranslator.com/bv.as...or-arduino
http://www.thanksbuyer.com/2ch-2-channel...p430-16357
Hier etwas genaueres.
Wenn über ein Teil Diskutiert wird sin genauere Inf. immer hilfreich.
Wenn das Teil keine Transen hätte ,wäre der Arduino schon defekt.

Auf der leiterplatte ist zu erkennen pro Kanal.
Leuchtdiode smd-R
Transe SMD Basis_R
vielleicht noch ein SMD-R Basis Masse
Diode

Vielleicht sucht mal einer den Bestückung und Schaltplan damit
das Problem 100% erledigt ist.
Man kann auch die Karte ausmessen.
Gruß.

Nicht jeder Neuling in einem Forum hat keine Ahnung über die Materie!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.05.2015, 16:20
Beitrag #21
RE: HIGH statt LOW
(24.05.2015 20:45)Bitklopfer schrieb:  
(24.05.2015 20:37)bergfrei schrieb:  ....
Ich weiß, dass es sowas gibt aber ich nix finden wo irgend was invertiert wird.
Habe eben ein Bild vom Netz geklaut - genau so eins isses.
Hab noch ein paar schöne Stunden.
Gruß Gerd

ähm hast du vielleicht auch noch nen Link von wo du das Teil bezogen hast ?

ich habe nun Zwei Versionen gefunden,
die wo sich verhält wie deine,
und diese Version die deinem Bild entspricht. Nur diese Version schaltet bei einem HIGH...die Schaltbilder dazu gibt es hier.
also das kommt dann wirklich darauf an das man die genauen Daten hat...Big Grin
lg
bk

(24.05.2015 22:07)RMR schrieb:  Ich weiss nicht wie die Eingäge dieser Platine aussehen, aber kann es sein, dass du zufällig den GND auf deinen Ausgang gelegt hast? Die Ausgänge können natürlich auch als Senke arbeiten.
Dann wäre bei HIGH kein Potentialunterschied, dein Relais wäre offen, bei LOW würde dein Relais anziehen.

VG, Ralf aka RMR.... der sich besser um seine RealTrashClock kümmern sollte. Wink

(25.05.2015 10:03)fraju schrieb:  Hallo
Wie man hier sieht ,merkt man schnell wie wichtig eine Zeichnung ist.
Es kann auch eine ASCII Zeichnung sein.
Die Relais werden doch bestimmt mit einen Transistor angesteuert, welcher im diesen Falle das Steuersignal negiert!

Code:
5V
                                   |
                                  Relais
                                   |
                                   o--
                                 |/
      Arduinio           ---1 k--|
                                 |>
                                   |
                                   |
    GND ----------------o----------o---- GND


ASCII Test

(25.05.2015 10:14)bergfrei schrieb:  " Alter Knacker " Aber Erfahrung ..... Junge wie recht du hast. Weshalb kommst jetzt erst ??? Big Grin
Ich müsste also einen PNP Transistor nehmen (oder NPN als Kollektorschaltung. ??)
Richtig ??
Dir ein großes Dankeschön.
Werde in Zukunft immer schöne Zeichnungen anfertigen - versprochen -
Schöner Pfingsttag
Gerd

(25.05.2015 10:51)Bitklopfer schrieb:  
(25.05.2015 10:14)bergfrei schrieb:  ..... Weshalb kommst jetzt erst ??? Big Grin
......

ähm du hättest nur mal meine Links die ich dir auf der ersten Seite gegeben habe auswerten müßen...dann hättest alles gesehen...Big GrinBig GrinBig Grin

(25.05.2015 11:09)HaWe schrieb:  ... und ich würde (wieder mal) aus dem Bauch heraus zwischen Basis und 1k Vorwiderstand noch einen Pulldown-Widerstand legen (10k ? 100 k?) , damit die Basis nicht in der Luft hängt - oder liege ich hier falsch ?

(25.05.2015 13:34)Bitklopfer schrieb:  
(25.05.2015 13:26)bergfrei schrieb:  Sorry ... ich kann nirgendwo einen Widerstand sehen...
Also, wenn Relay schaltet habe ich Pin 8 - 4,4 Volt in delay Zeit 0,5 Volt
wenn Relay nicht schaltet, also delay Zeit, PIN 4,4 Volt - 0,5 Volt
Also HIGH = - 4,4 Volt
oder LOW = 4,4 Volt

Das kann nur am Relay liegen.
Gruß Gerd

gut ich wollte es zwar ohne Port wissen...aber 4,4V deuten darauf hin das auf dem Relaisboard ein PNP Transistor das Relais schaltet...im übrigen linst so ein SMD Transi auf deinem Bildchen ein bischen raus...Big Grin
Und dann ist das ganz normal das dein Relais eingeschaltet wird wenn du den Ausgang auf LOW setzt. Kannst du auf dem einen Link von mir nachsehen...

Hast recht --- auf dem Port linsen sogar 2 SMD raus Smile
Dann wissen wir was Sache ist - ohne Bk und Lupe wäre mir das nie aufgefallen.
Bk..... ich danke dir. Dass es am Relais liegt war mir klar. Doch weshalb macht man so was ?? ich meine PNP Trans....
Grüße Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.05.2015, 16:25
Beitrag #22
RE: HIGH statt LOW
(25.05.2015 16:20)bergfrei schrieb:  ...
Dann wissen wir was Sache ist - ohne Bk und Lupe wäre mir das nie aufgefallen.
Bk..... ich danke dir. Dass es am Relais liegt war mir klar. Doch weshalb macht man so was ?? ich meine PNP Trans....
Grüße Gerd

..also Gerd, wenn ich schon mal was sage dann darfste mir das nach über 40 Jahren Berufserfahrung in Sachen Elektronik ruhig glauben...und da ist so eine Relaisansteuerung noch das simpelste was bei mir schon durchlief...Wink
Warum man das sooo macht ?...das ist die Freiheit des Designers...kein Mensch zwingt einen seine Version zu benutzen. Wie schon gezeigt gibt es beide Versionen.
Und btw. diese Version mit PNP Transistor darfst du so nicht an einem DUE, Raspberry Pi wo mit 3,3V läuft verwenden weil da sonst der Port wahrscheinlich sofort stirbt.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.05.2015, 22:58
Beitrag #23
RE: HIGH statt LOW
Danke, danke, danke ,,,,, PNP lasse ich wech habe genügend NPN die müßen zuerst verschossen werden....Big Grin
Liebe Grüße
Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.05.2015, 05:49
Beitrag #24
RE: HIGH statt LOW
(25.05.2015 22:58)bergfrei schrieb:  Danke, danke, danke ,,,,, PNP lasse ich wech habe genügend NPN die müßen zuerst verschossen werden....Big Grin
Liebe Grüße
Gerd

öhm dir ist aber schon klar das du die PNP's auf deiner Relaisplatine nicht einfach gegen NPN's tauschen kannst ?...da passt die übrige Beschaltung nämlich nicht...

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Statt 1 SMS gleich unendliche bergfrei 7 171 17.10.2016 18:49
Letzter Beitrag: bergfrei
  I²C vom NANO zum PI Probleme mit High/Low Bit Tobias1984 4 329 29.02.2016 00:00
Letzter Beitrag: hotsystems
  EMP setzt Input-PIN kurzzeitig auf HIGH holo 6 448 24.02.2016 19:25
Letzter Beitrag: Carlo
  OUTPUT bleibt HIGH und timer stopt nicht. Atwist 4 530 08.01.2016 11:02
Letzter Beitrag: Atwist
  Ir Signal bei High gronph 7 802 01.11.2015 18:49
Letzter Beitrag: gronph
  mit #ifdef Taster high-aktiv / low-aktiv ?? DL1AKP 11 1.347 24.06.2015 12:50
Letzter Beitrag: HaWe
  Multitasking mit millis statt delay LEDstar 2 1.245 15.04.2015 11:25
Letzter Beitrag: Bitklopfer
  PIR- High - Low - Wechsel und void MaHa1976 18 1.513 28.03.2015 02:04
Letzter Beitrag: Homer
  Lüfter mit LM35 über HIGH & LOW statt PWM Problem bhvfotos 0 1.178 09.11.2013 12:53
Letzter Beitrag: bhvfotos

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste