INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
HC-SR04 Alarmsketch läuft nicht richtig auf Digispark
31.12.2020, 13:13
Beitrag #9
RE: HC-SR04 Alarmsketch läuft nicht richtig auf Digispark
(30.12.2020 17:46)hotsystems schrieb:  Da es vermutlich nicht der Sketch ist, wäre mein letzter Tipp die Taktfrequenz des ATtiny85. Wie ist der ATtiny85 vom Bootloader her geflasht und mit welchem Takt flashst du den Sketch ?

Hallo
Danke für die Tipps.
Ich programmiere mit der Arduino IDE, da ist nur 16.5 MHz möglich.
Vielleicht kommt der ATTiny mit der Library nicht klar, werde mal den Sketch umschreiben, ob das hilft?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
31.12.2020, 13:53
Beitrag #10
RE: HC-SR04 Alarmsketch läuft nicht richtig auf Digispark
(31.12.2020 13:13)tapsi schrieb:  Hallo
Danke für die Tipps.
Ich programmiere mit der Arduino IDE, da ist nur 16.5 MHz möglich.
Vielleicht kommt der ATTiny mit der Library nicht klar, werde mal den Sketch umschreiben, ob das hilft?

Stimmt, ist ja ein digispark.
Ich könnte mir vorstellen, das der keinen korrekten Bootloader drauf hat. Also da die Taktfrequenz nicht stimmt.
Teste doch mal mit einem Blink-Sketch mit 1000 msek.
Ob der auch im Sekundentakt blinkt.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Bibliothek einbinden funktioniert nicht Maxcruiser 5 119 18.04.2021 21:31
Letzter Beitrag: Tommy56
  Nano. Sketch kann nicht hochgeladen werden 4heiner 4 310 02.04.2021 17:21
Letzter Beitrag: 4heiner
  Programm startet bei Neustart nicht Moritzzz 18 716 02.04.2021 14:06
Letzter Beitrag: Tommy56
  Arduino Ampelschaltung Taster funktioniert nicht fatihakan36 9 707 13.03.2021 22:06
Letzter Beitrag: N1d45
  Library Ethernet: Nicht zu compilieren GuaAck 5 463 22.02.2021 17:31
Letzter Beitrag: Tommy56
  von delay auf millis umgestellt, klappt nur nicht. Servo Geschwindigkeit einstellen. gutschy 8 731 21.02.2021 15:22
Letzter Beitrag: gutschy
  MMega2560-Clone läßt sich nicht programmieren kpc 8 643 08.02.2021 09:50
Letzter Beitrag: hotsystems
  If-Schleife wird nicht mehr durchlaufen LK2567 2 404 05.02.2021 21:20
Letzter Beitrag: LK2567
  Tasterabfrage funktioniert nicht Moehn 4 546 05.02.2021 15:23
Letzter Beitrag: Moehn
  Kompiler beschwert sich nicht, LC-Display macht aber nicht, was es soll. generic_user492 3 433 26.01.2021 14:11
Letzter Beitrag: MicroBahner

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste