INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Gassensor reagiert nicht mehr!!
12.02.2014, 11:07
Beitrag #1
Gassensor reagiert nicht mehr!!
Hallo,

ich bin ganz neu hierSmile und brauche eure Hilfe.
Um die VOC Konzentration in Prüfkammer zu messen habe ich ein Figaro TGS 2602 benutzt.
Ich habe alles aufgebaut und programmiert (ohne Kalibrierung), nachdem ich darauf gepustet habe (zum Testen) reagiert der Sensor nicht mehr, es ist auf den Wert 1022 geblieben.

Habe ich etwas falsch gemacht? Warum ist der Wert so hoch?
Wie kann ich das kalibrieren (Datasheet habe ich schon gelesen, aber verstehe trotzdem nicht)?

Ich will auch alle Werten (von verschiedenen Kammer) über WiFi am Computer in nur einem Fenster visualisieren . Was ist zu empfehlen?

ich warte auf eure Antwort

Vielen Dank
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.02.2014, 14:16 (Dieser Beitrag wurde zuletzt bearbeitet: 12.02.2014 14:29 von Sloompie.)
Beitrag #2
RE: Gassensor reagiert nicht mehr!!
(12.02.2014 11:07)florianagr schrieb:  Hallo,

ich bin ganz neu hierSmile und brauche eure Hilfe.
Um die VOC Konzentration in Prüfkammer zu messen habe ich ein Figaro TGS 2602 benutzt.
Ich habe alles aufgebaut und programmiert (ohne Kalibrierung), nachdem ich darauf gepustet habe (zum Testen) reagiert der Sensor nicht mehr, es ist auf den Wert 1022 geblieben.

Habe ich etwas falsch gemacht? Warum ist der Wert so hoch?
Wie kann ich das kalibrieren (Datasheet habe ich schon gelesen, aber verstehe trotzdem nicht)?

Ich will auch alle Werten (von verschiedenen Kammer) über WiFi am Computer in nur einem Fenster visualisieren . Was ist zu empfehlen?

ich warte auf eure Antwort

Vielen Dank


Moin

ich bin selbst Anfänger und stell mir bei Deinem langen Text die Frage? wie hat er den Sensor denn nun angeschlossen - an welchem Board? Nutzt Du ein Mini, Uno, Mega oder vielleicht schon den Yun?

Anfangs dachte ich ja mmh der kennt sich aus - hat das Datashield gelesen (vom Sensor und sicher auch den und den Schaltplan des verwendeten Boards).

Da Du ja noch mehr vor hast - gehe ich einfach davon aus, dass Du Erfahrung mit Arduino hast.
Zitat:Habe ich etwas falsch gemacht?
Das herauszufinden - ich glaube, da brauchen selbst die Fachleute und Hellseher hier entweder die berühmte Kristallkugel - die ist aber auch auf den asiatischen Märkten leider nicht so einfach zu erwerben - oder ein bissel mehr input.

Welches Board? nutzt Du
wie sieht Dein Code denn nun genau aus?
und interessant - sicher - wie hoch ist der normale Wert in der Kammer?

Zitat:Ich will auch alle Werten (von verschiedenen Kammer) über WiFi am Computer in nur einem Fenster visualisieren . Was ist zu empfehlen?

Dein Projekt geht ja noch ein bissel weiter - aber um Dein Problem erst mal zu lösen, solltest Du am besten mit Hilfe der # (findest Du oben beim Menu- wenn Du schreibst)
Code:
Deinen Code Sketch ähnliche hier posten

Und das verwendete Board mitteilen. denn das erleichtert dann auch die Antwortarbeiten der Genies hier, für Dein weiteres Projekt.
Und die wenigen, aber wie ich sehe vorhanden Kristallkugeln, hier können noch weiterhin für einfachere Lösungen genutzt werden.

Smile
Nicht übel nehmen - man hilft Dir hier gern.
Aber bissel mehr input ist wirklich manchmal nötig.
Ach ja - den Sensor hast Du ja sicher bewusst für das Projekt ausgesucht - oder?
Welche Probleme hast Du mit dem DataShied?
Denn die Probleme, die Du nun schon hast - hättest Du vielleicht vor Kauf schon durch Lesen und Nachfragen beheben können.

Mit dem Datenblatt ist es meiner Meinung nach, wie mit einem Schaltplan. Wink
Für alle Kristallkugelnutzer im Forum, so weit ich es erkennen, aber bin nur eine kleine Hexe handelt es sich um das folgende Datenblatt was er nicht versteht:

Datashied Figaro TGS 2611

Dimidium facti, qui coepit, habet: SAPERE AUDE, incipe!©Horaz

Vor allem sapere aude! oder wie Immanuel Kant sagt:
"Habe Mut, dich deines eigenen Verstandes zu bedienen!"

Es tut auch nicht weh! Daher: incipe! oder Tu es! wie Yoda sagen würde.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.02.2014, 14:36
Beitrag #3
RE: Gassensor reagiert nicht mehr!!
Hi Sloompie,

du hast recht, ich habe nicht viel input gegeben.

Ich benutze ein Arduino UNO und bin noch ganz neu bei diesem Thema ARDUINO.
Im Rahmen eines Projekts muss ich VOC Gaskonzentration (mit Figaro TGS 2602) in mehreren Prüfkammern messen und es später par WiFi am Computer über GUI visualisieren.

Vor 3 Stunden habe ich mit Messugen angefangen und der Sensor hatte nicht richtig reagiert. Deshalb habe ich hier im Forum geschrieben.

Gott sei Dank habe ich vor ein paar Minuten das Problem gelöst, falsche Potentiometer wurde benutzt.

Eigentlich soll ich auch den Sensor kalibrieren, aber ich weiß es nicht wie es zu machen ist.

Ich habe noch keinen Code für WiFi geschrieben. (ich weiß nicht wie ich anfangen soll).

Hoffentlich habe ich viel mehr erzählt.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.02.2014, 20:01 (Dieser Beitrag wurde zuletzt bearbeitet: 12.02.2014 20:02 von Sloompie.)
Beitrag #4
RE: Gassensor reagiert nicht mehr!!
(12.02.2014 14:36)florianagr schrieb:  Hi Sloompie,

du hast recht, ich habe nicht viel input gegeben.

Ich benutze ein Arduino UNO und bin noch ganz neu bei diesem Thema ARDUINO.
Im Rahmen eines Projekts muss ich VOC Gaskonzentration (mit Figaro TGS 2602) in mehreren Prüfkammern messen und es später par WiFi am Computer über GUI visualisieren.

Vor 3 Stunden habe ich mit Messugen angefangen und der Sensor hatte nicht richtig reagiert. Deshalb habe ich hier im Forum geschrieben.

Gott sei Dank habe ich vor ein paar Minuten das Problem gelöst, falsche Potentiometer wurde benutzt.

Eigentlich soll ich auch den Sensor kalibrieren, aber ich weiß es nicht wie es zu machen ist.

Ich habe noch keinen Code für WiFi geschrieben. (ich weiß nicht wie ich anfangen soll).

Hoffentlich habe ich viel mehr erzählt.

Smile
Super und da Du selber drauf gekommen bist - wird Dir der Fehler nie wieder passieren - und solltest Du es mir mal erklären müssen oder irgendwem anderes, wirst Du genau darauf hinweisen...
Ist doch was - find ich gut.

Das mit dem Wifi - sicher hast gemerkt das das Uno keinen Wlan Anschluss integriert hat. (bei weiterfolgenden Boards gibt es die Möglichkeiten aber wir sind hier ja beim UNO)

Nu - das ist das tolle am Arduino und der Denkweise - es gibt für vieles Lösungen in ShieldForm - so dass jeder, SEINE Idee anpassen kann.
bei Exp-Tech und Watterott findest Du sicher das passende.
ich hab hier mal zwei Beispiele rausgesucht dort findest Du auch in der Beschreibung alles, was Du eigentlich brauchst um das in Gang zu bekommen Smile

Wifi Shield



oder hier:

Wifi Shield

Ein Tipp so am Rande: Bei den Arduino Bauteilen sind die Händler und Hersteller sehr offen mit der Software - kein Wunder - ist ja der Grundgedanke von OPEN Smile
Somit findest Du schon vor dem Kauf jede Menge Infos, Datenblätter Schaltpläne, ja und oft auch schon Codes/Sketche, die Du nur anpassen musst.
und weisst, was für Deine Bedürfnisse das Beste ist - schon vorm Kauf.
Fragen hier oder direkt bei den Händlern schadet meistens auch nichts - ich hab da bisher - selbst mit meinen Anfängerfragen immer eine gute Antwort bekommen.

Da Du Deine Probleme schon alleine löst - denk ich ma,l Du hast als Arduino Neuling das hier schon gefunden?

Viel Erfolg !!

Dimidium facti, qui coepit, habet: SAPERE AUDE, incipe!©Horaz

Vor allem sapere aude! oder wie Immanuel Kant sagt:
"Habe Mut, dich deines eigenen Verstandes zu bedienen!"

Es tut auch nicht weh! Daher: incipe! oder Tu es! wie Yoda sagen würde.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
13.02.2014, 08:19
Beitrag #5
RE: Gassensor reagiert nicht mehr!!
Hi Sloompie,

ich hatte dieses Buch noch nicht.

Vielen Dank
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Bluetooth-Steuerung mit elegoo uno funktioniert nicht Matthias_Arduino 0 140 01.11.2016 19:47
Letzter Beitrag: Matthias_Arduino
  Motor reagiert nur auf 5 Volt Flap 18 487 22.10.2016 10:31
Letzter Beitrag: hotsystems
  Pin 5 an Pro Micro funktioniert nicht scritch 1 167 07.09.2016 13:54
Letzter Beitrag: ardu_arne
  Nema 17 Schrittmotor läuft an a4988 nicht fagus 9 578 04.08.2016 20:12
Letzter Beitrag: fagus
  LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr emduino 2 227 26.07.2016 20:42
Letzter Beitrag: hotsystems
  Uno gehen zwei digital Pins nicht edlosijagen 15 591 07.07.2016 19:22
Letzter Beitrag: Bitklopfer
  IFLZ44N schaltet nicht korrekt? torsten_156 22 1.012 25.04.2016 13:53
Letzter Beitrag: Bitklopfer
  HC-06 Bluetooth verbindung geht nicht BennIY 0 643 21.03.2016 20:32
Letzter Beitrag: BennIY
  mehr PWM Pins WIMunios 8 1.106 20.03.2016 00:19
Letzter Beitrag: hotsystems
  Pro Micro bootet nicht richtig. linuxpaul 3 621 02.03.2016 18:45
Letzter Beitrag: linuxpaul

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste