INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
GSM-Shield empfängt keine SMS mehr
11.10.2013, 23:58
Beitrag #1
GSM-Shield empfängt keine SMS mehr
Hallo,
ich hatte das GSM-Modul "GSM R3" (in Zusammenarbeit mit Telefonica) bis gestern in Benutzung. Plötzlich nimmt es keine neuen SMS mehr an.
Folgendes Testprogramm zeigt das Vorhandensein von 2 ungelesenen SMS an.
while (sms.available())
{
Serial.println("Message received from:");
sms.remoteNumber(senderNumber, 20);
Serial.println(senderNumber);
sms.flush();
Serial.println("Message geloescht");
}

sms.flush() bewirkt aber nichts, die SMS sind in der nächsten Schleife immer noch da. Neue werden ignoriert. Der Text der SMS wird mit dem entsprechenden Beispielprogramm nicht angezeigt.
Es scheint, dass der interne Speicher voll ist und sms.flush() nichts bewirkt.

Weiß jemand Rat?

Grüße
Jan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.10.2013, 10:39
Beitrag #2
RE: GSM-Shield empfängt keine SMS mehr
Nach langem Experimentieren habe ich die Antwort selbst gefunden.
Für die, die es interessiert: Auf meiner Karte war tatsächlich eine SMS, bei deren Empfang der Arduino offensichtlich abgestürzt ist (oder wurde). Die Karte im Arduino wartet seit dem auf den Text der SMS und empfängt keine weiteren.
In einem normalen Handy werden keine alten SMS angezeigt, da funktioniert auch alles. Erst in meinem neuen LTE-Router wurde die "verklemmte" SMS angezeigt und ließ sich löschen.
Jetzt geht wieder alles.

Gruß
Jan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  MP3 VS1053 shield Geeros#18 11 414 15.04.2018 13:37
Letzter Beitrag: hotsystems
  Keine Kalibrierung möglich Tudorf 1 278 16.03.2018 10:46
Letzter Beitrag: Tudorf
  328P geht nicht mehr [gelöst] Harry 37 2.662 04.03.2018 19:57
Letzter Beitrag: Harry
  Arduino Mega mit Shield und 7" Touch Tudorf 10 608 25.02.2018 14:30
Letzter Beitrag: Tommy56
  [gelöst] Micro SD-Card Shield an ISP? torsten_156 1 244 08.02.2018 22:24
Letzter Beitrag: Tommy56
  ILI9341 MEGA2560 keine BMP anzeige tillmg 4 369 08.02.2018 20:18
Letzter Beitrag: georg01
Bug I2C Displays wollen nicht mehr Der Ausserirdische 12 823 30.12.2017 17:11
Letzter Beitrag: hotsystems
  Motor Shield V3 Analog Digital Converter Nextero 5 539 19.12.2017 10:54
Letzter Beitrag: Nextero
  Aptotec V1.2 Can Bus Shield / Auto Marc2014 23 2.069 01.11.2017 07:30
Letzter Beitrag: Bitklopfer
  Kommunikation über das WiFi-Shield Flap 13 1.983 12.09.2017 22:12
Letzter Beitrag: Flap

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste