INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
GSM-Shield empfängt keine SMS mehr
11.10.2013, 23:58
Beitrag #1
GSM-Shield empfängt keine SMS mehr
Hallo,
ich hatte das GSM-Modul "GSM R3" (in Zusammenarbeit mit Telefonica) bis gestern in Benutzung. Plötzlich nimmt es keine neuen SMS mehr an.
Folgendes Testprogramm zeigt das Vorhandensein von 2 ungelesenen SMS an.
while (sms.available())
{
Serial.println("Message received from:");
sms.remoteNumber(senderNumber, 20);
Serial.println(senderNumber);
sms.flush();
Serial.println("Message geloescht");
}

sms.flush() bewirkt aber nichts, die SMS sind in der nächsten Schleife immer noch da. Neue werden ignoriert. Der Text der SMS wird mit dem entsprechenden Beispielprogramm nicht angezeigt.
Es scheint, dass der interne Speicher voll ist und sms.flush() nichts bewirkt.

Weiß jemand Rat?

Grüße
Jan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.10.2013, 10:39
Beitrag #2
RE: GSM-Shield empfängt keine SMS mehr
Nach langem Experimentieren habe ich die Antwort selbst gefunden.
Für die, die es interessiert: Auf meiner Karte war tatsächlich eine SMS, bei deren Empfang der Arduino offensichtlich abgestürzt ist (oder wurde). Die Karte im Arduino wartet seit dem auf den Text der SMS und empfängt keine weiteren.
In einem normalen Handy werden keine alten SMS angezeigt, da funktioniert auch alles. Erst in meinem neuen LTE-Router wurde die "verklemmte" SMS angezeigt und ließ sich löschen.
Jetzt geht wieder alles.

Gruß
Jan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Code aus 1.6.9 geht mit 1.8.1 nicht mehr zu kompilieren DL1AKP 7 291 02.02.2017 12:16
Letzter Beitrag: Tommy56
  Can-Bus Shield ok, aber keine Daten Clubsport 52 2.659 26.01.2017 16:32
Letzter Beitrag: Tommy56
  nRF24l01 empfängt Daten nicht techniclover 1 193 09.01.2017 19:20
Letzter Beitrag: celle
  [Gelöst] SD Card (Ethernet Shield) IO funktioniert nicht __jb__ 7 450 05.01.2017 09:51
Letzter Beitrag: rpt007
  CP2102 und USB Host Shield ?? DL1AKP 0 113 01.12.2016 08:55
Letzter Beitrag: DL1AKP
  Arduino UNO und Ethernet Shield 2 POE und Fritzbox 3272 tr3 2 293 19.11.2016 10:46
Letzter Beitrag: tr3
  Kommunikation über das WiFi-Shield Flap 3 345 07.11.2016 20:20
Letzter Beitrag: hotsystems
  Arduino Lan Shield - Visual Basic ZackiE 6 285 20.09.2016 19:26
Letzter Beitrag: ZackiE
  adafruit V2.3 Shield Hangloose 6 419 08.09.2016 17:13
Letzter Beitrag: rpt007
Question Keine Verbindung via USB nach flashen des Programms chaoscrack 5 278 23.08.2016 14:58
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste