INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Funduino Mega 2560 LCD Problem
16.02.2015, 20:14
Beitrag #1
Sad Funduino Mega 2560 LCD Problem
Hey Leute,
bin jetz seid fast 3 Stunden in allen möglichen Foren, auf Youtube und generell im Internet unterwegs da ich ein ganz doofes Problem habe. Ich habe mir das Funduino Mega Set gekauft und bin wirklich sehr zufrieden damit, Qualität wirkt für den preis super und der Controller wirkt auf mich funktionsfähig.

Mein Problem ich bekomme das LCD Display einfach nicht zum laufen, ich habe jetz schon so gut wie alles versucht was ich im Internet gefunden habe, aber vielleicht weiß hier ja jemand eine funktionierende Antwort zu geben Smile. Ich habe das Display nach dieser Anleitung bzw. Schaltplan angeschlossen: Funduino - LCD Display es geht auch an, und die Hintergrundbeleuchtung funktioniert ebenfalls. Mein Problem jedoch ist das ich einfach einen weißen Balken über das Display habe und es keine Buchstaben Zahlen etc. anzeigt. Ich habe bisher die Pins für D4-D7 gewechselt, andere Kabel benutzt, Lötstellen auf Sitz überprüft,Das Potentiometer durch einen 200ohm widerstand ersetzt... Sobald ich den Enabler herausziehe verschwindet der Balken, stecke ich ihn wieder hinein erscheint er wieder.

So sieht es bei mir auf dem Display aus:
[Bild: IMAG0235.jpg]
"Das ist nicht mein Bild das habe ich bei Google Bilder gefunden.

Hier mein Sketch:
// include the library code:
#include <LiquidCrystal.h>

// initialize the library with the numbers of the interface pins
LiquidCrystal lcd(12, 11, 5, 4, 3, 2);

void setup() {
// set up the LCD's number of columns and rows:
lcd.begin(16, 2);
// Print a message to the LCD.
lcd.print("hello, world!");
}

void loop() {
// set the cursor to column 0, line 1
// (note: line 1 is the second row, since counting begins with 0):
lcd.setCursor(0, 1);
// print the number of seconds since reset:
lcd.print(millis() / 1000);
}

Ich hoffe jemand weiß eine Antwort ^^ ich bedanke mich schon mal sehr im vorraus.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.02.2015, 23:15
Beitrag #2
RE: Funduino Mega 2560 LCD Problem
Probier !! Huh und vergiss nicht das richtige Board zu wählen.
Viel Spass
Gerd


#include <LiquidCrystal.h>

LiquidCrystal lcd(8, 13, 9, 4,5,6,7); // diese Pins werden benutzt

void setup()
{

lcd.clear(); // LCD löschen
lcd.begin(16, 2); // verfügbare Spalten und Zeilen

lcd.setCursor(0,0); // 0. Spalte (= ganz links) und 0. Zeile (= oben)
lcd.print("Das müßte klappen");

lcd.setCursor(0,1);
lcd.print("wenn nicht, schmeiß weg");

}


void loop()
{

}

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.02.2015, 23:43 (Dieser Beitrag wurde zuletzt bearbeitet: 16.02.2015 23:44 von King-Bobman.)
Beitrag #3
RE: Funduino Mega 2560 LCD Problem
Hallo freddy,
so ist alles in Ordnung, du musst nur noch mit einem Drehregler das Display runterregeln.
Siehe fundino.de Nr. 13
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.02.2015, 09:30
Beitrag #4
RE: Funduino Mega 2560 LCD Problem
Hallo King,
ich bin nicht Freddy, ich bin bergfrei.
Hoffentlich liest das Freddy1996
LG
Gerd - und BergfreiTongue

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  MEGA 2560 mit 5V 12A Netzteil betreiben möglich? Nafetz 18 515 11.11.2016 05:59
Letzter Beitrag: peterfido
Bug Hardware Problem (!) Gandalf 34 838 06.11.2016 07:29
Letzter Beitrag: Pardini
  3 Arduino Mega, 2 Sender 1 Empfänger claudius 22 650 18.10.2016 17:32
Letzter Beitrag: Pardini
  Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle MSchroeder 2 119 15.10.2016 22:18
Letzter Beitrag: MSchroeder
  ESP8266-01 Problem mit UDP loglo 5 382 03.08.2016 07:49
Letzter Beitrag: loglo
  Arduino 2560 p900 1 506 28.03.2016 14:04
Letzter Beitrag: hotsystems
  Zwei Ausgabeports am Mega verbinden um 50 mA Verbraucher anzuschließen ? holo 15 878 01.02.2016 13:07
Letzter Beitrag: Bitklopfer
  Arduino Mega Fehlverhalten hanse44 5 737 27.01.2016 08:25
Letzter Beitrag: hotsystems
  Problem mit adafruit motor shield Philthy 13 1.824 22.12.2015 15:27
Letzter Beitrag: hotsystems
  Pinbelegung UNO und Mega für TFT Anschluss AchDuShrek 4 1.523 19.11.2015 21:40
Letzter Beitrag: Klaus(i)

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste