INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Fehler gesucht
06.08.2015, 10:23
Beitrag #1
Fehler gesucht
Hallo Leute,
wollte einen Sensor prüfen und kopierte folgenden Sketch, der bereits lief.
Der Fehler wird gleich in Zeile 1 aufgezeigt. Big Grin
Was ist falsch ?

int sensorPin = A0;
int ledPin = 9;

int sensorValue = 0;
int schwellwert = 600;

void setup (){
pinMode (ledPin, OUTPUT);
}
void loop(){
sensorValue = analogRead (sensorPin);

if sensorValue > schwellwert) {
digitalWrite (ledPin, HIGH);
delay(1000);
digitalWrite (ledPin, LOW);
delay (1000);
}else{
}}

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.08.2015, 10:38 (Dieser Beitrag wurde zuletzt bearbeitet: 06.08.2015 10:42 von RMR.)
Beitrag #2
RE: Fehler gesucht
Das A stört. Rolleyes

So gehts:
sensorValue = analogRead(A0);
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.08.2015, 10:57
Beitrag #3
RE: Fehler gesucht
Und ich habe das Zeile für Zeile abgetippt. Kontrolliert und kontrolliert 1.1
Sketch geschrieben von einem Dipl. Ing.
Niemand ist von Fehler gefeit Smile
--- Ich danke dir ----
Gruß
Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.08.2015, 11:21 (Dieser Beitrag wurde zuletzt bearbeitet: 06.08.2015 11:22 von Bitklopfer.)
Beitrag #4
RE: Fehler gesucht
Hi,
also auf der IDE 1.0.3 läßt sich der Sketch kompilieren wenn man bei der if Abfrage die fehlende "(" Klammer hinzufügt Big Grin
Code:
int sensorPin = A0;
int ledPin = 9;

int sensorValue = 0;
int schwellwert = 600;

void setup (){
pinMode (ledPin, OUTPUT);
}
void loop(){
sensorValue = analogRead (sensorPin);

if (sensorValue > schwellwert) {
digitalWrite (ledPin, HIGH);
delay(1000);
digitalWrite (ledPin, LOW);
delay (1000);
}else{
}
}
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.08.2015, 15:35
Beitrag #5
RE: Fehler gesucht
Habe mal wieder über das Ziel geschossen - die Hitze :-)
Zu RMR das A störte nicht. Wie Bk. schrieb -- es war die fehlende Klammer ....
Bitklopfer .... ich danke dir.
Lieber Gruss
Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.08.2015, 20:25
Beitrag #6
RE: Fehler gesucht
(06.08.2015 15:35)bergfrei schrieb:  Habe mal wieder über das Ziel geschossen - die Hitze :-)
Zu RMR das A störte nicht. Wie Bk. schrieb -- es war die fehlende Klammer ....
Bitklopfer .... ich danke dir.
Lieber Gruss
Gerd

keine Ursache alter Freund...Smile
Die IDE läßt einen da mit ihren Fehlermeldungen eben im Wald stehen....ging mir anfangs auch öfters so...Sad
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.08.2015, 06:28
Beitrag #7
RE: Fehler gesucht
Bist lieb ..Smile ..... Danke.
Wünsche dir eine schöne Zeit.
Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Neuling Fehler beim Kompilieren guenni71 6 256 26.11.2017 16:48
Letzter Beitrag: hotsystems
  M enue System zeigt Fehler rev.antun 11 433 23.11.2017 12:22
Letzter Beitrag: rev.antun
  Fehler in gleitkomma Berechnung BennIY 5 346 04.11.2017 19:10
Letzter Beitrag: Tommy56
  Suche Hilfe für den Fehler in der Datei Holzwurm56 5 378 01.11.2017 14:26
Letzter Beitrag: Holzwurm56
  Hilfe bei Einschaltverzögerung gesucht Ingo 9 655 28.10.2017 19:04
Letzter Beitrag: Tommy56
  Hobby Programierer gesucht gegen Entgelt. Haustechno 31 4.883 15.08.2017 09:36
Letzter Beitrag: Home38
  Compiler Fehler Harti 8 667 16.06.2017 17:51
Letzter Beitrag: Harti
  Fehler bei Zeitmessung Fox 15 857 24.05.2017 09:19
Letzter Beitrag: SkobyMobil
  Seltsamer Fehler bei Vergleichsoperation ardu_arne 14 971 22.01.2017 20:35
Letzter Beitrag: Binatone
  Auftragsprogrammierer gesucht GY521/MPU6050 Nimes 3 559 12.01.2017 09:26
Letzter Beitrag: Nimes

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste