INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Fehler beim Kompilieren für das Board ...
11.11.2019, 18:55
Beitrag #17
RE: Fehler beim Kompilieren für das Board ...
Hallo,

(11.11.2019 18:26)Tommy56 schrieb:  @amithlon: Also zumindest die IDE 1.8.10 (mit ESP8266 2.5.2) meldet hier immer mehrere Libs, die nur 1 Mal vorhanden sind. Die IDE 1.8.8 mit 2.4.2 tut das nicht.

Ist das bei Dir auch so?

Ich habe das schon gesehen, aber nicht wirklich darauf geachtet und bei Fehlersuche auch nur kontrolliert, ob er die richtige als genutzt angegeben hat.
Ich habe das garade mal probiert und natürlich kam da keine Auflistung...
1.8.10 mit 2.5.2 und auch die Test-IDE 1.8.10 mit 2.6.0 waren ruhig.
Ich werde mal darauf achten, wenn es wieder passiert.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
13.11.2019, 21:27
Beitrag #18
RE: Fehler beim Kompilieren für das Board ...
(11.11.2019 14:02)hotsystems schrieb:  @TO
Fakt ist, du musst etwas falsch bei der Installation (IDE oder Libraries) gemacht haben.

Allerdings habe ich es nicht weiter untersucht.
Die Sketch lässt sich bei mir in der IDE 1.6.5 fehlerfrei kompilieren.
In der IDE 1.8.9 wirft er Fehler bei "hour()" usw. aus. Diese sind aber def. in der Time-Lib bei mir vorhanden.
Hallo Dieter,
ich habe das Gefühl, daß die IDE 1.10.0 die native c++ Bibliothek und nicht die Arduino-Bibliothek linkt. Sonst wäre es nicht zu erklären, daß verschiedene IDEs unterschiedliches Verhalten zeigen. Tommy hat nicht recht, daß die dazugeladenen Bibliotheken in /sketchbook/libraries stehen müssen! Wenn der vollständige Pfad angegeben wird, dürfen sie stehen wohin sie kopiert/installiert wurden.
Werde aber Time.h bzw. TimeLib.h nicht verwenden da sie zuviel Ballast enthalten. Wenn ich die Zeit einfach auslesen möchte, bin ich mit dem zufrieden, was das DFC-Signal enthält und brauche keine Info, wieviele Sekunden seit dem 1. 1. 1970 verflossen sind!
Mich wundert es, daß sich niemand gemeldet hat, der sich mit DFC-Modulen befaßt.

Gruß

K. W.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
13.11.2019, 21:38 (Dieser Beitrag wurde zuletzt bearbeitet: 13.11.2019 21:42 von Tommy56.)
Beitrag #19
RE: Fehler beim Kompilieren für das Board ...
(13.11.2019 21:27)Kurt Wallander schrieb:  ich habe das Gefühl, daß die IDE 1.10.0
Was ist die IDE 1.10.0? Wir sind derzeit bei 1.8.10.
Sollte das die unsägliche Windows-App sein, dann wirf sie weg und nimm Windows Installer oder Windows Zip (dann am Besten gleich auf portable umstellen - vor dem 1. Start!).

Mit der App gab es bisher nur Probleme.

Gruß Tommy

Edit: Bei der Time-Lib von Paul Stoffregen lieber #include <TimeLib.h> im Sketch benutzen

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
13.11.2019, 21:47
Beitrag #20
RE: Fehler beim Kompilieren für das Board ...
Hallo,

(13.11.2019 21:27)Kurt Wallander schrieb:  Tommy hat nicht recht, daß die dazugeladenen Bibliotheken in /sketchbook/libraries stehen müssen! Wenn der vollständige Pfad angegeben wird, dürfen sie stehen wohin sie kopiert/installiert wurden.

Ändere die Aussage in "sollten". Ich lasse die absichtlich in sketchbook/libraries. Einfach, weil ich mehrere portable IDE auf dem Rechner habe, mit unterschiedlichen IDE-Versionen, Boardversionen (speziell ESP) und eben auch Lib-Versionen.
Palttenplatz ist für mich kein Argument, also können die auch 5x identisch auf der HD liegen. Alte Projekte kopiere ich dann in ene neue IDE mit den aktuellen Versionen und lasse mich überraschen, was noch problemlos geht. Die alte IDE landet irgendwann in der Sicherung, so bekomme ich notfalls auch eine Geschiche wieder zum Laufen, die ich Jahre nicht mehr angefasst habe und die sich nicht ohne merklichen Aufwand an aktuelle Versionen anpassen läßt.
Sowas merke ich mir dann nur und mache das mal, wenn ich viel Langeweile habe.
Insofern sehe ich keinen Vorteil, die Libs irgendwo anders zu haben und include-Pfade setzen zu müssen.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
13.11.2019, 21:55 (Dieser Beitrag wurde zuletzt bearbeitet: 13.11.2019 22:29 von Tommy56.)
Beitrag #21
RE: Fehler beim Kompilieren für das Board ...
(13.11.2019 21:27)Kurt Wallander schrieb:  Tommy hat nicht recht, daß die dazugeladenen Bibliotheken in /sketchbook/libraries stehen müssen! Wenn der vollständige Pfad angegeben wird, dürfen sie stehen wohin sie kopiert/installiert wurden.
Ok, früher war die IDE pingeliger, sorry.

Das kannst Du machen. Mit einem Nachteil:

Dann kannst Du von Anderen im Forum keine Hilfe mehr erwarten, weil die nicht Deine Verzeichnisstruktur haben und mit Sicherheit nicht jedes Mal alles ummodeln wollen, nur weil Du unbedingt andere Lib-Verzeichnisse haben willst.
Du musst Dich entscheiden.

Gruß Tommy

@amithlon:
Ich habe derzeit über den Symlink ein gemeinsames Skatchverzeichnis zwischen 1.8.10 mit 2.5.2 und 1.8.8 mit 2.4.2. So kann ich mit beiden Kombinationen die Sketche testen. Das hat auch was.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Fehlermeldung beim Sketch hochladen heino_m 12 247 Gestern 18:25
Letzter Beitrag: Tommy56
  Fehler bei delay über 32767 Kleingärtner 5 280 07.05.2020 18:51
Letzter Beitrag: Kleingärtner
  Wo ist der RxD1 beim Wemos D1 mini? DO3GE 3 211 03.05.2020 12:33
Letzter Beitrag: Fips
  Fehler bei eigener Library Samu_wo 4 269 20.04.2020 15:51
Letzter Beitrag: Samu_wo
  Verschiedene Spannungen beim Schalten von Relais? Wosch 4 279 19.04.2020 16:33
Letzter Beitrag: Tommy56
  Fehler beim Kompilieren Lunge 6 364 09.04.2020 14:07
Letzter Beitrag: MicroBahner
  Timeout beim Hochladen freak76 5 345 06.04.2020 08:54
Letzter Beitrag: GuaAck
  Undefined reference-Fehler beim Kompilieren MdE 9 519 24.03.2020 21:39
Letzter Beitrag: Tommy56
  Stepper Motor mit zwei Taster bedienen / Fehler ohne Fehlermeldung Milano 6 478 21.03.2020 16:06
Letzter Beitrag: MicroBahner
  Fehler bei Kompilieren ak68 6 765 21.03.2020 13:12
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste