INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Fehler beim Kompilieren
29.03.2015, 13:01
Beitrag #1
Fehler beim Kompilieren
Hallo,

seit gestern besitze auch ich ein Arduino UNO, also absoluter Neuling. Geplant ist einmal ein Einsatz in der Tropfenfotografie.

Einige erste Versuche gestern zum Ansteuern von Relais verliefen auch recht positiv. Doch seit heute, zwischendurch wurde andere Software (NetBeans) installiert und wieder deinstalliert, kommt es zu folgender Fehlermeldung:

collect 2.exe: fatal error: cannot find 'LD'

Auch nach einer Neuinstallation der Arduino-Software bleibt der Fehler bestehen. Eine Suche über Google brachte auch nicht so den Erfolg.

Vielleicht kann mir ja jemand mal einen Tip geben, was diese Fehlermeldung genau bedeutet und wie man das Problem wieder in den Griff bekommt.

Gruß Stefan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.03.2015, 15:44
Beitrag #2
RE: Fehler beim Kompilieren
Hallo Stefan,

da gabs wohl ein Gerangel zwischen NetBeans und Arduino IDE um den Linker.
Wie hast du die Arduino IDE neu installiert? Aus dem .zip- oder aus dem Installer-Paket?
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.03.2015, 16:02
Beitrag #3
RE: Fehler beim Kompilieren
Hallo Ricardo,

Neuinstallation mit dem Installer-Paket

Stefan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.03.2015, 19:45
Beitrag #4
RE: Fehler beim Kompilieren
So, Problem ist gelöst. Arduino funktioniert wieder einwandfrei. Ursache war der Virenscanner, der die LD.exe in die Quarantäne verschoben hat.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30.03.2015, 11:54
Beitrag #5
RE: Fehler beim Kompilieren
So blöd kann man gar nicht denken.
Aber wo du es jetzt sagst fällt mir wieder ein, dass ich vor ein paar Tagen was über false positive Meldungen verschiedener Virenscanner bei der Toolchain der Arduino IDE gelesen habe.
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Seltsamer Fehler bei Vergleichsoperation ardu_arne 13 184 Gestern 20:50
Letzter Beitrag: Tommy56
  Arduino hängt beim Upload deranda 14 634 20.01.2017 16:14
Letzter Beitrag: renid55
  Led Impuls beim Taster betätigen clemens5555 11 247 17.01.2017 20:00
Letzter Beitrag: renid55
  Beim Hochladen USB Problem Nils 10 333 29.12.2016 21:05
Letzter Beitrag: renid55
  Fehler beim Hochladen steyr 24 527 16.12.2016 07:52
Letzter Beitrag: hotsystems
  Fehlermedungen beim Kompilieren Franz54 7 300 07.12.2016 14:29
Letzter Beitrag: Pit
  Fehler in meinem Programm Franz54 7 238 01.12.2016 23:58
Letzter Beitrag: hotsystems
  Fehler im Programmablauf binderj1 14 400 10.10.2016 10:29
Letzter Beitrag: StephanBuerger
  Fehler beim Kompilieren binderj1 5 362 03.10.2016 21:27
Letzter Beitrag: hotsystems
Smile Simpler Fehler bei MAP? malsehen 8 268 02.10.2016 19:46
Letzter Beitrag: malsehen

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste