INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Fehler beim Kompilieren
29.03.2015, 13:01
Beitrag #1
Fehler beim Kompilieren
Hallo,

seit gestern besitze auch ich ein Arduino UNO, also absoluter Neuling. Geplant ist einmal ein Einsatz in der Tropfenfotografie.

Einige erste Versuche gestern zum Ansteuern von Relais verliefen auch recht positiv. Doch seit heute, zwischendurch wurde andere Software (NetBeans) installiert und wieder deinstalliert, kommt es zu folgender Fehlermeldung:

collect 2.exe: fatal error: cannot find 'LD'

Auch nach einer Neuinstallation der Arduino-Software bleibt der Fehler bestehen. Eine Suche über Google brachte auch nicht so den Erfolg.

Vielleicht kann mir ja jemand mal einen Tip geben, was diese Fehlermeldung genau bedeutet und wie man das Problem wieder in den Griff bekommt.

Gruß Stefan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.03.2015, 15:44
Beitrag #2
RE: Fehler beim Kompilieren
Hallo Stefan,

da gabs wohl ein Gerangel zwischen NetBeans und Arduino IDE um den Linker.
Wie hast du die Arduino IDE neu installiert? Aus dem .zip- oder aus dem Installer-Paket?
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.03.2015, 16:02
Beitrag #3
RE: Fehler beim Kompilieren
Hallo Ricardo,

Neuinstallation mit dem Installer-Paket

Stefan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.03.2015, 19:45
Beitrag #4
RE: Fehler beim Kompilieren
So, Problem ist gelöst. Arduino funktioniert wieder einwandfrei. Ursache war der Virenscanner, der die LD.exe in die Quarantäne verschoben hat.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30.03.2015, 11:54
Beitrag #5
RE: Fehler beim Kompilieren
So blöd kann man gar nicht denken.
Aber wo du es jetzt sagst fällt mir wieder ein, dass ich vor ein paar Tagen was über false positive Meldungen verschiedener Virenscanner bei der Toolchain der Arduino IDE gelesen habe.
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Fehler in meinem Programm Franz54 7 139 01.12.2016 23:58
Letzter Beitrag: hotsystems
  Fehler im Programmablauf binderj1 14 347 10.10.2016 10:29
Letzter Beitrag: StephanBuerger
  Fehler beim Kompilieren binderj1 5 291 03.10.2016 21:27
Letzter Beitrag: hotsystems
Smile Simpler Fehler bei MAP? malsehen 8 225 02.10.2016 19:46
Letzter Beitrag: malsehen
  Fehler beim Speichern von Projekten Manni66 16 681 23.08.2016 10:05
Letzter Beitrag: hotsystems
  Arduino hängt beim Upload deranda 11 495 12.08.2016 21:27
Letzter Beitrag: hotsystems
  Ausgabe druckt immer 2 Werte anstatt nur einen. Finde den Fehler nicht TimeMen 24 732 02.07.2016 14:18
Letzter Beitrag: hotsystems
  Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren kl-ing 3 329 06.06.2016 16:07
Letzter Beitrag: Bitklopfer
  Hilfe beim Arduino Shield reimundko 6 453 05.06.2016 11:28
Letzter Beitrag: rpt007
  RX/TX als dig. Eingänge beim Mega 2560 benutzen? alpenpower 0 326 22.03.2016 12:13
Letzter Beitrag: alpenpower

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste