INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Falschen XBee gekauft ?????
03.10.2014, 17:34
Beitrag #1
Falschen XBee gekauft ?????
Hallo zusammen,
ich bräuchte mal eure Hilfe.
Bis jetzt sende ich meinen Daten vom Arduino mit einem Ethernshield auf meine Webseite. Nun wollte ich gern das Ethernetshield durch ein XBee ersetzen.
Also 1x Arduino mit aufgesteckten SainSmart Xbee Shield und ein XBee.
Nur habe ich das dumme Gefühl den verkehrten XBee, nämlich einen:
XB24 802.15.4 gekauft zu haben. Bei der Konfiguration mit X-ctu hab ich da so meine Probleme.
Kann mir jemand sagen, welches XBee ich brauche, um meine Daten über nen Wlan-Router ins Netz zu bringen?
Danke
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.10.2014, 18:36
Beitrag #2
RE: Falschen XBee gekauft ?????
(03.10.2014 17:34)Kurt schrieb:  Hallo zusammen,
ich bräuchte mal eure Hilfe.
Bis jetzt sende ich meinen Daten vom Arduino mit einem Ethernshield auf meine Webseite. Nun wollte ich gern das Ethernetshield durch ein XBee ersetzen.
Also 1x Arduino mit aufgesteckten SainSmart Xbee Shield und ein XBee.
Nur habe ich das dumme Gefühl den verkehrten XBee, nämlich einen:
XB24 802.15.4 gekauft zu haben. Bei der Konfiguration mit X-ctu hab ich da so meine Probleme.
Kann mir jemand sagen, welches XBee ich brauche, um meine Daten über nen Wlan-Router ins Netz zu bringen?
Danke

Cool *kopfkratz*...ähm also XBEE ist kein WLAN...*denk*..Tongue

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.10.2014, 11:07
Beitrag #3
RE: Falschen XBee gekauft ?????
Hallo,
melde mich jetzt erst wieder, aber das XBee kam erst .
Du hast Recht, das Xbee war keins für WLan. Habe mir deshalb das XBee S6B zugelegt und mit XCTU konfiguriert. Dann mit diesen Sketch getestet:
Code:
#include <SPI.h>
#include <WiFi.h>


char ssid[] = "Urtrxxx";      // your network SSID (name)
char pass[] = "xxxxxxxxxx";   // your network password
int keyIndex = 0;                 // your network key Index number (needed only for WEP)

int status = WL_IDLE_STATUS;

WiFiServer server(80);

void setup() {
  //Initialize serial and wait for port to open:
  Serial.begin(9600);
  while (!Serial) {
    ; // wait for serial port to connect. Needed for Leonardo only
  }

  // check for the presence of the shield:
  if (WiFi.status() == WL_NO_SHIELD) {
    Serial.println("WiFi nicht vorhanden");
    // don't continue:
    while(true);
  }

  // attempt to connect to Wifi network:
  while ( status != WL_CONNECTED) {
    Serial.print("Attempting to connect to SSID: ");
    Serial.println(ssid);
    // Connect to WPA/WPA2 network. Change this line if using open or WEP network:    
    status = WiFi.begin(ssid, pass);

    // wait 10 seconds for connection:
    delay(10000);
  }
  server.begin();
  // you're connected now, so print out the status:
  printWifiStatus();
}


void loop() {
  // listen for incoming clients
  WiFiClient client = server.available();
  if (client) {
    Serial.println("new client");
    // an http request ends with a blank line
    boolean currentLineIsBlank = true;
    while (client.connected()) {
      if (client.available()) {
        char c = client.read();
        Serial.write(c);
        // if you've gotten to the end of the line (received a newline
        // character) and the line is blank, the http request has ended,
        // so you can send a reply
        if (c == '\n' && currentLineIsBlank) {
          // send a standard http response header
          client.println("HTTP/1.1 200 OK");
          client.println("Content-Type: text/html");
          client.println("Connection: close");  // the connection will be closed after completion of the response
          client.println("Refresh: 5");  // refresh the page automatically every 5 sec
          client.println();
          client.println("<!DOCTYPE HTML>");
          client.println("<html>");
          // output the value of each analog input pin
          for (int analogChannel = 0; analogChannel < 6; analogChannel++) {
            int sensorReading = analogRead(analogChannel);
            client.print("analog input ");
            client.print(analogChannel);
            client.print(" is ");
            client.print(sensorReading);
            client.println("<br />");      
          }
          client.println("</html>");
           break;
        }
        if (c == '\n') {
          // you're starting a new line
          currentLineIsBlank = true;
        }
        else if (c != '\r') {
          // you've gotten a character on the current line
          currentLineIsBlank = false;
        }
      }
    }
    // give the web browser time to receive the data
    delay(1);
  
    // close the connection:
    client.stop();
    Serial.println("client disonnected");
  }
}


void printWifiStatus() {
  // print the SSID of the network you're attached to:
  Serial.print("SSID: ");
  Serial.println(WiFi.SSID());

  // print your WiFi shield's IP address:
  IPAddress ip = WiFi.localIP();
  Serial.print("IP Address: ");
  Serial.println(ip);

  // print the received signal strength:
  long rssi = WiFi.RSSI();
  Serial.print("signal strength (RSSI):");
  Serial.print(rssi);
  Serial.println(" dBm");
}
Nun kommt aber laufend die Fehlermeldung.
"wifi shield not present"
Ich habe zig Seiten im Netz durchgelesen, aber nichts gefunden wie ich diesen Fehler beheben kann.
Hat jemand schon Erfahrungen damit??

Bernd
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Ampel mit XBee manau21 2 490 16.12.2015 12:36
Letzter Beitrag: manau21
  werte von 2 Ultraschallsensoren mit xbee übertragen Darkon 4 1.170 25.05.2015 21:23
Letzter Beitrag: HaWe
  Arduino SoftwareSerial und Xbee Tobse101 5 2.257 06.02.2014 15:19
Letzter Beitrag: burgi650

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste