INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Esp32 1.0.0 geändert ??
28.12.2018, 10:25
Beitrag #1
Esp32 1.0.0 geändert ??
Gestern abend festgestellt das ohne das ich selbst etwas geändert habe, was vorher wahrscheinlich Warnungen waren jetzt nicht mehr kompiliert.
Hätte wohl mal vorher die Warnungen ansehen sollen!

error: format '%d' expects argument of type 'int', but argument 7 has type 'long unsigned int' [-Werror=format=]
Ist nicht das Problem das mal in Ordnung zu bringen "%ld".

Die BME280 LIB von finitespace geht garnicht mehr, da dort return Statements fehlen.

Habe ich einfach zweimal "return true" reingeschrieben meckert der Compilier nicht mehr.
Das ärgerliche ist, das der Ersteller der Lib schon im April drauf hingewiesen wurde.

Was mich dabei echt verwundert hat ist, das die Version 1.0.0 so über Nacht geändert wurde.
Obwohl es auch schon eine 1.0.1-rc1 und 1.0.1-rc2 gibt, in die man dann doch solche Änderungen einfliesen lassen kann.

Also nicht wundern wenn Sketche die Monate funktioniert haben, jetzt nicht mehr kompilieren.

Fazit: Warnungen beachten

Gruß Fips

Meine Esp8266 & ESP32 Projekte
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.12.2018, 14:07 (Dieser Beitrag wurde zuletzt bearbeitet: 28.12.2018 14:16 von amithlon.)
Beitrag #2
RE: Esp32 1.0.0 geändert ??
Hallo,

(28.12.2018 10:25)Fips schrieb:  Was mich dabei echt verwundert hat ist, das die Version 1.0.0 so über Nacht geändert wurde.
Obwohl es auch schon eine 1.0.1-rc1 und 1.0.1-rc2 gibt, in die man dann doch solche Änderungen einfliesen lassen kann.

habe gerade mal den esp32-Ordner rauskopiert und die 1.0.0 neu installiert.
Die Ordner incl. Inhalt sind 100% identisch und unverändert seit 28.07.2018.
Mir ist auch bisher nichts weiter aufgefallen.

Typprüfungen in der IDE wurden im Laufe der Zeit etliche von Warnig auf Error gesetzt, Ausgabe auf Standard fürht da inzwischen gern mal zu Abbrüchen. Ich schau mir das dann meist an und je nach Fehler setze ich dann böse uaf keine und vertraue dem Compiler, daß er das richtig macht...
Die Hoffnung, daß der Ersteller einer Lib das mal auf aktuellen Stand bringt, stirbt zuletzt...

Gruß aus Berlin
Michael



Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.12.2018, 14:21 (Dieser Beitrag wurde zuletzt bearbeitet: 28.12.2018 14:37 von Fips.)
Beitrag #3
RE: Esp32 1.0.0 geändert ??
(28.12.2018 14:07)amithlon schrieb:  Hallo,

habe gerade mal den esp32-Ordner rauskopiert und die 1.0.0 neu installiert.
Die Ordner incl. Inhalt sind 100% identisch und unverändert seit 28.07.2018.

Stimmt! Auch bei mir steht 28.07.2018.

Zitat:Typprüfungen in der IDE wurden im Laufe der Zeit etliche von Warnig auf Error gesetzt, Ausgabe auf Standard fürht da inzwischen gern mal zu Abbrüchen. Ich schau mir das dann meist an und je nach Fehler setze ich dann böse uaf keine und vertraue dem Compiler, daß er das richtig macht...
Die Hoffnung, daß der Ersteller einer Lib das mal auf aktuellen Stand bringt, stirbt zuletzt...

Gruß aus Berlin
Michael

Ich habe nichts geändert.
1.8.5 mit 1.0.0

Bleibt für mich die Frage warum es plötzlich zu den Fehlermeldungen kommt?
Irgendwas muss ja anders geworden sein.
Mit Magie wollte ich mich nicht abfinden.

Edit: Habs rausgefunden!
Compiler Warnung hatte ich wahrscheinlich vorher auf Standart. Erst bei Alle kommt der ERROR.

Gruß Fips

Meine Esp8266 & ESP32 Projekte
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.12.2018, 16:14
Beitrag #4
RE: Esp32 1.0.0 geändert ??
Hallo,

(28.12.2018 14:21)Fips schrieb:  Mit Magie wollte ich mich nicht abfinden.

Edit: Habs rausgefunden!
Compiler Warnung hatte ich wahrscheinlich vorher auf Standart. Erst bei Alle kommt der ERROR.

Wieder keine Magie... Naja, vielleicht im nächsten Jahr.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.12.2018, 08:04 (Dieser Beitrag wurde zuletzt bearbeitet: 29.12.2018 08:05 von Fips.)
Beitrag #5
RE: Esp32 1.0.0 geändert ??
(28.12.2018 16:14)amithlon schrieb:  Wieder keine Magie... Naja, vielleicht im nächsten Jahr.

Gruß aus Berlin
Michael

Danke dir, Michael, für deine Mithilfe!

Auch im nächsten Jahr bleibe ich bei Nullen und Einsen und überlasse die Magie anderen Gläubigen!


Gruß Fips

Meine Esp8266 & ESP32 Projekte
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Question Control Unit für Relay mit ESP32 2uk 33 467 Gestern 22:33
Letzter Beitrag: hotsystems
  ESP32 hängt -> reset per Attiny85 hYtas 90 2.048 18.11.2019 09:00
Letzter Beitrag: amithlon
  ESP32 - welche WIFI Library nehmen georg1010 2 81 16.11.2019 19:02
Letzter Beitrag: amithlon
  Sketch von einen ESP8266 auf ein ESP32 portieren (hagelt Fehlermeldung) magnum1795 23 578 13.11.2019 14:38
Letzter Beitrag: magnum1795
  esp32 wifi - new Client als Unterproramm georg1010 5 181 13.11.2019 12:10
Letzter Beitrag: Tommy56
  ESP32 - an mobile hotspot anmelden georg1010 3 177 12.11.2019 08:39
Letzter Beitrag: hotsystems
  ESP32 und mp3 via SD biologist 9 397 10.11.2019 14:14
Letzter Beitrag: biologist
  ESP32 Pakete installieren unter Ubuntu Gerdchen03 0 210 01.11.2019 15:37
Letzter Beitrag: Gerdchen03
  Frage zu App für Esp32 goofy15 4 429 29.10.2019 08:46
Letzter Beitrag: volvodani
  ESP32 "SPIFFS initialisation failed!" Gerdchen03 1 332 18.10.2019 17:34
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste