INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Empfänger funktioniert nicht mehr
06.09.2019, 17:55
Beitrag #1
Empfänger funktioniert nicht mehr
Hallo,
habe ein alten Code wieder für ein Projekt ausgegraben,
beim versuch den zu nutzen bekomme ich nur eine Fehlermeldung.
Code:
#include <SPI.h>
      #include <nRF24L01.h>
      #include <RF24.h>
      
      RF24 radio(9, 10);
      const uint64_t pipe = 0xE8E8F0F0E1LL;
      
      void setup(void) {
      Serial.begin(9600);
      radio.begin();
      radio.openReadingPipe(1, pipe);
      radio.startListening();
      Serial.begin(9600);
      Serial.println("Temperature Starting.....");
      delay(1000);
      Serial.println("Solar Temperatur");
      delay(1000);
      }
      
      void loop(void)
      {
      if (radio.available()) {
      float temperature = 0;
      if (!radio.read(&temperature, sizeof(float))) {
      Serial.println("keine Verbindung");
      }
      Serial.print("Temperature : ");
      Serial.println(temperature);
      delay(1000);
      }
      }
Der Fehler lautet wie folgt:
Arduino: 1.6.0 (Windows 7), Platine: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

D_T_empfenger.ino: In function 'void loop()':
D_T_empfenger.ino:24:50: error: could not convert 'radio.RF24::read(((void*)(& temperature)), ((uint8_t)sizeof (float)))' from 'void' to 'bool'
D_T_empfenger.ino:24:50: error: in argument to unary !
Fehler beim Kompilieren.

Dieser Report hätte mehr Informationen mit
"Ausführliche Ausgabe während der Kompilierung"
aktiviert in Datei > Einstellungen
Hat einer ein Tipp was sich da getan hat.
Danke Jörg
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.09.2019, 18:13
Beitrag #2
RE: Empfänger funktioniert nicht mehr
Du bist sicher, dass der Code schon mal lief und die Fehlermeldung zu diesem Sketch passt? Der Code in der Fehlermeldung ist nicht im Sketch enthalten.

Gib mal einen Link zu den verwendeten Libs.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.09.2019, 18:39
Beitrag #3
RE: Empfänger funktioniert nicht mehr
Hallo Tommy,
ja habe den aber wohl mit einer anderen NRF24 am Start gehabt, nach einfügen eines fehlende Satz sendet er wieder.

Danke Jörg
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.09.2019, 18:43
Beitrag #4
RE: Empfänger funktioniert nicht mehr
Gut. Dann stelle bitte den funktionierenden Sketch noch hier ein.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.09.2019, 18:46
Beitrag #5
RE: Empfänger funktioniert nicht mehr
Ja klar mache ich,
Code:
// TX 1 sender


#include <OneWire.h>
#include <DallasTemperature.h>
#include <SPI.h>
#include <nRF24L01.h>
#include <RF24.h>
#define ONE_WIRE_BUS_1 2


OneWire oneWire(ONE_WIRE_BUS_1);


DallasTemperature sensor(&oneWire);
RF24 radio(9, 10);
const uint64_t pipe = 0xE8E8F0F0E1LL;
              //pipe = 0xE8E8F0F0E1LL;
void setup(void)
{
     Serial.begin(9600);
     Serial.println("Dallas Temperatur  Library Demo - EinPin_DS18B20");

     radio.begin();
     radio.openWritingPipe(pipe);
     sensor.begin();
    
}

void loop(void)
{
    
     sensor.requestTemperatures();
     Serial.println(sensor.getTempCByIndex(0));

     sensor.requestTemperatures();
     float temperature = sensor.getTempCByIndex(0);
   //  radio.write(&temperature, sizeof(float));
     radio.stopListening();
     radio.write(&temperature, sizeof(float));
     radio.startListening();
     delay(1000);
        
}

gerne au den Empfänger da zu
Code:
#include <SPI.h>
       #include <nRF24L01.h>
       #include <RF24.h>
      
       RF24 radio(9, 10);
       const uint64_t pipe = 0xE8E8F0F0E1LL;
      
       void setup(void) {
       Serial.begin(9600);
       radio.begin();
       radio.openReadingPipe(1, pipe);
       radio.startListening();
       Serial.begin(9600);
       Serial.println("Temperature Starting.....");
       delay(1000);
       Serial.println("Solar Temperatur");
       delay(1000);
       }
      
       void loop(void)
       {
       if (radio.available()) {
       float temperature = 0;
       if (!radio.read(&temperature, sizeof(float))) {
       Serial.println("keine Verbindung");
       }
       Serial.print("Temperature : ");
       Serial.println(temperature);
       delay(1000);
       }
       }
Gruß Jörg
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.09.2019, 18:57
Beitrag #6
RE: Empfänger funktioniert nicht mehr
Danke.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Nebelmaschine: Programmteile funktionieren nicht ChrisTastic 11 331 15.11.2019 09:08
Letzter Beitrag: hotsystems
  Nextion und Arduino kommunizieren nicht alpenpower 7 225 04.11.2019 10:36
Letzter Beitrag: GuaAck
  Button funktioniert nicht trotz korrekter Schaltung Schneggl 3 266 12.10.2019 08:17
Letzter Beitrag: Schneggl
  kein setup() mehr?! woswasi 9 963 20.09.2019 16:44
Letzter Beitrag: Tommy56
  myport nicht gefunden? - Arduino und Visual Studio Stagneth.Alexander 4 520 04.09.2019 14:16
Letzter Beitrag: Stagneth.Alexander
  UDP send oder print ??? Ich kapiers nicht HarryB 5 452 03.09.2019 13:06
Letzter Beitrag: Tommy56
Wink Solar Roboter- Servo dreht nach Stopp nicht weiter Stagneth.Alexander 37 2.707 20.08.2019 14:15
Letzter Beitrag: geist4711
  Atmega 328 Sketchl läuft auf UNO3, alleine auf Breadboard nicht delay 9 910 02.08.2019 15:03
Letzter Beitrag: hotsystems
  Reaktionsspiel funktioniert nicht, wie es sollte... Stagneth.Alexander 27 1.690 21.07.2019 07:57
Letzter Beitrag: Stagneth.Alexander
Question Programm läuft nicht richtig CMeeep 22 1.877 04.07.2019 21:58
Letzter Beitrag: Franz54

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste