INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Einfaches Projekt funktioniert am USB Anschluss, aber nicht mit Akkus
05.04.2021, 00:45
Beitrag #1
Einfaches Projekt funktioniert am USB Anschluss, aber nicht mit Akkus
Hallo zusammen,

Ich hab diese mal (vermute ich) ein Hardware Problem.

Ich baue eine Art ferngesteuertes Auto, die Fernbedienung benutzt:

- Arduino Nano
- MPU6050 Giro + Beschleunigungssensor über 3,3 V
- NRF24L01 Modul zur Drahtlosen Übertragung über 3,3 V
- Touch Sensor über 5 V

Nun das Problem:
Wenn ich alles über den USB Anschluss vom PC laufen lasse, funktioniert es soweit.
Benutze ich jedoch 4 AA Akkus am 5V Anschluss, funktioniert auch alles (Senden des Signals, wenn ich den Toch Sensor drücke kommt an), nur der MPU6050 scheint einfach keine Werte zu liefern, sobald ich in den Akku Betrieb gehe. Auch etwas mehr Leistung durch 4 AA Batterien ändern leider nichts daran.

Die Kontrollen LED auf dem MPU6050 leuchtet aber.

Hat irgendwer eine Idee, was dahinter stecken könnte?

Ich kann natürlich bei Bedarf noch Schaltbilder senden, aber die Schaltung ist denkbar simpel.

Ich hatte selbst die Vermutung, dass vielleicht einfach die Stromstärke Nicht ausreicht, aber die ganzen Teile ziehen ja kaum Strom...oder verbraucht der NRF24L01 so viel, wenn ich non stop Daten sende?

Liebe Grüße und danke im Voraus,
PurpleLightning

_____________________________________________________________
LG,

Purple Lightning
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.04.2021, 02:05
Beitrag #2
RE: Einfaches Projekt funktioniert am USB Anschluss, aber nicht mit Akkus
Also einen Teil der Lösung habe ich schon gefunden: Der Modus, in dem der NRF24L01 läuft:
Code:
radio.setPALevel(RF24_PA_MAX);

geändert zu

Code:
radio.setPALevel(RF24_PA_HIGH);

Außerdem habe ich noch, weil es "überall" empfohlen wird an die NRF24L01 noch je einen 100µF Keramik-Kondensator gelötet.

Trotzdem die Frage: Kennt jemand ein gutes Tutorial, wie man am besten einen Ressourcen-sparenden Sender baut? Ich übertrage eigentlich permanent die Daten des Gyro+Beschl. Sensors als Lenkung für mein Fahrzeug (bzw. hab einen Delay von 50 am Ende des Loops), lasse den Sender aber die ganze Zeit im Sendemodus.

Da gibt es doch sicherlich einen schnelleren Weg?

Und hat jemand Referenzen, wie wie die Reichweite im HIGH Modus ist? Ich brauche eigentlich Indoor nur 10-15 m.

Liebe Grüße,
PurpleLightning

_____________________________________________________________
LG,

Purple Lightning
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.04.2021, 08:05 (Dieser Beitrag wurde zuletzt bearbeitet: 05.04.2021 09:26 von SpaghettiCode.)
Beitrag #3
RE: Einfaches Projekt funktioniert am USB Anschluss, aber nicht mit Akkus
Hi,

(05.04.2021 00:45)PurpleLightning schrieb:  Wenn ich alles über den USB Anschluss vom PC laufen lasse, funktioniert es soweit.
Benutze ich jedoch 4 AA Akkus am 5V Anschluss, ...

was ist bei Dir der 5V Anschluss?
Wenn Du damit den Vin Pin meinst, dann sollten es mindestens 6,5V sein.
Am 5V Pin dürfen es max 5,5V sein ...

Gruß André
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.04.2021, 12:07
Beitrag #4
RE: Einfaches Projekt funktioniert am USB Anschluss, aber nicht mit Akkus
(05.04.2021 02:05)PurpleLightning schrieb:  Und hat jemand Referenzen, wie wie die Reichweite im HIGH Modus ist? Ich brauche eigentlich Indoor nur 10-15 m.

Da sind die Aussagen der Lieferanten alle sehr unterschiedlich.
Auch die Testbeiträge liefern hier sehr unterschiedliche Angaben.
Mit den Onboard-Antennen ist die Reichweite allerdings sehr begrenzt.
Ich empfehle daher immer eine externe Antenne zu verwenden. Damit hast du bei der recht hohen Sendefrequenz eine deutlich bessere Abstrahlung und sicher genügend Reserven. 2,4 GHz sind kein Pappenstiel und sollte entsprechend behandelt werden.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Poolroboter-Projekt mit Arduino Nano zB_MaxMustermann 4 194 19.06.2021 10:34
Letzter Beitrag: hotsystems
  Bootloader will sich nicht auf Mini Pro installieren lassen Foto-Ralf 27 1.347 09.06.2021 07:15
Letzter Beitrag: SpaghettiCode
  Arduino Mega wird nicht erkannt Gian-Luca 61 15.927 27.05.2021 23:21
Letzter Beitrag: Hurz
  Arduino startet nicht kpc 14 2.062 27.04.2021 22:24
Letzter Beitrag: hotsystems
  MKR1200 läuft nicht bei Batteriebetrieb kpc 24 4.303 05.04.2021 22:59
Letzter Beitrag: kpc
  Sketche lassen sich aus IDE nicht mehr hochladen Steinspiel 9 1.968 19.03.2021 19:11
Letzter Beitrag: Chopp
  Sketches lassen sich nicht mehr hochladen. Was kann ich noch tun? Tonio 3 919 19.03.2021 15:32
Letzter Beitrag: Tommy56
  Arduino 3D-Druck Projekt Bigfire3 24 5.090 15.03.2021 16:00
Letzter Beitrag: Bigfire3
  Servo funktioniert nicht richtig an Arduino Nano Maxcruiser 25 4.301 14.03.2021 17:11
Letzter Beitrag: hotsystems
  2 I2C-Devices nicht zusammen wonk 36 6.246 04.03.2021 00:08
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste