INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
ESP8266 tuts nicht
15.09.2016, 22:09
Beitrag #1
ESP8266 tuts nicht
Hallo Freunde, ich bin so ziemlich am Ende meiner bescheidenen Weisheit.
ESP8266-01 und USB-serial-Wandler FTDI232 sind folgendermaßen verbunden:

ESP------FTDI
VCC ------ VCC
GND ------ GND
RX --------- TX
TX --------- RX
CH_PD -- 1k -- VCC
RES ------1k -- VCC

CH_PD und RES können zwecks Programmierung mit Tastern an GND gelegt werden.
zwischen VCC und GND liegt ESP-seitig ein 150uF-Kondensator.
VCC ist am FTDI auf 3,3V eingestellt.
Im PC wird die virtuelle serielle Schnittstelle als COM7 erkannt.

Mit einem Terminalprogramm sende ich an COM7 im ASCII-Mode "AT".
Ich habe es schon mit drei verschiedenen ESP8266-01-Shields probiert, sowie mit einem ESP8266-12E. Das mit allen Baudraten, die das Terminalprogramm kann (von 9600 bis 115299). Nie hat ein Shield einmal geantwortet. Nach Drücken der RES-Taste laufen manchmal zusammenhanglose Zeichen ein. Manchmal gibt es auch langes Geblinke der LEDs auf ESP und FTDI.

Was schlagt ihr mir vor, was ich tun soll?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.09.2016, 08:09
Beitrag #2
RE: ESP8266 tuts nicht
Da hatte sich ein Fehler eingeschlichen.
Die Beschaltung ist:

ESP------FTDI
VCC ------ VCC
GND ------ GND
RX --------- TX
TX --------- RX
CH_PD --- VCC
RES ------1k -- VCC
GPIO0-----1k --VCC
Taster an RES und GPIO0.

Das ist aber wohl nur für das Programmieren relevant. Eine antwort auf den "AT"-Befehl müsste so oder so kommen.
Probiert habe ich das mit und ohne CR/LF nach dem "AT".
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.09.2016, 17:46 (Dieser Beitrag wurde zuletzt bearbeitet: 17.09.2016 17:46 von amithlon.)
Beitrag #3
RE: ESP8266 tuts nicht
Hallo,

PullUp an GND und GPIO0 sind nicht unbedingt nötig, die internen des ESP reichen.
Und wenn externe dann eher 10k, bei 1k fließen unnötig 5mA pro Taster wenn gedrückt wird.
Der interne 3,3V Regler des FTDI kann den Strom für den ESP nicht liefern, da hilft auch der Elko meist nicht.

USB-TTL Wandler mit dem CP2102 schaffen es meist zusammen mit dem Elko.
Mit etlichen neueren Modulen klappte das aber auch nicht mehr richtig, offenbar sind andere Flashbausteine verbaut.

3,3V mit Längsregler (China AMS1117 o.ä.) aus den 5V des USB erzeugen.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.09.2016, 20:07
Beitrag #4
RE: ESP8266 tuts nicht
Danke, das werd ich mal versuchen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.09.2016, 21:09
Beitrag #5
RE: ESP8266 tuts nicht
Du solltest in der Konsole das "no line ending" in "CR+NL" machen, dann bekommst du auch eine Antwort.

Gruß

Hier könnte ihre Werbung stehen
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.09.2016, 13:55
Beitrag #6
RE: ESP8266 tuts nicht
So, dank eurer Hilfe bin ich einen Schritt weiter gekommen.
Die Stromversorgung ist wohl ziemlich kritisch. Ein AMS1117 - Regler hat sich schon abgemeldet. Ich hab dann mit einem LM317 eine ordentliche 3,3V-Versorgung gebaut. Jetzt hab ich zwei ESP die antworten. Die anderen habe ich wohl mit meinen Versucher sie neu zu flashen lahmgelegt. Danach werde ich später mal schauen.
Manchmal muss ich nach dem Einschalten der SV auch mehrfach die Spannung aus- und wieder einschalten, oder mehrfach Reset drücken. Ist alles ziemlich wackelig. Aber, wenns überhaupt schon mal was tut, kann man daruf aufbauen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
19.09.2016, 19:09
Beitrag #7
RE: ESP8266 tuts nicht
Den ESP8266 habe ich auch.
Habe auch ärger beim starten gehabt usw.

Jetzt habe ich es mir einfach gemacht und habe mir diesen gekauft :
http://www.ebay.de/itm/172346314000?_trk...EBIDX%3AIT
für 5 Euro.

Und bin jetzt zufrieden. Lege von meinem Roboter die 7,2 Volt an und das Board regelt alles von alleine. Keine Fehler mehr.
Der Roboter wird von meinem PC ferngesteuert.

Gruss
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
19.09.2016, 21:01
Beitrag #8
RE: ESP8266 tuts nicht
Das Teil sieht gut aus. Das werd ich mir auch mal anschauen. Aber zunächst mal mach ich was mit den 10 andern ESP-01 und -12, die ich nach und nach gekauft habe, weil ich dachte die anderen seien kaputt. Mit der stabilen Stromversorgung laufen die jetzt.
Ach ja, ein weiteres Problem gabs damit, dass die original Firmware auf 11500Bd eingestellt war und die softserial-Schnittstelle des Arduino UNO, mit dem ich sie verbinden möchte, das nicht kann. Im Netz habe ich eine Firmware gefunden, die von Haus aus auf 9600 Bd eingestellt ist. Jetzt klappt soweit alles.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  ESP8266 in der Elektronik-Presse Bitklopfer 3 206 07.05.2018 09:48
Letzter Beitrag: amithlon
  Nodemuce verbindet nicht mit WLAN Blatzi 6 150 06.05.2018 21:37
Letzter Beitrag: Blatzi
  Gartenbewässerung mit Arduino und/oder ESP8266 alpenpower 7 2.225 27.04.2018 07:51
Letzter Beitrag: FredRam
  Datenübergabe zwischen Arduino Uno und ESP8266 bastelmichi 2 1.567 10.04.2018 15:05
Letzter Beitrag: Tommy56
  Spiffs Verwaltung -->> ESP...Datei Verwaltung für ESP8266, Nodemcu, Wemos, Sonoff Fips 1 453 01.04.2018 19:54
Letzter Beitrag: Tommy56
  ESP8266 esp-12e development board & BME280 falsche Werte Lurchi 8 2.140 25.03.2018 07:34
Letzter Beitrag: Fips
Lightbulb SPIFFS DOWNLOAD UPLOAD & DELETE Esp8266 NodeMCU Fips 30 4.804 23.03.2018 11:10
Letzter Beitrag: sfb2
Question ESP8266 E-Mail Versandt mit Library lakarder 7 633 18.03.2018 21:20
Letzter Beitrag: amithlon
  Esp8266 Software Version 2.4.1 Fips 10 948 12.03.2018 13:29
Letzter Beitrag: ardu_arne
  Grove UART WiFi (ESP8266) Modul georg01 2 411 10.03.2018 15:57
Letzter Beitrag: georg01

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste