INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 1 Bewertungen - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
ESP8266 HTML Problem
24.04.2016, 14:02
Beitrag #1
ESP8266 HTML Problem
Hallo Community

Ich möchte gerne die aktuelle Gefahrenkarte für meine Land (Schweiz) auf meinem Webserver (http://wlannesslau.internet-box.ch:8000) darstellen

Die Website stellt folgenden Code zur Verfügung:

Code:
<div style="width:180px;height:180px; border: 1px solid black;">
<a href="http://alarm.meteocentrale.ch/index.html" alt="Aktuelle Unwetterwarnungen für die Schweiz" title="Aktuelle Unwetterwarnungen für die Schweiz">
<img src="http://alarm.meteocentrale.ch/images/map/schweiz_preview.png" style="border: 0;" alt="Aktuelle Unwetterwarnungen für die Schweiz" />
</a>
</div>


Ich habe dann diesen Code in meinen Webserver Code hinzugefügt:

1. Vorher:

Code:
void handleRoot() {
  char temp[400];

snprintf ( temp, 400,

"<html>\
  <head>\
    <title>ESP8266 Demo</title>\
    <style>\
      body { background-color: #F7FF00; font-family: Arial, Helvetica, Sans-Serif; Color: #000088; }\
    </style>\
  </head>\
  <body>\
    <h1>Hello from ESP8266!</h1>\
    <p>SSID: %s</<p>\
    <p>Passwort: %s</<p>\
    <p>Temperatur: %s Grad</<p>\
    <p>Feuchtigkeit: %s %</<p>\
    <p>Zeit: %s </<p>\
  </body>\
</html>",

      ssid, password, packetBuffer, packetBuffer2, stringOne
   );
   server.send ( 200, "text/html", temp );
}

2. Nachher:

Code:
void handleRoot() {
  char temp[400];

snprintf ( temp, 400,

"<html>\
  <head>\
    <title>ESP8266 Demo</title>\
    <style>\
      body { background-color: #F7FF00; font-family: Arial, Helvetica, Sans-Serif; Color: #000088; }\
    </style>\
  </head>\
  <body>\
    <h1>Hello from ESP8266!</h1>\
    <p>SSID: %s</<p>\
    <p>Passwort: %s</<p>\
    <p>Temperatur: %s Grad</<p>\
    <p>Feuchtigkeit: %s %</<p>\
    <p>Zeit: %s </<p>\
    <div style=\"/width:180px;height:180px; border: 1px solid black;\" />\
         <a href=\"/http://alarm.meteocentrale.ch/index.html\" />\ alt=\"/Aktuelle Unwetterwarnungen für die Schweiz\" />\ title=\"/Aktuelle Unwetterwarnungen für die Schweiz\" />\
         <img src=\"/http://alarm.meteocentrale.ch/images/map/schweiz_preview.png\" />\ style=\"/border: 0;\" />\ alt=\"/Aktuelle Unwetterwarnungen für die Schweiz\" />\
         </a>\
    </div>\
  </body>\
</html>",

      ssid, password, packetBuffer, packetBuffer2, stringOne
   );
   server.send ( 200, "text/html", temp );
}


Aber irgendwie taucht die Grafik nicht auf, sondern es bleibt genau gleich wie vorher. Könnt ihr mir helfen?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.04.2016, 21:52 (Dieser Beitrag wurde zuletzt bearbeitet: 25.04.2016 21:55 von rkuehle.)
Beitrag #2
RE: ESP8266 HTML Problem
Moin,
anbei mal der HTML-Code der bei mir (Firefox) die Grafik anzeigt.
Grüße Ricardo
Code:
<html>
  <head>
    <title>ESP8266 Demo</title>
    <style>
      body { background-color: #F7FF00; font-family: Arial, Helvetica, Sans-Serif; Color: #000088; }
    </style>
  </head>
  <body>
    <h1>Hello from ESP8266!</h1>
    <p>SSID: %s</<p>
    <p>Passwort: %s</<p>
    <p>Temperatur: %s Grad</<p>
    <p>Feuchtigkeit: %s %</<p>
    <p>Zeit: %s </<p>
    <div style="width:180px;height:180px; border: 1px solid black;" />
         <a href="http://alarm.meteocentrale.ch/index.html/" </a>
         <img src="http://alarm.meteocentrale.ch/images/map/schweiz_preview.png"
         style="border: 0;"
         alt="Aktuelle Unwetterwarnungen f&uuml;r die Schweiz"/>
    </div>
  </body>
</html>

ALT ist im wesentlichen nur für img - Sources verwendbar und erscheint wenn die Source nicht erreichbar / anzeigbar ist.
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Smart Home Webserver Basic Authentication Problem Osotastic 21 275 20.02.2017 18:00
Letzter Beitrag: Tommy56
  ESP8266 Server connect sowerum 7 439 15.02.2017 11:23
Letzter Beitrag: Tommy56
  ESP8622 - 01 sendet UDP - Problem WLan Kriskind 33 1.197 11.02.2017 18:59
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 300 31.01.2017 20:41
Letzter Beitrag: Tommy56
Bug ESP8266 ESP-12E & DHT22 hängt sporadisch Lurchi 6 217 31.01.2017 17:42
Letzter Beitrag: NormanIGB
  2 ESP8266 miteinander kommunizieren lassen NormanIGB 17 639 29.01.2017 14:14
Letzter Beitrag: NormanIGB
  arduino uno und esp8266-01 kardors 27 923 14.01.2017 16:01
Letzter Beitrag: renid55
  Beim Hochladen USB Problem Nils 10 528 29.12.2016 21:05
Letzter Beitrag: renid55
  ESP8266 ESP12-E Webserver-Frage Claus_M 8 549 14.11.2016 22:02
Letzter Beitrag: Claus_M
  Problem mit SD Card Library BennIY 4 324 06.10.2016 18:38
Letzter Beitrag: Bitklopfer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste