INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 1 Bewertungen - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
ESP8266 HTML Problem
24.04.2016, 14:02
Beitrag #1
ESP8266 HTML Problem
Hallo Community

Ich möchte gerne die aktuelle Gefahrenkarte für meine Land (Schweiz) auf meinem Webserver (http://wlannesslau.internet-box.ch:8000) darstellen

Die Website stellt folgenden Code zur Verfügung:

Code:
<div style="width:180px;height:180px; border: 1px solid black;">
<a href="http://alarm.meteocentrale.ch/index.html" alt="Aktuelle Unwetterwarnungen für die Schweiz" title="Aktuelle Unwetterwarnungen für die Schweiz">
<img src="http://alarm.meteocentrale.ch/images/map/schweiz_preview.png" style="border: 0;" alt="Aktuelle Unwetterwarnungen für die Schweiz" />
</a>
</div>


Ich habe dann diesen Code in meinen Webserver Code hinzugefügt:

1. Vorher:

Code:
void handleRoot() {
  char temp[400];

snprintf ( temp, 400,

"<html>\
  <head>\
    <title>ESP8266 Demo</title>\
    <style>\
      body { background-color: #F7FF00; font-family: Arial, Helvetica, Sans-Serif; Color: #000088; }\
    </style>\
  </head>\
  <body>\
    <h1>Hello from ESP8266!</h1>\
    <p>SSID: %s</<p>\
    <p>Passwort: %s</<p>\
    <p>Temperatur: %s Grad</<p>\
    <p>Feuchtigkeit: %s %</<p>\
    <p>Zeit: %s </<p>\
  </body>\
</html>",

      ssid, password, packetBuffer, packetBuffer2, stringOne
   );
   server.send ( 200, "text/html", temp );
}

2. Nachher:

Code:
void handleRoot() {
  char temp[400];

snprintf ( temp, 400,

"<html>\
  <head>\
    <title>ESP8266 Demo</title>\
    <style>\
      body { background-color: #F7FF00; font-family: Arial, Helvetica, Sans-Serif; Color: #000088; }\
    </style>\
  </head>\
  <body>\
    <h1>Hello from ESP8266!</h1>\
    <p>SSID: %s</<p>\
    <p>Passwort: %s</<p>\
    <p>Temperatur: %s Grad</<p>\
    <p>Feuchtigkeit: %s %</<p>\
    <p>Zeit: %s </<p>\
    <div style=\"/width:180px;height:180px; border: 1px solid black;\" />\
         <a href=\"/http://alarm.meteocentrale.ch/index.html\" />\ alt=\"/Aktuelle Unwetterwarnungen für die Schweiz\" />\ title=\"/Aktuelle Unwetterwarnungen für die Schweiz\" />\
         <img src=\"/http://alarm.meteocentrale.ch/images/map/schweiz_preview.png\" />\ style=\"/border: 0;\" />\ alt=\"/Aktuelle Unwetterwarnungen für die Schweiz\" />\
         </a>\
    </div>\
  </body>\
</html>",

      ssid, password, packetBuffer, packetBuffer2, stringOne
   );
   server.send ( 200, "text/html", temp );
}


Aber irgendwie taucht die Grafik nicht auf, sondern es bleibt genau gleich wie vorher. Könnt ihr mir helfen?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.04.2016, 21:52 (Dieser Beitrag wurde zuletzt bearbeitet: 25.04.2016 21:55 von rkuehle.)
Beitrag #2
RE: ESP8266 HTML Problem
Moin,
anbei mal der HTML-Code der bei mir (Firefox) die Grafik anzeigt.
Grüße Ricardo
Code:
<html>
  <head>
    <title>ESP8266 Demo</title>
    <style>
      body { background-color: #F7FF00; font-family: Arial, Helvetica, Sans-Serif; Color: #000088; }
    </style>
  </head>
  <body>
    <h1>Hello from ESP8266!</h1>
    <p>SSID: %s</<p>
    <p>Passwort: %s</<p>
    <p>Temperatur: %s Grad</<p>
    <p>Feuchtigkeit: %s %</<p>
    <p>Zeit: %s </<p>
    <div style="width:180px;height:180px; border: 1px solid black;" />
         <a href="http://alarm.meteocentrale.ch/index.html/" </a>
         <img src="http://alarm.meteocentrale.ch/images/map/schweiz_preview.png"
         style="border: 0;"
         alt="Aktuelle Unwetterwarnungen f&uuml;r die Schweiz"/>
    </div>
  </body>
</html>

ALT ist im wesentlichen nur für img - Sources verwendbar und erscheint wenn die Source nicht erreichbar / anzeigbar ist.
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  ESP8266 - gelegentliche Verbindungsabbrüche ardu_arne 27 521 Gestern 10:58
Letzter Beitrag: ardu_arne
  Welche OneWire Library für ESP8266-12E? ardu_arne 7 289 30.07.2017 20:21
Letzter Beitrag: Tommy56
  esp8266 OTA Uploadproblem(chen) ardu_arne 24 669 28.07.2017 22:22
Letzter Beitrag: Tommy56
  Einfacher Webserver Nodemcu Esp8266 Onboard Led (Pin) schalten Fips 0 452 18.07.2017 08:10
Letzter Beitrag: Fips
Lightbulb SPIFFS DOWNLOAD UPLOAD & DELETE Esp8266 NodeMCU Fips 24 1.087 14.07.2017 07:24
Letzter Beitrag: Fips
  Hardware für und mit ESP8266 Gelegenheitsbastler 0 352 04.07.2017 19:28
Letzter Beitrag: Gelegenheitsbastler
  [Vorstellung] ESP8266 Webserver mit AJAX Tommy56 19 937 03.07.2017 12:09
Letzter Beitrag: Tommy56
  Esp8266 programmieren Sixtus80 21 1.045 26.06.2017 20:59
Letzter Beitrag: Tommy56
  ESP8266 esp-12e development board & BME280 falsche Werte Lurchi 6 620 09.05.2017 00:54
Letzter Beitrag: Lurchi
Lightbulb ESP8266 ESP-12E & BME280 Lurchi 9 1.593 04.05.2017 11:59
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste