INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
ESP32 (AzureIoT + BLE in keine Header-Dateien)
30.11.2018, 17:04
Beitrag #1
ESP32 (AzureIoT + BLE in keine Header-Dateien)
Hallo!

Ich habe mir einen ESP32 mit einem OLED Display besorgt und wollte den heute das erste mal programmieren.
Jetzt habe ich jedoch das Problem, wenn ich einen Sketch auf das Bord laden möchte, bekomme ich folgende Fehlermeldungen.

Ungültige Bibliothek C:\Program Files (x86)\Arduino-1.8.7\hardware\espressif\esp32\libraries\AzureIoT in keine Header-Dateien (.h) in C:\Program Files (x86)\Arduino-1.8.7\hardware\espressif\esp32\libraries\AzureIoT gefunden

Ungültige Bibliothek C:\Program Files (x86)\Arduino-1.8.7\hardware\espressif\esp32\libraries\BLE in keine Header-Dateien (.h) in C:\Program Files (x86)\Arduino-1.8.7\hardware\espressif\esp32\libraries\BLE gefunden

Die Arduino ESP32 hab ich schon eingebunden. Hat leider nichts gebracht.
Die Ordner in

C:\Program Files (x86)\Arduino-1.8.7\hardware\espressif\esp32\libraries\BLE
C:\Program Files (x86)\Arduino-1.8.7\hardware\espressif\esp32\libraries\AzureIoT

sind beide leer.

Mir ist schon klar das die Dateien fehlen.
Nur wo bekomme ich die her.
Ich suche mir seit Stunden einen Wolf auf Tante Google, wurde aber bis jetzt nicht fündig.

Kann mir da wer weiterhelfen.

DANKE
Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30.11.2018, 17:13
Beitrag #2
RE: ESP32 (AzureIoT + BLE in keine Header-Dateien)
Da scheinen sie bei den ESP32-Libs wieder mal was verbasselt zu haben.
Schau mal, ob Dir das hilft.

Mir ist der ESP32 und sein Umfeld noch zu instabil für eine sinnvolle Nutzung.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30.11.2018, 17:23
Beitrag #3
RE: ESP32 (AzureIoT + BLE in keine Header-Dateien)
(30.11.2018 17:13)Tommy56 schrieb:  Da scheinen sie bei den ESP32-Libs wieder mal was verbasselt zu haben.
Schau mal, ob Dir das hilft.

Mir ist der ESP32 und sein Umfeld noch zu instabil für eine sinnvolle Nutzung.

Gruß Tommy

Danke!

Ja das ist eines der wenigen Dinge, die ich im Netzt gefunden habe, habe ich auch schon probiert.
Leider ohne Erfolg Undecided

Nun, das der ESP32 noch nicht ganz reif ist, ist mir schon klar.
Wollte mir einfach mal ansehen, was man damit und wie anstellen kann / könnte. Blush

Es ist eben nur ärgerlich das ich einfach keine Sketch auf das Bord bekomme um mal die ersten Gehversuche damit zu machen.

LG
Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30.11.2018, 18:23
Beitrag #4
RE: ESP32 (AzureIoT + BLE in keine Header-Dateien)
(30.11.2018 17:04)ChrisL schrieb:  Die Ordner in

C:\Program Files (x86)\Arduino-1.8.7\hardware\espressif\esp32\libraries\BLE
C:\Program Files (x86)\Arduino-1.8.7\hardware\espressif\esp32\libraries\AzureIoT

sind beide leer.

Bei mir sind die gefüllt.
D:\Arduino_Portable\Arduino_Portable_2.4.2\portable\packages\esp32\hardware\esp3​2\1.0.0\libraries\BLE\src

53 Elemente im Ordner sagt WIN10.

Wie hast du den 32er installiert?

Gruß Fips

Meine Esp8266 & ESP32 Projekte
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30.11.2018, 21:13
Beitrag #5
RE: ESP32 (AzureIoT + BLE in keine Header-Dateien)
Hallo,

hier auch alles so vorhanden, Win7-64, IDE 1.8.7 portable, ESP32 v1.0.0 per Boardmanager-Link.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.12.2018, 11:42
Beitrag #6
RE: ESP32 (AzureIoT + BLE in keine Header-Dateien)
Hallo Leute!

Danke für eure Antworten.
Hab jetzt nochmal alles neu installiert.
Leider wieder ohne Erfolg.

Die beiden Ordner
C:\Program Files (x86)\Arduino\hardware\espressif\esp32\libraries\BLE
C:\Program Files (x86)\Arduino\hardware\espressif\esp32\libraries\AzureIoT

sind nachwie vor leer.

Alle anderen Ordner die von der arduino-esp32-master.zip installiert werden sind gefüllt.
Hab ich eventuell die falsche zip Datei.
Ich finde jedoch keine andere.

Ich versteh's ehrlich gesagt nicht.

Von wo habt ihr die esp32.libarie her?
hat vielleicht jemand einen download link, oder sonst noch einen hilfreichen Tip.

Danke
Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.12.2018, 11:58
Beitrag #7
RE: ESP32 (AzureIoT + BLE in keine Header-Dateien)
Hallo,

installiert per Boardmanager-Link:
https://github.com/espressif/arduino-esp...manager.md

Ich nutze im Moment nur die stable 1.0.0 Version. Es gibt beim Espressif-IDF und bei den github Arduino-Versionen noch zuvieles, was sich ständig ändert.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.12.2018, 13:45
Beitrag #8
RE: ESP32 (AzureIoT + BLE in keine Header-Dateien)
(01.12.2018 11:58)amithlon schrieb:  Hallo,

installiert per Boardmanager-Link:
https://github.com/espressif/arduino-esp...manager.md

Ich nutze im Moment nur die stable 1.0.0 Version. Es gibt beim Espressif-IDF und bei den github Arduino-Versionen noch zuvieles, was sich ständig ändert.

Gruß aus Berlin
Michael


Hallo Michael!

So hab jetzt nochmal alles deinstalliert und dann nach dieser Anleitung nochmal installiert.
Jetzt brummt's. Big Grin

Danke für den Tipp!

LG
Christian
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  ESP32 > RS485 >Nano shrimps 3 108 20.09.2019 05:31
Letzter Beitrag: Bitklopfer
Question ESP32: Core Panik! achim81 19 995 11.09.2019 08:03
Letzter Beitrag: Fips
  Debug mit Telnet ESP8266 (und ESP32 ungetestet)) Tommy56 7 4.517 07.09.2019 14:11
Letzter Beitrag: ardu_arne
  ESP8266 8 Kanal Relais keine Aktualisierung im WebIF magnum1795 10 1.060 23.08.2019 07:54
Letzter Beitrag: Fips
  ESP32-CAM Projekt MINICAM Maico 11 1.736 22.08.2019 22:03
Letzter Beitrag: Maico
  ESP32 - Schreibzyklen im RTC RAM Hoffmakl 5 591 22.08.2019 21:07
Letzter Beitrag: Tommy56
  ESP32 mit MAX7219 --> Programmlogik, ich verstehe es nicht... tho.schmidt 4 760 10.08.2019 16:43
Letzter Beitrag: Fips
  ESP32 MQTT Ausfall nach 201 Minuten Jan Hirt 9 1.738 06.08.2019 18:31
Letzter Beitrag: Tommy56
  ESP32 Hostname für die Anzeige im Router ändern Tommy Rakete 4 1.263 17.07.2019 21:42
Letzter Beitrag: Tommy56
  ESP32 Devboard mit Laderegler? markusw129 4 966 14.07.2019 17:33
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste