INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
DHCP Problem lwIP
05.03.2015, 14:52
Beitrag #9
RE: DHCP Problem lwIP
Hm, ich habe mal weiter rum probiert, bekomme aber weiterhin so komische Adressen...

Was mir aber aufgefallen ist, ich bekomme jedesmal paar warnings:
Code:
atsma3x8e.cpp.o:In function `low_level_input'
atsma3x8e.cpp:377: warning: undefined reference to `pbuf_alloc'
atsma3x8e.cpp.o:In function `atsam3x8e_input(void*)'
atsma3x8e.cpp:464: warning: undefined reference to `pbuf_free'
atsma3x8e.cpp.o:In function `low_level_init'
atsma3x8e.cpp:254: warning: undefined reference to `ethernet_phy_init'
atsma3x8e.cpp:260: warning: undefined reference to `ethernet_phy_auto_negotiate'
atsma3x8e.cpp:266: warning: undefined reference to `ethernet_phy_set_link'
atsma3x8e.cpp.o:In function `atsam3x8e_init(netif*)'
atsma3x8e.cpp:520: warning: undefined reference to `etharp_output'
tcp_lwip.cpp.o:In function `loop'
tcp_lwip.ino:63: warning: undefined reference to `lwip_init'
tcp_lwip.ino:74: warning: undefined reference to `netif_add'
tcp_lwip.ino:83: warning: undefined reference to `netif_set_default'
tcp_lwip.ino:86: warning: undefined reference to `netif_set_up'
tcp_lwip.ino:93: warning: undefined reference to `dhcp_start'
tcp_lwip.ino:108: warning: undefined reference to `sys_check_timeouts'
tcp_lwip.ino:113: warning: undefined reference to `sys_check_timeouts'
tcp_lwip.ino:131: warning: undefined reference to `echo_init()'
tcp_lwip.ino:139: warning: undefined reference to `sys_check_timeouts'
tcp_lwip.ino:139: warning: undefined reference to `ip_input'
tcp_lwip.ino:139: warning: undefined reference to `dhcp_timoutcntr'
tcp_lwip.ino:139: warning: undefined reference to `TxPerfConnMonCntr'
tcp_lwip.ino:139: warning: undefined reference to `TcpFastTmrFlag'
tcp_lwip.ino:139: warning: undefined reference to `TcpSlowTmrFlag'

Kann es vielleicht daran liegen??? Und wie kann ich diese beheben?Huh

Gruß KK
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.03.2015, 10:55 (Dieser Beitrag wurde zuletzt bearbeitet: 06.03.2015 10:55 von rkuehle.)
Beitrag #10
RE: DHCP Problem lwIP
Hallo KK66,
kann es sein, dass du mit dem Atmel Studio arbeitest?
Wenn ja musst du wohl das Makefile anpassen.
Wenn nicht (also Arduino IDE) solltest du vielleicht die "atsma3x8e.h" includieren Huh
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.03.2015, 08:07
Beitrag #11
RE: DHCP Problem lwIP
Hallo rkuehle,

also ich arbeite mit Visual Micro, also für Visual Studio 12. Hab da auch mal probiert die Header-Datei zu includieren aber dann kamen noch merkwürdigere Warnings und das Programm hat gar nicht mehr kompiliert... Undecided

Gruß KK
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit der Textauswertung Franz54 13 316 15.04.2018 18:17
Letzter Beitrag: Tommy56
  Problem mit RIFD UID ParadoxDev 6 239 27.03.2018 12:04
Letzter Beitrag: ParadoxDev
  Problem mit OLED 0.96" Display torsten_156 5 1.714 07.03.2018 23:27
Letzter Beitrag: Tommy56
  Ucglib Library Problem Bully 26 941 05.03.2018 18:47
Letzter Beitrag: Tommy56
  Problem mit Wire.available() abfrage avoid 1 331 11.01.2018 13:40
Letzter Beitrag: Tommy56
  SerialComInstruments 4 Problem Darstellung Nextero 35 1.465 15.12.2017 18:51
Letzter Beitrag: ElEspanol
  Problem mit Nema17 und A4988 Philthy 6 460 08.12.2017 12:35
Letzter Beitrag: Tommy56
  Arduino -> Controllino [Problem gelöst] Cyrilsneer 17 1.329 27.11.2017 18:49
Letzter Beitrag: Franz54
Question Problem beim seriellen Einlesen von RFID-Reader Bezel 5 605 05.11.2017 22:37
Letzter Beitrag: Tommy56
  NeoPixels: Sketch will nicht - Problem mit delay? Zabsi 5 828 22.08.2017 15:17
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste