INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
DC Motor läuft unrund
04.01.2015, 06:50
Beitrag #1
DC Motor läuft unrund
Hi, ich hab ein kleines Problem mit einem DC Motor und meinem Adafruite Motor Shield der sich wie folgt darstellt. Ich habe ein UNO Board, das Motor Shield, einen NEMA 17 Stepper und einen kleinen DC Motor welcher viel zu schwach läuft und ruckweise. ABER nur dann wenn der NEMA 17 angeschlossen ist! Klemme ich den Schrittmotor ab läuft der DC Motor einwandfrei, sobald ich den NEMA 17 wieder dranklemme macht der DC Motor zicken.
Der DC Motor funktioniert auch wenn ich im Programm den Stepper auskommentiere.
Habt ihr eine Ahnung woran das liegt?

Gruß Micha
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.01.2015, 08:54
Beitrag #2
RE: DC Motor läuft unrund
Der Stepper zieht vielleicht zu viel Strom?

Wenn der IC raucht wird viel Strom verbraucht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.01.2015, 09:08
Beitrag #3
RE: DC Motor läuft unrund
Ich hab probeweise von einem 0,6A auf 1A Netzteil gewechselt (ich weiß das es auf Dauer zu hoch ist) habe aber keinen Unterschied feststellen können.
Gibt es eine Methode dies zu überprüfen? Meine Mittel sind leider nur sehr begrenzt auf ein einfaches Multimeter.

Gruß Michi
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.01.2015, 09:13
Beitrag #4
RE: DC Motor läuft unrund
Ich nehme an, Du hast die Stromversorgung über das Motorshield gemacht, oder? Ohne separate Stromversorgung für den Motor zieht das Shield Strom über den Arduino und der liefert maximal 0,5 A, unabhängig davon wie viel eingespiesen wird. Beachte auch die Stellung der Jumper auf dem Motorshield: die externe Stromversorgung (Vin Jumper) muss aktiviert sein.

Wenn der IC raucht wird viel Strom verbraucht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.01.2015, 09:55
Beitrag #5
RE: DC Motor läuft unrund
Ja, ich lass die Stromversorgung extern über Motorshield laufen. Dennoch habe ich das Problem. Ich hätte noch ein Netzteil mit 2,4A hab aber Angst das mir die H-Brücke abraucht oder ist das unbedenklich?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.01.2015, 12:29
Beitrag #6
RE: DC Motor läuft unrund
Das hängt von deinem Schrittmotor ab. Er kann nicht mehr aufnehmen als die technischen Spezifikationen aussagen. Auch wenn Deine Stromversorgung 10A abgibt nimmt der Motor nur 2A auf wenn die Wicklungen so definiert sind. Sinnvollerweise erhöhst Du die Spannung für den Motor soweit als möglich, mit höherer Spannung wird der Strombedarf kleiner. Auch hier darfst Du natürlich nicht über die Spezifikationen von Motor und Shield hinausgehen. In meinem Fall betreibe ich einen Schrittmotor mit 12V, der Akku gibt gut und gerne 4A ab bei Vollast, der Motor begrenzt den Strom aber auf ca. 1A.

Wenn der IC raucht wird viel Strom verbraucht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.01.2015, 10:20
Beitrag #7
RE: DC Motor läuft unrund
Alles klar, ich habe festgestellt das mein Motor Shield einfach zu schwach ausgelegt ist trotz der Verwendung eines SN754410 Chip mit Kühlkörper wird mir das Ding (H-Brücke) einfach zu heiß. Der Stepper hat eine Stromaufnahme von 1,2A und der SN754410 verträgt eine Dauerlast von 1A. Ich denke bei simultaner Nutzung des DC Motors und dem Stepper ist es einfach zu viel (kp was der DC verbraucht). Ich werde mir die neuere Version des Shield holen was ich eigentlich schon länger vor hatte.
@ Rene, du hatte übrigens recht mit der Stromversorgung ich habe es kurz mit einem Akku laufen lassen 12V 2,4A und es lief einwandfrei. Nur war die Wärmeentwicklung dermaßen hoch das ich nach ca. 1min es abgebrochen habe.
Vielen Dank für deine Hilfe!

Gruß Micha
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Motor reagiert nur auf 5 Volt Flap 18 493 22.10.2016 10:31
Letzter Beitrag: hotsystems
  Schrittmotor ruckelt beim Start und im laufenden Betrieb - Arduino+Motor Shield grt35a 3 276 21.09.2016 06:56
Letzter Beitrag: Bitklopfer
  Arduino hängt bei DC-Motor MeisterQ 4 248 27.08.2016 18:39
Letzter Beitrag: Binatone
  Past der Schritt Motor??? Uwe1475 0 161 11.08.2016 19:56
Letzter Beitrag: Uwe1475
  Nema 17 Schrittmotor läuft an a4988 nicht fagus 9 585 04.08.2016 20:12
Letzter Beitrag: fagus
  Motor Shield wird Heiß erwin 8 1.135 24.03.2016 11:29
Letzter Beitrag: hotsystems
  Bipolar Motor ansteuern #elextro19 7 748 12.02.2016 02:11
Letzter Beitrag: Wetteronkel
  Motor shield #elextro19 2 667 25.01.2016 09:24
Letzter Beitrag: #elextro19
  Problem mit adafruit motor shield Philthy 13 1.822 22.12.2015 15:27
Letzter Beitrag: hotsystems
Question Motor mit kontrollierter Kraft und Positionsangabe decoder_oh 6 1.130 15.10.2015 09:18
Letzter Beitrag: Binatone

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste