INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Brauche Hilfe, bin absoluter Neuling!
27.04.2013, 16:26
Beitrag #1
Brauche Hilfe, bin absoluter Neuling!
Hallo zusammen,

ich muss im Rahmen dieses Semesters eine Schaltung für ein Projekt bauen. Studiere eigentlich hauptsächlich Gestaltung und kenne mich deshalb mit dem Arduino etc. nicht wirklich aus. Ich habe nun einen Arduino Mega zur Verfügung gestellt bekommen und möchte über ein Relay verschiedene LEDs ansteuern. Um das Ganze erstmal über einen PIN zu testen, wollte ich nun den "Blink" Code aus den Beispielen von Arduino ausprobieren.
Das Problem liegt nun darin, dass die angebrachte LED auf dem Relay nun zwar blinkt, dies jedoch nur einmal tut. Das heißt die LED ist an, geht aus, anschließend wieder an und bleibt dann aber auch an.
Eigentlich sollte die LED doch dann blinken, oder?
Kann mir jemand weiterhelfen?
Vielen Dank!

lg Daniela
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.04.2013, 09:10
Beitrag #2
RE: Brauche Hilfe, bin absoluter Neuling!
(27.04.2013 16:26)newbie schrieb:  Hallo zusammen,

ich muss im Rahmen dieses Semesters eine Schaltung für ein Projekt bauen. Studiere eigentlich hauptsächlich Gestaltung und kenne mich deshalb mit dem Arduino etc. nicht wirklich aus. Ich habe nun einen Arduino Mega zur Verfügung gestellt bekommen und möchte über ein Relay verschiedene LEDs ansteuern. Um das Ganze erstmal über einen PIN zu testen, wollte ich nun den "Blink" Code aus den Beispielen von Arduino ausprobieren.
Das Problem liegt nun darin, dass die angebrachte LED auf dem Relay nun zwar blinkt, dies jedoch nur einmal tut. Das heißt die LED ist an, geht aus, anschließend wieder an und bleibt dann aber auch an.
Eigentlich sollte die LED doch dann blinken, oder?
Kann mir jemand weiterhelfen?
Vielen Dank!

lg Daniela
Hallo Daniela, das blinken passiert beim laden des Programmes. Ich vermute, Du hast nicht den richtigen Sketch (Blink) geladen. Versuche es nochmal damit. Ich verstehe auch nicht, warum Du die LED erst über ein Relais ansteuerst. Du kannst sie ja auch direkt an die PIN`s (z.B. PIN 13) anstecken, wenn Du die 40mA Belastung pro PIN nicht überschreitest.
Viel Erfolg!
neuling
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.04.2013, 16:56
Beitrag #3
RE: Brauche Hilfe, bin absoluter Neuling!
Hey,

danke für deine Antwort. Das Relais brauche ich für eine größere Schaltung. Die eine LED habe ich nur darüber geschalten, um den ganzen Mechanismus erstmal auszuprobieren.
Ich habe dieses Programm hergenommen:

/*
Blink
Turns on an LED on for one second, then off for one second, repeatedly.

This example code is in the public domain.
*/

// Pin 13 has an LED connected on most Arduino boards.
// give it a name:
int led = 13;

// the setup routine runs once when you press reset:
void setup() {
// initialize the digital pin as an output.
pinMode(led, OUTPUT);
}

// the loop routine runs over and over again forever:
void loop() {
digitalWrite(led, HIGH); // turn the LED on (HIGH is the voltage level)
delay(1000); // wait for a second
digitalWrite(led, LOW); // turn the LED off by making the voltage LOW
delay(1000); // wait for a second
}


Anstatt der 13 oben, kann ich doch einfach jede Nummer von den Digitalen PINS angeben oder?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
08.05.2013, 21:20
Beitrag #4
RE: Brauche Hilfe, bin absoluter Neuling!
(28.04.2013 16:56)newbie schrieb:  Hey,

danke für deine Antwort. Das Relais brauche ich für eine größere Schaltung. Die eine LED habe ich nur darüber geschalten, um den ganzen Mechanismus erstmal auszuprobieren.
Ich habe dieses Programm hergenommen:

/*
Blink
Turns on an LED on for one second, then off for one second, repeatedly.

This example code is in the public domain.
*/

// Pin 13 has an LED connected on most Arduino boards.
// give it a name:
int led = 13;

// the setup routine runs once when you press reset:
void setup() {
// initialize the digital pin as an output.
pinMode(led, OUTPUT);
}

// the loop routine runs over and over again forever:
void loop() {
digitalWrite(led, HIGH); // turn the LED on (HIGH is the voltage level)
delay(1000); // wait for a second
digitalWrite(led, LOW); // turn the LED off by making the voltage LOW
delay(1000); // wait for a second
}


Anstatt der 13 oben, kann ich doch einfach jede Nummer von den Digitalen PINS angeben oder?

Ja, kann man sofern der Port auch als Digital Out zu verwenden geht.
..beim Arduino Nano Port A6 und A7 geht nicht, das sind nur Analog Eingänge.

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.05.2013, 16:53
Beitrag #5
RE: Brauche Hilfe, bin absoluter Neuling!
Hallo Leute, habe schon sehr viele gute Antworten bzw. Hilfestellungen auf mein PWM Softstart Problem erhalten.
Ich konnte jedoch das eigentliche Problem nicht lösen. Ich versuche die ganze Zeit einen Softstard mit einem PWM Signal mit einem UNO,einem Joystick und einem Motorshield hinzubekommen. Ich benütze einen 12volt Getriebemotor. Der Motor läuft direkt über einen Poti total schön an!!!! Wenn ich jedoch über das Arduino antreibe, dann fähr er immer ruckartig an. Ich weiß mir keinen Rat, warum das so ist. Ich habe ien Programm erhalten, wo das Arduino schrittweise hinaufzhät, sodass keine wirklichen Stufen entstehen können.Kann mir jemand helfen, ich weiß mir keinen Rat mehr??????????????????????????
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.05.2013, 19:08
Beitrag #6
RE: Brauche Hilfe, bin absoluter Neuling!
(26.05.2013 16:53)Martin Steger schrieb:  Hallo Leute, habe schon sehr viele gute Antworten bzw. Hilfestellungen auf mein PWM Softstart Problem erhalten.
Ich konnte jedoch das eigentliche Problem nicht lösen. Ich versuche die ganze Zeit einen Softstard mit einem PWM Signal mit einem UNO,einem Joystick und einem Motorshield hinzubekommen. Ich benütze einen 12volt Getriebemotor. Der Motor läuft direkt über einen Poti total schön an!!!! Wenn ich jedoch über das Arduino antreibe, dann fähr er immer ruckartig an. Ich weiß mir keinen Rat, warum das so ist. Ich habe ien Programm erhalten, wo das Arduino schrittweise hinaufzhät, sodass keine wirklichen Stufen entstehen können.Kann mir jemand helfen, ich weiß mir keinen Rat mehr??????????????????????????

...ähm...war dein Anliegen nicht in nem anderen Thread, nämlich hier:
http://www.arduinoforum.de/arduino-Threa...sen?page=2 Huh

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.05.2013, 22:14
Beitrag #7
RE: Brauche Hilfe, bin absoluter Neuling!
Ja genau, ich wollte möglichst viele Meinungen einholen, da du mir zwar einen super code geschrieben hast. Danke nochmal!!! Aber dieser leider nicht funktioniert hat bzw der Motor 1. noch immer ruckartig losfährt und der trotz einem delay von 1 total lange braucht bis er losfährt. bin mittlerweile etwas frustriert, weil es mit dem poti super zum softstarten geht aber mit dem arduino nicht. Kein Mensch kann mir sagen warum!!! Ich hoffe es geht in Ordnung, dass ich in mehreren Foren nachfrage.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Hilfe: IR Remote Steuerung, MSGEQ7 + RGB-LED Streifen dastob 1 123 14.10.2016 21:40
Letzter Beitrag: hotsystems
Sad Ich brauche Hilfe Prosac 4 237 09.10.2016 18:39
Letzter Beitrag: Prosac
  at24c256 Hilfe Gandalf 6 249 29.08.2016 18:59
Letzter Beitrag: MKc
Smile Progammier Neuling Codeschloss bittet um Hilfe Donalonso 2 287 27.08.2016 18:23
Letzter Beitrag: Binatone
  Hilfe gesucht. Webserver Statsiche und Dynamische HTMl Seite b3ta 11 454 22.08.2016 08:07
Letzter Beitrag: b3ta
  Hilfe: Mega2560 - ENC 28J60 - MYSQL Gandalf 1 181 28.07.2016 16:30
Letzter Beitrag: Gandalf
  Selbstfahrender Roboter Programm änderung hilfe ? arekklone 11 550 06.07.2016 14:59
Letzter Beitrag: Binatone
Wink Bin Neuling Guekard 62 3.242 12.06.2016 19:01
Letzter Beitrag: hotsystems
  Hilfe beim Arduino Shield reimundko 6 460 05.06.2016 11:28
Letzter Beitrag: rpt007
  Brauche etwas Hilfe bei der Umsetzung einer Idee raspido 3 536 23.04.2016 10:26
Letzter Beitrag: rkuehle

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste