INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Blutiger Anfänger hat ein Syntax Problem, bitte um Unterstützung
24.09.2014, 18:30
Beitrag #1
Smile Blutiger Anfänger hat ein Syntax Problem, bitte um Unterstützung
Hallo liebe Community,

ich arbeite mich im Moment durch das Buch "Arduino, Physical Computing für Bastler, Designer & Geeks" vom O'Reilly Verlag. Entweder ich habe es geschafft 3x falsch aus dem Buch abzuschreiben, oder aber es ist fehlerhafte Syntax abgedruckt.

Bis jetzt, hat alles was ich aus dem Buch gelernt und auf meinen Arduino Duemilanove übertragen habe auch so wie beschrieben funktioniert.

Der aktuelle Code, der mir Kopfschmerzen bereitet (weil ich noch nicht verstehe, was falsch ist / sein könnte), sieht so aus:

Code anfang:

int led[4] = { 10,11,12,13};
int oldVal = 0;
int counter = 0;
int taster = 2;
void setup() {
for (int i = 0; i<4; i++){
pinMode(led[i], OUTPUT);
}
void setLED(int ledNr) {
for (int i = 0;i<4;i++) {
if (i == ledNr) {
digitalWrite(led[i]; HIGH);
}
else {
digitalWrite(led[i]; LOW);
}
}
}
int setCounter(int counter) {
if (counter == 3) {
counter = 0;
}
else {
counter++;
}
return counter;
}
void loop()
{
int val = digitalRead(taster);
if (val != oldVal && val == HIGH) {
counter = setCounter();
setLED(counter);
delay(10);
}
oldVal = val;
}

Code Ende.

Und dieser Fehler wird mir angezeigt, wenn ich versuche den Code zu kompilieren:

[Bild: jp3hib8k43ig.jpg]

Habe ich es richtig verstanden, das nacheinander die 4 angeschlossenen LEDs leuchten, danach 10 Ms Wartezeit verstreicht - und erst dann wieder durchlaufen, wenn ich den Taster drücke?

Besten Dank schonmal im Voraus! Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.09.2014, 18:38
Beitrag #2
RE: Blutiger Anfänger hat ein Syntax Problem, bitte um Unterstützung
Hi,
hier...

void setup() {
for (int i = 0; i<4; i++){
pinMode(led[i], OUTPUT);
}

Da fehlt noch eine schliessende "}" um die Definition der Funktion setup abzuschliessen.
Gruss,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Smart Home Webserver Basic Authentication Problem Osotastic 21 383 20.02.2017 18:00
Letzter Beitrag: Tommy56
  ESP8622 - 01 sendet UDP - Problem WLan Kriskind 33 1.664 11.02.2017 18:59
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 346 31.01.2017 20:41
Letzter Beitrag: Tommy56
  Beim Hochladen USB Problem Nils 10 562 29.12.2016 21:05
Letzter Beitrag: renid55
  Problem mit SD Card Library BennIY 4 345 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 298 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 1.075 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 630 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 895 13.06.2016 21:14
Letzter Beitrag: torsten_156
  ESP8266_01 flashen - Problem torsten_156 12 1.372 30.05.2016 20:12
Letzter Beitrag: torsten_156

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste