INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Blutiger Anfänger hat ein Syntax Problem, bitte um Unterstützung
24.09.2014, 18:30
Beitrag #1
Smile Blutiger Anfänger hat ein Syntax Problem, bitte um Unterstützung
Hallo liebe Community,

ich arbeite mich im Moment durch das Buch "Arduino, Physical Computing für Bastler, Designer & Geeks" vom O'Reilly Verlag. Entweder ich habe es geschafft 3x falsch aus dem Buch abzuschreiben, oder aber es ist fehlerhafte Syntax abgedruckt.

Bis jetzt, hat alles was ich aus dem Buch gelernt und auf meinen Arduino Duemilanove übertragen habe auch so wie beschrieben funktioniert.

Der aktuelle Code, der mir Kopfschmerzen bereitet (weil ich noch nicht verstehe, was falsch ist / sein könnte), sieht so aus:

Code anfang:

int led[4] = { 10,11,12,13};
int oldVal = 0;
int counter = 0;
int taster = 2;
void setup() {
for (int i = 0; i<4; i++){
pinMode(led[i], OUTPUT);
}
void setLED(int ledNr) {
for (int i = 0;i<4;i++) {
if (i == ledNr) {
digitalWrite(led[i]; HIGH);
}
else {
digitalWrite(led[i]; LOW);
}
}
}
int setCounter(int counter) {
if (counter == 3) {
counter = 0;
}
else {
counter++;
}
return counter;
}
void loop()
{
int val = digitalRead(taster);
if (val != oldVal && val == HIGH) {
counter = setCounter();
setLED(counter);
delay(10);
}
oldVal = val;
}

Code Ende.

Und dieser Fehler wird mir angezeigt, wenn ich versuche den Code zu kompilieren:

[Bild: jp3hib8k43ig.jpg]

Habe ich es richtig verstanden, das nacheinander die 4 angeschlossenen LEDs leuchten, danach 10 Ms Wartezeit verstreicht - und erst dann wieder durchlaufen, wenn ich den Taster drücke?

Besten Dank schonmal im Voraus! Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.09.2014, 18:38
Beitrag #2
RE: Blutiger Anfänger hat ein Syntax Problem, bitte um Unterstützung
Hi,
hier...

void setup() {
for (int i = 0; i<4; i++){
pinMode(led[i], OUTPUT);
}

Da fehlt noch eine schliessende "}" um die Definition der Funktion setup abzuschliessen.
Gruss,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Wie wird bitte der Pin EN am HC05 gesetzt ? comfan 3 217 26.09.2017 16:34
Letzter Beitrag: Alfrede
  NeoPixels: Sketch will nicht - Problem mit delay? Zabsi 5 313 22.08.2017 15:17
Letzter Beitrag: Tommy56
  Problem mit LSM 303 Snörb 1 235 22.08.2017 14:16
Letzter Beitrag: Snörb
  Problem mit externem Interrupt manfred474 13 923 13.08.2017 08:54
Letzter Beitrag: MicroBahner
  Problem mit Klassen GuaAck 4 359 09.08.2017 09:28
Letzter Beitrag: MicroBahner
Question Problem mit TFT Sam217 8 679 20.07.2017 21:51
Letzter Beitrag: hotsystems
  Problem FastLED fliege_m 3 446 16.07.2017 16:56
Letzter Beitrag: Tommy56
  Ublox Neo 6M und Nextion ! Bitte um Hilfe. b3ta 19 1.068 13.07.2017 14:52
Letzter Beitrag: Tommy56
  Anfänger sucht erfahrene Hilfe Customizer 21 1.383 11.07.2017 21:37
Letzter Beitrag: Customizer
  eine einfache Xor Bitte ? himbeersirup 1 297 08.06.2017 09:15
Letzter Beitrag: MicroBahner

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste