INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Bitte um Hilfe
05.03.2015, 20:06
Beitrag #1
Bitte um Hilfe
Hallo,

bin Arduino-Neuling und habe ein Problem, mit der Bitte um Hilfe.

Ich möchte mir einen Kamerslider bauen. Das Projekt findet man unter: http://www.halecker.de/kameraslider/category/hardware/

Dort habe ich mir die "aktuelle" INO datei Version 1.1.2 heruntergeladen: http://www.halecker.de/kameraslider/downloads/

Nachdem ich meine Arduino IDE geöffnet habe und den CODE mit dem "Verifizieren" will bekomme ich folgende Fehlermeldung unten im Fenster angezeigt:

Kameraslider_v112.cpp.o: In function `loop':
/Arduino/Kameraslider_v112.ino:610Sad.text.loop+0x1850): relocation truncated to fit: R_AVR_13_PCREL against `no symbol'
collect2: error: ld returned 1 exit status
Fehler beim Kompilieren.

Ich probier jetzt seit Stunden rum und habe überhaupt keine Idee was da falsch läuft.

Vielleicht gibt es jemand unter Euch, der so nett ist und mir bitte helfen kann.

cu Holger
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.03.2015, 21:23
Beitrag #2
RE: Bitte um Hilfe
ich habe die Sachen mal aus dem Netz geholt und mich ein bisschen belesen.
Das Problem sind die beim Linken benutzten Optionen.
Das Ganze lässt sich unter der 1.0.6 Version der IDE ohne Probleme übersetzen.
Dort sind die Linker-Optionen wohl anders gesetzt.
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.03.2015, 16:10
Beitrag #3
RE: Bitte um Hilfe
Hallo zusammen,

vielen Dank für die Antworten.
D. h., ich muss das aktuelle Arduino IDE deinstallieren und das 1.0.6 installieren?
Muss ich dann den Ordner Libraries auch löschen oder greift die "alte" Version auf dieses Verzeichnis zu ?

cu Holger
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.03.2015, 17:47
Beitrag #4
RE: Bitte um Hilfe
Hallo Holger,
Zitat:D. h., ich muss das aktuelle Arduino IDE deinstallieren und das 1.0.6 installieren?
Ja.
Zitat:Muss ich dann den Ordner Libraries auch löschen oder greift die "alte" Version auf dieses Verzeichnis zu ?
Mit der Deinstallation der bisherigen IDE wird ja der Libraries Ordner auch gelöscht.
Daher vor der Deinstallation eine Kopie des Libraries Ordners machen.
Dann die alte Version deinstallieren, die neue Version installieren.
Danach die Kopie des Libraries - Ordners der alten Version auf die neue Version raufkopieren. Danach hast du eine neue IDE-Version mit dem Inhalt des Libraries Ordners der alten Version.
Wichtig: da die IDE ja selbst auch schon Libraries mitbringt solltest du bei einer Abfrage ob ein vorhandener Ordner überschrieben werden soll, "Überspringen" auswählen.
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Hilfe: IR Remote Steuerung, MSGEQ7 + RGB-LED Streifen dastob 1 123 14.10.2016 21:40
Letzter Beitrag: hotsystems
Sad Ich brauche Hilfe Prosac 4 237 09.10.2016 18:39
Letzter Beitrag: Prosac
  at24c256 Hilfe Gandalf 6 249 29.08.2016 18:59
Letzter Beitrag: MKc
Smile Progammier Neuling Codeschloss bittet um Hilfe Donalonso 2 287 27.08.2016 18:23
Letzter Beitrag: Binatone
  Hilfe gesucht. Webserver Statsiche und Dynamische HTMl Seite b3ta 11 454 22.08.2016 08:07
Letzter Beitrag: b3ta
  Hilfe: Mega2560 - ENC 28J60 - MYSQL Gandalf 1 181 28.07.2016 16:30
Letzter Beitrag: Gandalf
  Selbstfahrender Roboter Programm änderung hilfe ? arekklone 11 550 06.07.2016 14:59
Letzter Beitrag: Binatone
  Hilfe beim Arduino Shield reimundko 6 459 05.06.2016 11:28
Letzter Beitrag: rpt007
  Brauche etwas Hilfe bei der Umsetzung einer Idee raspido 3 536 23.04.2016 10:26
Letzter Beitrag: rkuehle
  Wo finde ich bitte die LIB USBHOST ? arduinopeter 6 502 24.03.2016 16:53
Letzter Beitrag: arduinopeter

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste