INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Ausgabe druckt immer 2 Werte anstatt nur einen. Finde den Fehler nicht
02.07.2016, 14:18
Beitrag #25
RE: Ausgabe druckt immer 2 Werte anstatt nur einen. Finde den Fehler nicht
(02.07.2016 13:56)Pit schrieb:  @hotsystems

Zitat:"Dann hast du da etwas falsch gemacht oder die "billigen Schrottteile" genommen."

ich geb' zu, ich hab' die "billigen Schrottteile" genommen.
Ich wollte aber nicht nur ein an/aus Signal übertragen sondern ein Datenpaket in ca. 250 byte Länge.
Ein Signal ist in vielleicht 80 Prozent angekommen.
Der korrekte Datenstring kam nur in Ausnahmefällen an.
Natürlich könnte man nun einen Fehlererkennungs- oder sogar Fehlerkorrekturcode einsetzen.
Aber die Störanfälligkeit war so gross, dass das keine Option schien.
Vielleicht probiere ich das gelegentlich noch mal mit Besseren als den "Schrottteilen" aus.

Das Problem bei den "billigen" Teilen ist die veraltete Technik. Da ist keinerlei Großsignalfestigkeit und Selektion drin. Jedes naheliegende Signal (CB-Funk) auf einem Nachbarkanal stört den Empfang gewaltig. Besonders in größeren Städten wirkt sich das negativ aus.

Ich bin schon seit einiger Zeit mit den besseren Empfängern (diese hier) am experimentieren und das funktioniert auch sehr gut. Auch mit längeren Datenpaketen.

Ich gebe zu, keine 250 Byte sondern nur 50 Byte aber auch das sollte funktionieren. Und aus Sicherheitsgründen muss man das mehrfach senden und anschließend eben vergleichen. Das sollte per Funk immer gemacht werden.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Analog Read, Fehler nach 0,6 Sekunden, Prescaler, SD nilsconrad 18 339 21.02.2017 21:46
Letzter Beitrag: Bitklopfer
Rainbow File geht nicht zum compilieren!!!! Jocky 7 135 19.02.2017 20:01
Letzter Beitrag: Binatone
  IRremote bringe ich nicht zum laufen Franz54 5 86 19.02.2017 11:56
Letzter Beitrag: Tommy56
  Servo-Ansteuerung über einen Push-Button Aubergine83 1 91 16.02.2017 19:49
Letzter Beitrag: georg01
  Code aus 1.6.9 geht mit 1.8.1 nicht mehr zu kompilieren DL1AKP 7 257 02.02.2017 12:16
Letzter Beitrag: Tommy56
  Arduino Läst sich nicht Programmieren Micha06 4 184 29.01.2017 17:27
Letzter Beitrag: Micha06
  Nicht verzagen Forum fragen bergfrei 13 403 28.01.2017 06:09
Letzter Beitrag: dqb312
  Sloeber findet meinen Com Port nicht :-( Pfeilebastler 2 106 27.01.2017 11:11
Letzter Beitrag: hotsystems
  Seltsamer Fehler bei Vergleichsoperation ardu_arne 14 320 22.01.2017 20:35
Letzter Beitrag: Binatone
  nRF24l01 empfängt Daten nicht techniclover 1 181 09.01.2017 19:20
Letzter Beitrag: celle

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste