INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Ausgabe druckt immer 2 Werte anstatt nur einen. Finde den Fehler nicht
02.07.2016, 14:18
Beitrag #25
RE: Ausgabe druckt immer 2 Werte anstatt nur einen. Finde den Fehler nicht
(02.07.2016 13:56)Pit schrieb:  @hotsystems

Zitat:"Dann hast du da etwas falsch gemacht oder die "billigen Schrottteile" genommen."

ich geb' zu, ich hab' die "billigen Schrottteile" genommen.
Ich wollte aber nicht nur ein an/aus Signal übertragen sondern ein Datenpaket in ca. 250 byte Länge.
Ein Signal ist in vielleicht 80 Prozent angekommen.
Der korrekte Datenstring kam nur in Ausnahmefällen an.
Natürlich könnte man nun einen Fehlererkennungs- oder sogar Fehlerkorrekturcode einsetzen.
Aber die Störanfälligkeit war so gross, dass das keine Option schien.
Vielleicht probiere ich das gelegentlich noch mal mit Besseren als den "Schrottteilen" aus.

Das Problem bei den "billigen" Teilen ist die veraltete Technik. Da ist keinerlei Großsignalfestigkeit und Selektion drin. Jedes naheliegende Signal (CB-Funk) auf einem Nachbarkanal stört den Empfang gewaltig. Besonders in größeren Städten wirkt sich das negativ aus.

Ich bin schon seit einiger Zeit mit den besseren Empfängern (diese hier) am experimentieren und das funktioniert auch sehr gut. Auch mit längeren Datenpaketen.

Ich gebe zu, keine 250 Byte sondern nur 50 Byte aber auch das sollte funktionieren. Und aus Sicherheitsgründen muss man das mehrfach senden und anschließend eben vergleichen. Das sollte per Funk immer gemacht werden.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino funktioniert immer erst nach reset Maxi290997 8 250 Heute 16:33
Letzter Beitrag: Maxi290997
  Ich komme mit millis nicht weiter !!! Gonmaus 8 376 09.07.2017 21:24
Letzter Beitrag: Tommy56
  Countdown - Werte ändern am Touchscreen ElAleMaNo 2 236 04.07.2017 18:43
Letzter Beitrag: Tommy56
  Brauche einen Sketch zum Testen HDT 12 502 22.06.2017 07:37
Letzter Beitrag: HDT
  Compiler Fehler Harti 8 334 16.06.2017 17:51
Letzter Beitrag: Harti
  Motor Steuerung durch Sensoren Werte Zerebrator 14 488 12.06.2017 14:36
Letzter Beitrag: Franz54
  WEMOS Motorshield funzt nicht Rumpl-X 8 280 07.06.2017 21:10
Letzter Beitrag: Tommy56
  Arduino Sensor zeigt falsche Werte an Sandro2504 4 236 04.06.2017 09:03
Letzter Beitrag: hotsystems
  Fehler bei Zeitmessung Fox 15 400 24.05.2017 09:19
Letzter Beitrag: SkobyMobil
  LCD geht nicht - keine Ahnung warum?? DL1AKP 12 562 15.05.2017 13:17
Letzter Beitrag: DL1AKP

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste