INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Ausgabe LCD-Display funktioniert nicht
23.12.2020, 14:11 (Dieser Beitrag wurde zuletzt bearbeitet: 23.12.2020 14:38 von wonk.)
Beitrag #1
Ausgabe LCD-Display funktioniert nicht
Hallo,
Kann mir jemand sagen, warum durch das folgende Prgrämmchen nur jeweils der 1. Buchstabe in der Zeile ausgegeben wird? Ich bin mir sicher, dass es früher eine komplette Ausgabe der Texte erfolgte. Die Verkabelung habe ich geprüft.

Code:
#include <Wire.h>  // Wire Bibliothek hochladen
#include <LiquidCrystal_I2C.h> // Vorher hinzugefügte LiquidCrystal_I2C Bibliothek hochladen
LiquidCrystal_I2C lcd(0x27, 16, 2);  //Hier wird das Display benannt (Adresse/Zeichen pro Zeile/Anzahl Zeilen).
//In unserem Fall „lcd“. Die Adresse des I²C Displays kann je nach Modul variieren.

void setup()
{
lcd.init(); //Im Setup wird der LCD gestartet
lcd.backlight(); //Hintergrundbeleuchtung einschalten (0 schaltet die Beleuchtung aus).
}

void loop()
{
lcd.setCursor(0,0); //Text soll beim ersten Zeichen in der ersten Reihe beginnen..
lcd.print("Test Zeile 1"); //In der ersten Zeile soll der Text „Test Zeile 1“ angezeigt werden
lcd.setCursor(0,1);
lcd.print("Zeile 2");
delay(1000);
}
Danke, Gruss, wonk
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.12.2020, 15:57
Beitrag #2
RE: Ausgabe LCD-Display funktioniert nicht
(23.12.2020 14:11)wonk schrieb:  Hallo,
Kann mir jemand sagen, warum durch das folgende Prgrämmchen nur jeweils der 1. Buchstabe in der Zeile ausgegeben wird? Ich bin mir sicher, dass es früher eine komplette Ausgabe der Texte erfolgte. Die Verkabelung habe ich geprüft.

Code:
#include <Wire.h>  // Wire Bibliothek hochladen
#include <LiquidCrystal_I2C.h> // Vorher hinzugefügte LiquidCrystal_I2C Bibliothek hochladen
LiquidCrystal_I2C lcd(0x27, 16, 2);  //Hier wird das Display benannt (Adresse/Zeichen pro Zeile/Anzahl Zeilen).
//In unserem Fall „lcd“. Die Adresse des I²C Displays kann je nach Modul variieren.

void setup()
{
lcd.init(); //Im Setup wird der LCD gestartet
lcd.backlight(); //Hintergrundbeleuchtung einschalten (0 schaltet die Beleuchtung aus).
}

void loop()
{
lcd.setCursor(0,0); //Text soll beim ersten Zeichen in der ersten Reihe beginnen..
lcd.print("Test Zeile 1"); //In der ersten Zeile soll der Text „Test Zeile 1“ angezeigt werden
lcd.setCursor(0,1);
lcd.print("Zeile 2");
delay(1000);
}
Danke, Gruss, wonk
Hallo , bei mir läuft der gleiche Sketch ohne Probleme, allerdings habe ich kein delay drin.

Mit freundlichen Grüßen
Norbert
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.12.2020, 16:58
Beitrag #3
RE: Ausgabe LCD-Display funktioniert nicht
Vermutlich passt der Sketch nicht zur Library.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.12.2020, 17:42
Beitrag #4
RE: Ausgabe LCD-Display funktioniert nicht
Hi,

das klingt nach dem Problem was hier unter LiquidCrystal_I2C beschrieben ist >>> https://arduino-projekte.webnode.at/fremdlibraries/
Da bin ich vor längere Zeit selber drüber gestolpert, weshalb ich mir sowas auch ewig merke ...

Gruß André
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.12.2020, 18:05
Beitrag #5
RE: Ausgabe LCD-Display funktioniert nicht
(23.12.2020 17:42)SpaghettiCode schrieb:  Hi,

das klingt nach dem Problem was hier unter LiquidCrystal_I2C beschrieben ist >>> https://arduino-projekte.webnode.at/fremdlibraries/
Da bin ich vor längere Zeit selber drüber gestolpert, weshalb ich mir sowas auch ewig merke ...

Gruß André

Ja, vor einigen Jahren lag das Problem an einem IDE --Update, welches dann wohl kurzfristig wieder verschwunden ist. Neuere IDE-Versionen kennen das Problem aber nicht.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.12.2020, 21:07
Beitrag #6
RE: Ausgabe LCD-Display funktioniert nicht
(23.12.2020 17:42)SpaghettiCode schrieb:  Hi,

das klingt nach dem Problem was hier unter LiquidCrystal_I2C beschrieben ist >>> https://arduino-projekte.webnode.at/fremdlibraries/
Da bin ich vor längere Zeit selber drüber gestolpert, weshalb ich mir sowas auch ewig merke ...

Gruß André
Danke, genau das war es. Ich hatte vorher die "normale" IDE-Version verwendet, mit der es auch so lief. Jetzt habe ich die portable IDE-Version. Die verlangt offensichtlich die dort beschriebene Anpassung.
Gruss, wonk
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.12.2020, 21:15
Beitrag #7
RE: Ausgabe LCD-Display funktioniert nicht
(23.12.2020 21:07)wonk schrieb:  Danke, genau das war es. Ich hatte vorher die "normale" IDE-Version verwendet, mit der es auch so lief. Jetzt habe ich die portable IDE-Version. Die verlangt offensichtlich die dort beschriebene Anpassung.
Gruss, wonk

Das hat aber nichts mit normal oder portabel zu tun. Da musst du eine uralte Version drauf gehabt haben.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Suche adapter oled zu 3,5' Display dc7fb 21 2.717 19.06.2021 12:11
Letzter Beitrag: hotsystems
  Bootloader will sich nicht auf Mini Pro installieren lassen Foto-Ralf 27 3.608 09.06.2021 07:15
Letzter Beitrag: SpaghettiCode
  Arduino Mega wird nicht erkannt Gian-Luca 61 18.147 27.05.2021 23:21
Letzter Beitrag: Hurz
  Arduino startet nicht kpc 14 2.452 27.04.2021 22:24
Letzter Beitrag: hotsystems
  MKR1200 läuft nicht bei Batteriebetrieb kpc 24 4.889 05.04.2021 22:59
Letzter Beitrag: kpc
  Einfaches Projekt funktioniert am USB Anschluss, aber nicht mit Akkus PurpleLightning 3 888 05.04.2021 12:07
Letzter Beitrag: hotsystems
  Sketche lassen sich aus IDE nicht mehr hochladen Steinspiel 9 2.216 19.03.2021 19:11
Letzter Beitrag: Chopp
  Sketches lassen sich nicht mehr hochladen. Was kann ich noch tun? Tonio 3 1.081 19.03.2021 15:32
Letzter Beitrag: Tommy56
  Servo funktioniert nicht richtig an Arduino Nano Maxcruiser 25 4.831 14.03.2021 17:11
Letzter Beitrag: hotsystems
  2 I2C-Devices nicht zusammen wonk 36 6.854 04.03.2021 00:08
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste