INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
AtTiny85 spielt Code nicht ab?!?
05.08.2014, 17:50
Beitrag #1
AtTiny85 spielt Code nicht ab?!?
Hy,

kann mir jemand sagen warum der unten stehende Code auf einem AtTiny85(interne 1MHz Clock) nicht funktioniert?? Programmiert über ISP Arduino, Chip ist geflashed, Bootloader installiert!! Habe blink ausprobiert und ein paar andere Standarts die laufen.

Code:
#define SHUTTER_PIN PB2
#define LIGHTNING_TRIGGER_ANALOG_PIN PB4
#define TRIGGER_THRESHHOLD 30

int lightningVal;

void setup()
{
  pinMode(SHUTTER_PIN, OUTPUT);
  digitalWrite(SHUTTER_PIN, LOW);


  lightningVal = analogRead(LIGHTNING_TRIGGER_ANALOG_PIN);
}

void loop()
{
  int cmd,
  int newLightningVal = analogRead(LIGHTNING_TRIGGER_ANALOG_PIN);

    
  if (abs(newLightningVal - lightningVal) > TRIGGER_THRESHHOLD)
  {
    digitalWrite(SHUTTER_PIN, HIGH);
    delay(1000);
    digitalWrite(SHUTTER_PIN, LOW);
    vorshutter();
  }

  lightningVal = newLightningVal;
}

void vorshutter(){
  delay(500);
  digitalWrite(SHUTTER_PIN, HIGH);
    delay(500);
    digitalWrite(SHUTTER_PIN, LOW);}

Greez
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  BME280 wird nicht erkannt sowerum 14 193 Gestern 22:14
Letzter Beitrag: Tommy56
  Echtzeituhrmodul läuft nicht scritch 21 533 30.11.2017 10:44
Letzter Beitrag: Tommy56
  Bootloader lässt sich nicht brennen?? dobermann145 10 500 21.11.2017 22:58
Letzter Beitrag: hotsystems
Sad Nano - nicht genug Speicher torsten_156 10 618 30.10.2017 21:40
Letzter Beitrag: MicroBahner
  Code wird langsamer mit der Laufzeit Wampo 9 570 05.10.2017 11:32
Letzter Beitrag: SkobyMobil
Tongue Visual Studio Code als Editor für die Entwicklung von Arduino Code Klaus(i) 1 347 03.09.2017 19:15
Letzter Beitrag: Mathias
  NeoPixels: Sketch will nicht - Problem mit delay? Zabsi 5 480 22.08.2017 15:17
Letzter Beitrag: Tommy56
  BME280 - Luftdruckoffset nicht einstellbar ? Stargazer 17 1.268 13.08.2017 15:38
Letzter Beitrag: hotsystems
  Ich komme mit millis nicht weiter !!! Gonmaus 8 932 09.07.2017 21:24
Letzter Beitrag: Tommy56
  Volume Up falscher Tastatur Hex-Code Maxi290997 7 599 03.07.2017 21:49
Letzter Beitrag: Maxi290997

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste