INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
AtTiny85 spielt Code nicht ab?!?
05.08.2014, 17:50
Beitrag #1
AtTiny85 spielt Code nicht ab?!?
Hy,

kann mir jemand sagen warum der unten stehende Code auf einem AtTiny85(interne 1MHz Clock) nicht funktioniert?? Programmiert über ISP Arduino, Chip ist geflashed, Bootloader installiert!! Habe blink ausprobiert und ein paar andere Standarts die laufen.

Code:
#define SHUTTER_PIN PB2
#define LIGHTNING_TRIGGER_ANALOG_PIN PB4
#define TRIGGER_THRESHHOLD 30

int lightningVal;

void setup()
{
  pinMode(SHUTTER_PIN, OUTPUT);
  digitalWrite(SHUTTER_PIN, LOW);


  lightningVal = analogRead(LIGHTNING_TRIGGER_ANALOG_PIN);
}

void loop()
{
  int cmd,
  int newLightningVal = analogRead(LIGHTNING_TRIGGER_ANALOG_PIN);

    
  if (abs(newLightningVal - lightningVal) > TRIGGER_THRESHHOLD)
  {
    digitalWrite(SHUTTER_PIN, HIGH);
    delay(1000);
    digitalWrite(SHUTTER_PIN, LOW);
    vorshutter();
  }

  lightningVal = newLightningVal;
}

void vorshutter(){
  delay(500);
  digitalWrite(SHUTTER_PIN, HIGH);
    delay(500);
    digitalWrite(SHUTTER_PIN, LOW);}

Greez
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  BME280 - Luftdruckoffset nicht einstellbar ? Stargazer 17 469 13.08.2017 15:38
Letzter Beitrag: hotsystems
  Ich komme mit millis nicht weiter !!! Gonmaus 8 515 09.07.2017 21:24
Letzter Beitrag: Tommy56
  Volume Up falscher Tastatur Hex-Code Maxi290997 7 412 03.07.2017 21:49
Letzter Beitrag: Maxi290997
  delay(...) im Code ok? donut 4 318 08.06.2017 20:16
Letzter Beitrag: donut
  WEMOS Motorshield funzt nicht Rumpl-X 8 358 07.06.2017 21:10
Letzter Beitrag: Tommy56
  Textdokument in Arduino Code umwandeln Tellen 9 478 03.06.2017 16:30
Letzter Beitrag: Tellen
  LCD geht nicht - keine Ahnung warum?? DL1AKP 12 643 15.05.2017 13:17
Letzter Beitrag: DL1AKP
  433mHz Funkmodule senden/empfangen nicht metzgefa 2 581 06.05.2017 13:30
Letzter Beitrag: metzgefa
  TFT Pixel to Code oOSpikeOo 5 342 06.04.2017 18:49
Letzter Beitrag: Tommy56
  SD Karte wird nicht erkannt Maxi290997 6 348 31.03.2017 06:05
Letzter Beitrag: Bitklopfer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste