INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino mega 2560 mit TFT LCD Touch Shield V1
29.07.2016, 16:56
Beitrag #1
Arduino mega 2560 mit TFT LCD Touch Shield V1
Hallo Leute hab da ein kleines Problem und zwar bekomme ich wenn ich das Display an mein Arduino Mega anschließe keine Grafik Angezeigt wenn ich mein Uno nehme funkioniert es das ist mein Code

#include <UTFT.h>
#include <URTouch.h>

UTFT myGLCD(ITDB28 ,19,18,17,16);
URTouch myTouch(15, 10, 14, 8, 9 );
extern uint8_t SmallFont[];



void setup() {
myGLCD.InitLCD();
myTouch.InitTouch();
myTouch.InitTouch();
myGLCD.clrScr();
myGLCD.clrScr();
myGLCD.setFont(SmallFont);

}

void loop() {

myGLCD.setColor(255, 0, 0);
myGLCD.drawLine(5, 19, 89, 19);
myGLCD.drawLine(89, 69, 89, 19);
myGLCD.drawLine(5, 69, 89, 69);
myGLCD.drawLine(5, 69, 5, 19);
myGLCD.drawLine(25, 18, 15, 18);
myGLCD.drawLine(25, 17, 15, 17);
myGLCD.drawLine(25, 16, 15, 16);
myGLCD.drawLine(68, 18, 78, 18);
myGLCD.drawLine(68, 17, 78, 17);
myGLCD.drawLine(68, 16, 78, 16);
myGLCD.drawLine(13, 35, 28, 35);
myGLCD.drawLine(13, 34, 28, 34);
myGLCD.drawLine(63, 35, 78, 35);
myGLCD.drawLine(63, 34, 78, 34);
myGLCD.drawLine(70, 43, 70, 27);
myGLCD.drawLine(71, 43, 71, 27);

delay(500);



myGLCD.setColor(0, 0, 0);
myGLCD.drawLine(5, 19, 89, 19);
myGLCD.drawLine(89, 69, 89, 19);
myGLCD.drawLine(5, 69, 89, 69);
myGLCD.drawLine(5, 69, 5, 19);
myGLCD.drawLine(25, 18, 15, 18);
myGLCD.drawLine(25, 17, 15, 17);
myGLCD.drawLine(25, 16, 15, 16);
myGLCD.drawLine(68, 18, 78, 18);
myGLCD.drawLine(68, 17, 78, 17);
myGLCD.drawLine(68, 16, 78, 16);
myGLCD.drawLine(13, 35, 28, 35);
myGLCD.drawLine(13, 34, 28, 34);
myGLCD.drawLine(63, 35, 78, 35);
myGLCD.drawLine(63, 34, 78, 34);
myGLCD.drawLine(70, 43, 70, 27);
myGLCD.drawLine(71, 43, 71, 27);
delay(500);
}
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.08.2016, 00:47
Beitrag #2
RE: Arduino mega 2560 mit TFT LCD Touch Shield V1
Hallo,
hast ne´n Link zu dem "TFT LCD Touch Shield V1 "
Mal die Pin´s des UNO und Mega 2560 R3 verglichen?
Gruß und Spaß
Andreas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.08.2016, 18:00
Beitrag #3
RE: Arduino mega 2560 mit TFT LCD Touch Shield V1
(01.08.2016 00:47)SkobyMobil schrieb:  Hallo,
hast ne´n Link zu dem "TFT LCD Touch Shield V1 "
Mal die Pin´s des UNO und Mega 2560 R3 verglichen?
Gruß und Spaß
Andreas

Hallo das ist mein Display:
http://wiki.iteadstudio.com/2.4_TFT_LCD_Touch_shield

Mfg
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.08.2016, 18:59
Beitrag #4
RE: Arduino mega 2560 mit TFT LCD Touch Shield V1
(01.08.2016 18:27)Lötzinnerhitzer schrieb:  die SPI-Pins liegen beim Mega anders
(siehe z.B.:https://arduino-info.wikispaces.com/MegaQuickRef )

Edit: bitte keine PN's - Belegung ist im Link zu finden
oder google mit "Arduino Mega 2560 SPI pinout" füttern
http://www.gidf.de

Hab soeben die Pins des Mega ausprobiert funkioniert leider nicht
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.08.2016, 19:14
Beitrag #5
RE: Arduino mega 2560 mit TFT LCD Touch Shield V1
(01.08.2016 18:59)Clemens55555 schrieb:  Hab soeben die Pins des Mega ausprobiert funkioniert leider nicht

Dann zeig uns doch mal wie du SPI am Mega angeschlossen hast.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.08.2016, 19:17
Beitrag #6
RE: Arduino mega 2560 mit TFT LCD Touch Shield V1
(01.08.2016 19:14)hotsystems schrieb:  
(01.08.2016 18:59)Clemens55555 schrieb:  Hab soeben die Pins des Mega ausprobiert funkioniert leider nicht

Dann zeig uns doch mal wie du SPI am Mega angeschlossen hast.

ich glaube der Display ist nicht SPI fähig
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.08.2016, 19:39
Beitrag #7
RE: Arduino mega 2560 mit TFT LCD Touch Shield V1
Hallo Clemens55555,
gehe mal in die Datei libraries\UTFT\hardware\avr\HW_AVR_defines.h und entkommentiere die Zeile
Code:
#define USE_UNO_SHIELD_ON_MEGA 1
Danach neu compilieren.
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.08.2016, 20:13
Beitrag #8
RE: Arduino mega 2560 mit TFT LCD Touch Shield V1
(01.08.2016 19:39)rkuehle schrieb:  Hallo Clemens55555,
gehe mal in die Datei libraries\UTFT\hardware\avr\HW_AVR_defines.h und entkommentiere die Zeile
Code:
#define USE_UNO_SHIELD_ON_MEGA 1
Danach neu compilieren.
Grüße Ricardo

Dumm gefragt wie kann ich die Zeile entkommentieren und wird der Display wieder so angeschlossen wie beim UNO?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Treiberprobleme Arduino Mega 2560 DonAthello 8 196 Gestern 18:38
Letzter Beitrag: Tommy56
  Firmata (Daten senden an den Arduino und empfangen vom Arduino) comfan 6 690 29.04.2017 14:29
Letzter Beitrag: hotsystems
  Programmierung von PCa9685 Shield im Bezug auf Arduinos Crazydiver 5 247 10.04.2017 12:20
Letzter Beitrag: hotsystems
  Can-Bus Shield ok, aber keine Daten Clubsport 54 3.613 02.04.2017 22:28
Letzter Beitrag: Bitklopfer
  Keypad Shield luj1990 11 430 29.03.2017 21:15
Letzter Beitrag: Tommy56
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 16 705 26.03.2017 14:15
Letzter Beitrag: oOSpikeOo
  tft.touch screen david 4 267 20.03.2017 12:58
Letzter Beitrag: hotsystems
  Mega 2560 und deren RX/TX alpenpower 17 3.822 06.03.2017 13:25
Letzter Beitrag: Franz54
  Einstieg Arduino Mega Markus0815 14 935 08.01.2017 13:40
Letzter Beitrag: Tommy56
  [Gelöst] SD Card (Ethernet Shield) IO funktioniert nicht __jb__ 7 663 05.01.2017 09:51
Letzter Beitrag: rpt007

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste