INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino Uno will nicht mehr
13.01.2021, 21:41 (Dieser Beitrag wurde zuletzt bearbeitet: 21.01.2021 10:13 von Bitklopfer.)
Beitrag #1
Arduino Uno will nicht mehr
Hallo,
woran kann es liegen?
Mein Arduino nimmt kein (auch kein einzeiliges) Programm mehr an. Die IDE reagiert ganz normal, meldet Kompilieren, Hochladen, Hochladen abgeschlossen.
Am seriellen Monitor zeigt sich nichts.
Wenn ich die RESET-Taste drücke, sehe ich am Monitor, dass das alte Prg. im Speicher abläuft mit entsprechenden Ausgaben.
"ON" LED ist an, LED "L" blinkt nach RESET einige Male.
Die CH340-Schnittstelle ist in der WIN-Systemseuerung korrekt installiert.
Der Arduino wird über das USB-Kabel versorgt. Anderes USB-Kabel hilft nicht weiter.
Was kann das sein?
Gruss, wonk
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
13.01.2021, 21:45
Beitrag #2
RE: Arduino uno will nicht mehr
Bei der Fehlerbeschreibung kann man nur raten/würfeln:
CH340 Treiber deinstallieren, IDE deinstallieren, beides neu installieren.
Wenn das nicht hilft, anderen Arduino testen, evtl. ist der jetzige gestorben.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
13.01.2021, 22:26
Beitrag #3
RE: Arduino uno will nicht mehr
Hallo,

kann es sein, dass Du immer was anders hochlädst als Du denkst? (Ist mir schon passiert!)

Beim Hochladen ist in der IDE als Standard das "Verify" eingeschaltet, nach dem Hochladen wird das Programm wieder aus dem Flash ausgelesen und mit der PC-Version verglichen. Wenn das stimmt, dann kann eigentlich nichts schief gegangen sein, sonst gibt es eine Fehlermeldung.

Siehe sicherheitshalber mal nach, ob das "Verify" eingeschaltet ist. (Bei sehr großen Programmen muss man es ausschalten, sonst gibt es beim Hochladen ein Time-out.)

Gruß
GuaAck
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.01.2021, 08:48
Beitrag #4
RE: Arduino uno will nicht mehr
Du solltest in den Einstellungen der IDE auch die "Fehlermeldungen anzeigen" anhaken. Da siehst du dann mehr Informationen.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.01.2021, 17:00
Beitrag #5
RE: Arduino uno will nicht mehr
Hallo,
Vielend Dank für Eure Hinweise, aber sie helfen alle nicht weiter.
Er tut es jetzt "manchmal" wieder, ich kann den Fehler nocht nicht richtig reproduzieren. Deshalb eine Frage:
Ich lassen ein einfaches Prog laufen, z.B. Lesen eines analogen Abschlusses und Ausgabe auf dem seriellen Monitor ohne irgendeinen Pin bestückt zu haben.
Wenn ich USB abziehe und wieder anstecke, läuft das Programm MANCHMAL nicht wieder an, zumindestens nicht die Ausgabe auf dem seriellen Monitor. Auch ein RESET hilft dann nicht. Wenn ich dasselbe Prog neu hochlade funktioniert die serielle Ausgabe aber wieder.
Ist das so normal?
Gruss, wonk
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.01.2021, 18:01
Beitrag #6
RE: Arduino uno will nicht mehr
Normal ist das nicht. Welchen Arduino hast Du? (Mein MKRZero hat auch ein Problem mit dem seriellen Monitor, das ist aber bei dem normal und zu erklären.)

Gruß
GuaAck
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.01.2021, 18:45 (Dieser Beitrag wurde zuletzt bearbeitet: 14.01.2021 18:48 von hotsystems.)
Beitrag #7
RE: Arduino uno will nicht mehr
(14.01.2021 17:00)wonk schrieb:  Ist das so normal?

Ja, klar.....wenn du immer alle geheim hältst, wie sollen wir dann dein Problem lösen ?
Was für ein Board hast du ?
Ein Arduino ist es sicher nicht.
Was hast du angeschlossen ?
Was hast du jetzt für einen Sketch drauf ?

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.01.2021, 22:53
Beitrag #8
RE: Arduino uno will nicht mehr
Hallo!
Wie gesagt, die in den beiträgen #2-#4 gemachten Vorschläge änderten nichts.
Es ist ein Arduino uno.
Das Problem tritt mit allen Progs auf, auch mit so einem einfachen wie diesem:
Code:
void setup() {
  pinMode(A0, INPUT_PULLUP);
  Serial.begin(9600);
}

void loop() {
  int sensorValue = analogRead(A0);
  float voltage = sensorValue * (5.0 / 1023.0);
  Serial.println(voltage);
}
Wie ich schon geschrieben hatte, ist beim Programmlauf NICHTS angeschlossen (liefert natürlich immer 5.0), wenn es läuft.
Gruss, wonk
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  2 I2C-Devices nicht zusammen wonk 36 1.591 04.03.2021 00:08
Letzter Beitrag: hotsystems
  Schieberegister funktioniert nicht richtig flint74 9 704 21.02.2021 13:35
Letzter Beitrag: flint74
  Warum sind mehrere Attiny´s nicht Synchron ? Chris_Arduino 6 2.159 02.02.2021 11:46
Letzter Beitrag: Harry
  RFID keine Daten / wird nicht erkannt Wochenendprogrammierer 79 7.316 27.12.2020 19:20
Letzter Beitrag: Wochenendprogrammierer
  Ausgabe LCD-Display funktioniert nicht wonk 6 1.113 23.12.2020 21:15
Letzter Beitrag: hotsystems
  Schrittmotor bewegt sich nicht DerMaschbaustudent 79 10.302 01.12.2020 22:08
Letzter Beitrag: MicroBahner
  Neopixel - LEDS leuchten obwohl sie es nicht sollten Mauser 72 7.285 01.12.2020 10:00
Letzter Beitrag: hotsystems
  Seltsames Zackenmuster, wenn Poti nicht bewegt wird. . Guekard 9 2.198 26.11.2020 08:40
Letzter Beitrag: hotsystems
  Spannungsversorgung Wemos 5V über Regler oder nicht?? DO3GE 23 4.522 21.10.2020 06:02
Letzter Beitrag: DO3GE
Question [ATmega168PA]Programmierung bisher nicht gelungen ManniP 32 5.014 24.09.2020 17:39
Letzter Beitrag: Chopp

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste