INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino + SRF02 Entfernungsmesser Problem
22.11.2013, 11:44 (Dieser Beitrag wurde zuletzt bearbeitet: 23.11.2013 10:18 von rkuehle.)
Beitrag #9
RE: Arduino + SRF02 Entfernungsmesser Problem
Hallo rik1234,

in der Beschreibung für den Sensor steht folgendes:
Zitat:•Minimum range approx 15cm
•Maximun Range approx 2.5m
Damit erklärt sich das Verhalten des Sensors.

Ich glaube der HC-SR04 http://www.robodino.de/2011/12/ultrascha...-sr04.html ist für die kleinen Distanzen besser geeignet.

Grüße Ricardo
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.11.2013, 12:29
Beitrag #10
RE: Arduino + SRF02 Entfernungsmesser Problem
Peinlich peinlich,

wenn man nicht lesen kann Wink Ok alles klar vielen Dank. Das erklärt warum bei rund 15 cm nur Datenmüll heraus kommt. Smile


(22.11.2013 11:44)rkuehle schrieb:  Hallo rik1234,

in der Beschreibung für den Sensor steht folgendes:
Zitat:•Minimum range approx 15cm
•Maximun Range approx 2.5m
Damit erklärt sich das Verhalten des Sensors.

Ich glaube der HC-SR04 http://www.robodino.de/2011/12/ultrascha...-sr04.html ist für die kleinen Distanzen besser geeignet.

Grüße Ricardo
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
27.12.2013, 13:36
Beitrag #11
RE: Arduino + SRF02 Entfernungsmesser Problem
Hallo Leute,

ich hoffe ihr habt schöne Weihnachten gehabt Smile

Leider habe ich ein erneutes Problem, was sehr ähnlich ist.
Ich will jetzt 2 Sensoren gleichzeitig laufen lassen.
Dazu habe ich nun den 2. erst einmal eigenständig in Betrieb genommen.
Mein 1. Ergebnis war eine Distanz von -2 cm.
Daraufhin habe ich mich an diesen Beitrag erinnert und den I2C Scanner verwendet.
Dabei kam heraus, dass ich die Adresse anpassen muss von 0x79 auf 0x70. Allerdings werden mir nun 0cm angezeigt.
Ich habe folgenden Code verwendet:

Code:
    #include <Wire.h>
    

    void setup()
    {
    
      Wire.begin();                // join i2c bus (address optional for master)
      Serial.begin(9600);          // start serial communication at 9600bps
      Serial.println("Arduino SRF02 Ultrasonic range finder \n ---------------------------------------");
      delay(2000);
    }
    
    int reading = 0;
    
    void loop()
    {
      // step 1: instruct sensor to read echoes
      Wire.beginTransmission(112); // transmit to device #112 (0x70)
      // the address specified in the datasheet is 224 (0xE0)
      // but i2c adressing uses the high 7 bits so it's 112
      Wire.write(byte(0x00));      // sets register pointer to the command register (0x00)  
      Wire.write(byte(0x51));      // command sensor to measure in "inches" (0x50)
      // use 0x51 for centimeters
      // use 0x52 for ping microseconds
      Wire.endTransmission();      // stop transmitting
    
      // step 2: wait for readings to happen
      delay(70);                   // datasheet suggests at least 65 milliseconds
    
      // step 3: instruct sensor to return a particular echo reading
      Wire.beginTransmission(112); // transmit to device #112
      Wire.write(byte(0x02));      // sets register pointer to echo #1 register (0x02)
      Wire.endTransmission();      // stop transmitting
    
      // step 4: request reading from sensor
      Wire.requestFrom(121, 2);    // request 2 bytes from slave device #112
    
        // step 5: receive reading from sensor
      if(2 <= Wire.available())    // if two bytes were received
      {
        reading = Wire.read();  // receive high byte (overwrites previous reading)
        reading = reading << 8;    // shift high byte to be high 8 bits
        reading |= Wire.read(); // receive low byte as lower 8 bits
        //    Serial.println(reading);   // print the reading
      }
//      if(reading >= 100){            // over 100 cm
//        Serial.println("Target out of Range.");
//      }
//      else{                          // below 100  cm
        Serial.print("Target in Range! (");
        Serial.print(reading);       // print distance
        Serial.println("cm)");
      
      
     // }
    
      delay(250);                  // wait a bit since people have to read the output :)
    }

Weiß jemand woran das jetzt noch liegen kann mit 0cm?
Schonmal vielen Dank im Voraus Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 5 101 Gestern 22:58
Letzter Beitrag: Tommy56
  ESP8622 - 01 sendet UDP - Problem WLan Kriskind 37 2.470 14.03.2017 19:49
Letzter Beitrag: Tommy56
  Smart Home Webserver Basic Authentication Problem Osotastic 21 556 20.02.2017 18:00
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 445 31.01.2017 20:41
Letzter Beitrag: Tommy56
  Beim Hochladen USB Problem Nils 10 642 29.12.2016 21:05
Letzter Beitrag: renid55
  Problem mit SD Card Library BennIY 4 395 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 320 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 1.140 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 667 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 961 13.06.2016 21:14
Letzter Beitrag: torsten_156

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste