INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino Nano von IC_Station unter Windows 8.1, USB-Probleme
01.03.2015, 12:42
Beitrag #1
Arduino Nano von IC_Station unter Windows 8.1, USB-Probleme
Ich habe mir bei IC_Station 2 Nanos bestellt. Die Schnittstelle wird über FTDI-Chip USB to RS232 gemacht. Diese Chips sind ja leider dafür bekannt, dass es illegale Chinakopien davon gibt. Anfänglich funktionierten beide Nanos problemlos an 2 verschiedenen COM: -Ports. Einen Tag später wurden aber beide nicht mehr richtig erkannt und eine wahre Odyssee begann. Ich musste zwischenzeitlich sogar ein Backup meines PC's zurücklesen weil der mit einem Treiberfehler im Bootloop fest hing!

Ich habe den ganzen Nachmittag damit verbracht das Problem zu lösen:

Damit ihr keine Probleme damit bekommt unter Windows 8.1 müsst ihr die automatische Treiberinstallation abstellen. Danach alle alten FTDI-Treiber löschen und auch bereits reservierte COM.-Ports. Danach den Nano anstecken und folgendes Schritt für Schritt durchführen:

1. download and install "cdm v2.08.30 whql certified", Achtung: keine neueren Treiber verwenden!
2. In Device Manager right click the problematic “FT232R” icon and click “Properties”
3. Under “Driver”, click “Update Driver”
4. Click “browse my computer for driver software”
5. Click “Let me pick…”
6. Click “Have Disk”
7. Browse to location of new drivers and click “ftdibus.inf” and press “Open” and then “OK”
8. Assign this to “USB Serial Controller” and click “Next”
Then click “Close”
9. Back in Device Manager, you will see that the “FT232R” is now replaced with “USB Serial Controller”
10. Right click “USB Serial Controller” and click “Properties”
11. Under “Driver”, click “Update Driver”
12. Click “browse my computer for driver software”
13. Click “Let me pick…”
14. Click “Have Disk”
15. Browse to location and click “ftdiport.inf” and press “Open” and “OK”
16. Assign this to “USB Serial Port” and click “Next”
17. Then click “Close”

Es kann auch sein, dass die ID der USB Chips vom aktuellen Treiber mit 0000 überschrieben wurde um diese unbrauchbar zu machen. Dafür gibt es ein Tool bei FTDI zum flashen der ID: FTDI_FT-Prog. Damit kann wieder die richtige Nummer 6001 geflasht werden.

Achtung: sollen mehrere Nanos betrieben werden müssen die an verschiedenen USB-Anschlüssen verbunden werden (warum auch immer) sonst ist die Erkennung wieder futsch und alles beginnt von vorn! (auch mit dem alten Treiber, jedenfalls unter Windows 8.1)

hier der Link zu den Nanos:

http://www.icstation.com/icstation-atmeg...-3483.html

Wenn der IC raucht wird viel Strom verbraucht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.03.2015, 14:30
Beitrag #2
RE: Arduino Nano von IC_Station unter Windows 8.1, USB-Probleme
Hallo,
soweit ich das mitbekommen habe hat FTDI diesen schädlichen Treiber wieder zurückgezogen. Mit dem was aktuell bei FTDI zum runterladen gibt müßte es also wieder funktionieren.
Wie das aber aussieht wenn die ID schon auf 0000 steht kann ich mangels Erfahrung nicht sagen. Aber das Problem ist hier glaube ich auch schon mal durchgekaut worden.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.03.2015, 14:32 (Dieser Beitrag wurde zuletzt bearbeitet: 01.03.2015 14:33 von René Hitz.)
Beitrag #3
RE: Arduino Nano von IC_Station unter Windows 8.1, USB-Probleme
(01.03.2015 14:30)Bitklopfer schrieb:  Hallo,
soweit ich das mitbekommen habe hat FTDI diesen schädlichen Treiber wieder zurückgezogen. Mit dem was aktuell bei FTDI zum runterladen gibt müßte es also wieder funktionieren.
Wie das aber aussieht wenn die ID schon auf 0000 steht kann ich mangels Erfahrung nicht sagen. Aber das Problem ist hier glaube ich auch schon mal durchgekaut worden.
lg
bk

Stimmt leider nicht. Mit dem aktuellen Treiber werden die Chips sofort wieder kaputt gemacht (ID auf 0000 gesetzt), daher meine Anleitung im Forum. Vielleicht bettriff das ja nur Windows 8.1, 64Bit?

Wenn der IC raucht wird viel Strom verbraucht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.03.2015, 14:51
Beitrag #4
RE: Arduino Nano von IC_Station unter Windows 8.1, USB-Probleme
(01.03.2015 14:32)René Hitz schrieb:  
(01.03.2015 14:30)Bitklopfer schrieb:  Hallo,
soweit ich das mitbekommen habe hat FTDI diesen schädlichen Treiber wieder zurückgezogen. Mit dem was aktuell bei FTDI zum runterladen gibt müßte es also wieder funktionieren.
Wie das aber aussieht wenn die ID schon auf 0000 steht kann ich mangels Erfahrung nicht sagen. Aber das Problem ist hier glaube ich auch schon mal durchgekaut worden.
lg
bk

Stimmt leider nicht. Mit dem aktuellen Treiber werden die Chips sofort wieder kaputt gemacht (ID auf 0000 gesetzt), daher meine Anleitung im Forum. Vielleicht bettriff das ja nur Windows 8.1, 64Bit?

hmmm.... also hier ein Artikel vom Heise Verlag.
Wie das nun Real aussieht weiß ich auch nicht, ich hatte noch keine USB Treiberprobleme. Habe hier auch keine Nano's im Einsatz.

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Micro - Probleme madin 30 468 Gestern 21:35
Letzter Beitrag: Tommy56
  Gemeinsame Spannungsversorgung für Arduino Nano und WS2812b and1 11 202 09.12.2016 17:38
Letzter Beitrag: georg01
  Probleme mit dem FTDI-Chip Harry Hirsch 6 150 08.12.2016 19:08
Letzter Beitrag: René Hitz
  Ardunio Nano 3,3V Mathias 5 132 24.11.2016 22:38
Letzter Beitrag: Tommy56
  Probleme mit ESP8266 BennIY 6 233 20.11.2016 14:49
Letzter Beitrag: BennIY
  Arduino NANO mit zwei 1.8 SPI-tfts Thandor 2 107 15.11.2016 23:18
Letzter Beitrag: Thandor
  Probleme mit mehreren DS18B20 Fühlern Uwa 12 333 15.10.2016 15:26
Letzter Beitrag: ardu_arne
  Arduino Nano - VIN Mathias 16 702 22.09.2016 21:39
Letzter Beitrag: ardu_arne
  Arduino Nano und SD Card emjott 3 336 09.09.2016 12:15
Letzter Beitrag: Bitklopfer
  Probleme mit SIM900 GSM seit PinManagment test BennIY 0 179 31.07.2016 23:33
Letzter Beitrag: BennIY

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste