INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 1 Bewertungen - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino Nano keine Verbindung zu nRF24L01 Modul
25.11.2019, 16:37
Beitrag #1
Arduino Nano keine Verbindung zu nRF24L01 Modul
Guten Mittag,

Ich bin seit einiger Zeit mit einem Arduino Projekt für die Schule beschäftigt, jedoch komme ich einfach nicht weiter... Es wäre super, wenn mir jemand helfen könnte.

Also grob gesagt, baue ich ein Ferngesteuertes Auto auf Arduino Ebene.
Als Wireless Modul habe ich das nRF24L01 gewählt, jedoch schaffe ich es weder zwei Module kommunizieren zu lassen, noch überhaupt eine Verbindung vom Nano zum Modul herzustellen. Ich habe alles ausprobiert, was nur möglich ist und es klappt immer noch nicht.
Der Code zum prüfen, ob eine Verbindung vom Nano zum nRF24L01 besteht:
Code:
#include <SPI.h>
#include <RF24.h>
#include <nRF24l01.h>
RF24 radio(5,6);

void setup(void) {
  Serial.begin(9600);
  delay(100);

  radio.begin();
  bool result = radio.isChipConnected();

  Serial.println(result);
}
void loop(){
  
}

Die Ausgabe ist immer 0. Ich habe etliche male alles neu angeschlossen, ein anders Modul oder einen anderen Nano genommen...nichts hat geklappt...

Über Hilfe würde ich mich daher sehr freuen!
LG Jonas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.11.2019, 22:50
Beitrag #2
RE: Arduino Nano keine Verbindung zu nRF24L01 Modul
Zeige doch mal ein Schaltbild, wie du den Nano mit dem nRF24l01 verbunden hast.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.11.2019, 16:30
Beitrag #3
RE: Arduino Nano keine Verbindung zu nRF24L01 Modul
Ich habe das Modul so angeschlossen:

LG Jonas


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.11.2019, 16:59
Beitrag #4
RE: Arduino Nano keine Verbindung zu nRF24L01 Modul
(26.11.2019 16:30)Jonaz2 schrieb:  Ich habe das Modul so angeschlossen:

LG Jonas
Das kann so auch nicht funktionieren.
Du musst schon den SPI-Bus am Nano verwenden.
Sieh dir mal die Beispielschaltungen dazu im Web an.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.11.2019, 19:37
Beitrag #5
RE: Arduino Nano keine Verbindung zu nRF24L01 Modul
Danke, ich dachte bis jetzt immer, das die drei letzten Pins überall angeschlossen werden können. Habe jetzt mehrere SPI Schaltungen aus dem Internet getesten. z.B.: https://www.google.com/search?rlz=1C1CHB...makTjrw7M:

Allerdings ist die Ausgabe immernoch 0...

Gruß Jonas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.11.2019, 20:25
Beitrag #6
RE: Arduino Nano keine Verbindung zu nRF24L01 Modul
Das hilft dir so auch nicht weiter und wir wissen nicht, was nun stimmt.
Im Sketch verwendest du Pin5 und 6, in der letzten Darstellung Pin7 und 8.

Was stimmt denn da jetzt ?

Wenn du etwas änderst, solltest du auch den Sketch anpassen und auch hier zeigen.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.11.2019, 20:48 (Dieser Beitrag wurde zuletzt bearbeitet: 26.11.2019 20:49 von Jonaz2.)
Beitrag #7
RE: Arduino Nano keine Verbindung zu nRF24L01 Modul
Das ist das Sketch was ich mit der SPI Schaltung benutzt habe:

Code:
#include <SPI.h>
#include <RF24.h>
#include <nRF24l01.h>
RF24 radio(7,8);

void setup(void) {
  Serial.begin(9600);
  delay(100);

  radio.begin();
  bool result = radio.isChipConnected();

  Serial.println(result);
}
void loop(){
  
}
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.11.2019, 21:15
Beitrag #8
RE: Arduino Nano keine Verbindung zu nRF24L01 Modul
Irgend etwas machst du noch falsch.
Da ich nicht auf deinen Arbeitsplatz sehen kann, ist meine Hilfe hier am Ende.

Du solltest einfach nochmal nach einem Tutorial den Aufbau anpassen.
Z.B. diesem hier.

Wenn du strikt danach vorgehst, muss es doch funktionieren.
Da ich mit den Transceivern bisher noch nichts gemacht habe, fällt mir auch nichts mehr ein.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Mega 2560 vs Arduino DUE Batucada 24 7.092 Gestern 15:46
Letzter Beitrag: Tommy56
  Arduino Nano Funktioniert nicht? acca500 7 1.418 10.05.2020 10:22
Letzter Beitrag: hotsystems
  Nano nur mit CH340 USB ?? Franz54 23 3.957 18.04.2020 21:16
Letzter Beitrag: Franz54
  Nano und 12Volt für Weichensteuerung Jan99 2 974 13.04.2020 12:30
Letzter Beitrag: hotsystems
  Analog Read messchwankung durch Bluetooth HC-05 Modul? GERGto 12 2.549 07.04.2020 13:38
Letzter Beitrag: GERGto
  Stand-alone-Nano an USB leuchtet nicht AnFi 5 1.050 23.03.2020 10:08
Letzter Beitrag: SOFTHARD
Photo der NANO will nicht sensor 8 1.951 02.03.2020 17:26
Letzter Beitrag: hotsystems
  Modul NFR24L01 arduino2108 6 1.297 23.02.2020 10:28
Letzter Beitrag: arduino2108
  Stromversorgung Nano + Servos turold 13 2.553 04.02.2020 23:40
Letzter Beitrag: Chopp
  Sketch auf Arduino Nano laden berny46 5 1.543 05.01.2020 11:05
Letzter Beitrag: berny46

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste